More extra packages

This commit is contained in:
Mike Staszel 2010-02-15 02:49:03 -06:00
parent 94fd8cb7f7
commit 0004b8cb2f
10 changed files with 195 additions and 1 deletions

View file

@ -3,11 +3,12 @@
pkgbase=gcc
pkgname=('gcc' 'gcc-libs')
pkgver=4.4.3
pkgrel=1
pkgrel=2
pkgdesc='The GNU Compiler Collection'
arch=(arm)
license=(GPL LGPL custom)
url='http://gcc.gnu.org'
groups=('base-devel')
makedepends=(flex 'gcc>=3.4' 'gawk>=3.1.5' 'make>=3.80')
source=(http://gcc-uk.internet.bs/releases/gcc-$pkgver/gcc-{core,g++,fortran,objc}-$pkgver.tar.bz2)
md5sums=('054b66f315b3d04ad06544ce26e72365'

23
core/yaourt/PKGBUILD Normal file
View file

@ -0,0 +1,23 @@
# Author: Julien MISCHKOWITZ <wain@archlinux.fr>
pkgname=yaourt
pkgver=0.9.2.6
pkgrel=1
pkgdesc="A Pacman frontend with more features and AUR support"
arch=(i686 x86_64 ppc arm)
url="http://www.archlinux.fr/yaourt-en/"
license="GPL"
depends=('wget' 'diffutils' 'pacman>=3.2.0')
makedepends=('gettext')
optdepends=('aurvote: vote for favorite packages from AUR for inclusion in [community]'
'customizepkg: automatically modify PKGUILD during install/upgrade'
'pacman-color: fully colorized output'
'colordiff: colorized output with yaourt -C')
install=yaourt.install
backup=('etc/yaourtrc')
source=(http://archiwain.free.fr/os/i686/$pkgname/$pkgname-$pkgver.src.tar.gz)
md5sums=('188fecb7c7401287cca6028ab3f2de6f')
build() {
cd $startdir/src/$pkgname-$pkgver
make install DESTDIR=$pkgdir || return 1
}

26
extra/faac/PKGBUILD Normal file
View file

@ -0,0 +1,26 @@
# Maintainer: Manuel Rotter <rotter.manuel@gmail.com>
pkgname=faac
pkgver=1.28
pkgrel=1
pkgdesc="FAAC is an AAC audio encoder."
arch=('arm')
url="http://www.audiocoding.com/"
license=('GPL' 'custom')
depends=('libmp4v2' 'glibc')
makedepends=('automake' 'autoconf' 'libtool')
options=('!libtool')
source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
md5sums=('80763728d392c7d789cde25614c878f6')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
find . -type f -print0 | xargs -0 sed -i 's/\r//g'
./bootstrap
./configure --prefix=/usr --with-mp4v2
make || return 1
make DESTDIR=${pkgdir} install
install -D -m644 ${srcdir}/${pkgname}-${pkgver}/libfaac/kiss_fft/COPYING \
${pkgdir}/usr/share/licenses/faac/COPYING.kiss_fft
}

22
extra/gd/PKGBUILD Normal file
View file

@ -0,0 +1,22 @@
# Maintainer: Eric Belanger <eric@archlinux.org>
pkgname=gd
pkgver=2.0.36RC1
pkgrel=3
pkgdesc="Library for the dynamic creation of images by programmers"
arch=('i686' 'x86_64')
url="http://www.libgd.org/"
license=('custom')
depends=('perl' 'libpng>=1.4.0' 'fontconfig' 'libjpeg>=8')
options=('!libtool')
source=(http://www.libgd.org/releases/${pkgname}-${pkgver}.tar.bz2 libpng14.patch)
md5sums=('e876979ca3130623a4e7866d9579171a'
'7921556f4960e8d66cf4fb67ea7101b5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i ${srcdir}/libpng14.patch || return 1
./configure --prefix=/usr --without-xpm || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING" || return 1
}

12
extra/gd/libpng14.patch Normal file
View file

@ -0,0 +1,12 @@
diff -Nur gd-2.0.36RC1.orig/gd_png.c gd-2.0.36RC1/gd_png.c
--- gd-2.0.36RC1.orig/gd_png.c 2007-11-27 10:30:34.000000000 +0200
+++ gd-2.0.36RC1/gd_png.c 2010-01-17 17:14:11.000000000 +0200
@@ -151,7 +151,7 @@
return NULL;
}
- if (!png_check_sig (sig, 8)) { /* bad signature */
+ if (png_sig_cmp (sig, 0, 8)) { /* bad signature */
return NULL; /* bad signature */
}

38
extra/gtk2/PKGBUILD Normal file
View file

@ -0,0 +1,38 @@
# Maintainer: Philipp Scholl <pscholl@bawue.de>
# From ArchMobile.org
pkgname=gtk2
pkgver=2.18.6
pkgrel=1
pkgdesc="The GTK+ Toolkit (v2)"
arch=(arm)
url="http://www.gtk.org/"
install=gtk2.install
depends=('atk>=1.28.0' 'pango>=1.26.0' 'libxcursor' 'libxinerama' 'libxrandr>=1.3.0' \
'libxi>=1.2.1' 'libcups>=1.4.2' 'libxcomposite' 'libxdamage' 'heimdal>=1.3.1' \
'gnutls>=2.8.3' 'shared-mime-info')
makedepends=('pkgconfig' 'gtk-doc')
replaces=('gtkprint-cups' 'gail')
conflicts=('gtkprint-cups' 'gail')
provides=('gail=1.22.3')
options=('!libtool' '!docs')
backup=(etc/gtk-2.0/gtkrc)
license=('LGPL')
source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/2.18/gtk+-${pkgver}.tar.bz2
xid-collision-debug.patch)
sha256sums=('67a83c6b2e774bc20b2a0582fb7fad7b1e8d5e04ede39f299d614e365756d2a7'
'd758bb93e59df15a4ea7732cf984d1c3c19dff67c94b957575efea132b8fe558')
build() {
cd "${srcdir}/gtk+-${pkgver}"
patch -Np1 -i "${srcdir}/xid-collision-debug.patch" || return 1
CXX=/bin/false ./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --with-xinput=yes \
--without-libjasper\
--with-included-loaders=png || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
echo 'gtk-fallback-icon-theme = "gnome"' > "${pkgdir}/etc/gtk-2.0/gtkrc" || return 1
}

13
extra/gtk2/gtk2.install Normal file
View file

@ -0,0 +1,13 @@
post_install() {
usr/bin/gtk-query-immodules-2.0 > etc/gtk-2.0/gtk.immodules
usr/bin/gdk-pixbuf-query-loaders > etc/gtk-2.0/gdk-pixbuf.loaders
}
post_upgrade() {
post_install
}
pre_remove() {
rm -f etc/gtk-2.0/gtk.immodules &>/dev/null
rm -f etc/gtk-2.0/gdk-pixbuf.loaders &>/dev/null
}

View file

@ -0,0 +1,11 @@
--- gtk+-2.18.2/gdk-pixbuf/io-jpeg.c.orig 2009-10-09 09:53:34.000000000 +0200
+++ gtk+-2.18.2/gdk-pixbuf/io-jpeg.c 2009-10-09 09:54:23.000000000 +0200
@@ -920,6 +920,8 @@
return FALSE;
}
}
+
+ cinfo->scale_num = 1;
for (cinfo->scale_denom = 2; cinfo->scale_denom <= 8; cinfo->scale_denom *= 2) {
jpeg_calc_output_dimensions (cinfo);

View file

@ -0,0 +1,15 @@
--- gtk+-2.18.3/gdk/x11/gdkxid.c 2009-06-19 04:59:18.000000000 +0200
+++ gtk+-2.18.3/gdk/x11/gdkxid.c.new 2009-07-22 11:30:12.000000000 +0200
@@ -56,10 +56,10 @@
if (!display_x11->xid_ht)
display_x11->xid_ht = g_hash_table_new ((GHashFunc) gdk_xid_hash,
(GEqualFunc) gdk_xid_equal);
-
+/*
if (g_hash_table_lookup (display_x11->xid_ht, xid))
g_warning ("XID collision, trouble ahead");
-
+*/
g_hash_table_insert (display_x11->xid_ht, xid, data);
}

33
extra/libmp4v2/PKGBUILD Normal file
View file

@ -0,0 +1,33 @@
# Maintainer: Mike Staszel <mikestaszel@plugboxlinux.org>
# From ArchMobile.org
pkgname=libmp4v2
pkgver=1.6
pkgrel=1
pkgdesc="MPEG-4 library and tools from mpeg4ip"
arch=('arm')
license=('custom')
url="http://mpeg4ip.sourceforge.net/"
depends=('gcc-libs')
options=('!libtool')
source=(http://downloads.sourceforge.net/sourceforge/mpeg4ip/mpeg4ip-${pkgver}.tar.gz)
md5sums=('004b481542e5aa9fdb455d9a1b640eff')
build() {
cd ${startdir}/src/mpeg4ip-${pkgver}
touch bootstrapped
echo "" > lib/rtp/configure
echo "" > lib/SDLAudio/configure
./configure --prefix=/usr || return 1
for dir in lib/gnu lib/mp4av lib/mp4v2; do
cd ${startdir}/src/mpeg4ip-${pkgver}/${dir}
make || return 1
make DESTDIR=${startdir}/pkg install || return 1
done
install -m644 ${startdir}/src/mpeg4ip-${pkgver}/include/mpeg4ip{,_version}.h ${startdir}/pkg/usr/include/ || return 1
install -m644 $startdir/src/mpeg4ip-$pkgver/mpeg4ip_config.h $startdir/pkg/usr/include/ || return 1
install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
install -m644 ${srcdir}/mpeg4ip-${pkgver}/COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}