mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
aur updates
This commit is contained in:
parent
2772de6d19
commit
00452949e1
18 changed files with 364 additions and 58 deletions
|
@ -2,7 +2,7 @@
|
|||
# Maintainer: Nathan Owe <ndowens.aur at gmail dot com>
|
||||
pkgname=flexget
|
||||
_pkgname=FlexGet
|
||||
pkgver=1.0r3214
|
||||
pkgver=1.0.3288
|
||||
pkgrel=2
|
||||
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.)"
|
||||
arch=(any)
|
||||
|
@ -10,13 +10,13 @@ url="http://flexget.com/"
|
|||
depends=('python2' 'python2-cherrypy' 'python2-progressbar' \
|
||||
'python2-pynzb' 'pyrss2gen' 'python2-sqlalchemy' 'python2-html5lib' \
|
||||
'python2-beautifulsoup4>=4.1' 'python2-beautifulsoup3>=3.2' 'python2-yaml' 'python2-feedparser'
|
||||
'python2-flask' 'python2-requests-0.14' 'python2-certifi>=0.0.7'
|
||||
'python2-flask' 'python2-requests' 'python2-certifi>=0.0.7'
|
||||
'python2-chardet>=1.0.0' 'python2-dateutil')
|
||||
optdepends=('pytransmissionrpc: Transmission support')
|
||||
makedepends=('python2-distribute')
|
||||
license=('MIT')
|
||||
#install=('flexget.install')
|
||||
source=("http://download.flexget.com/unstable/${_pkgname}-${pkgver}.tar.gz")
|
||||
source=("http://download.flexget.com/${_pkgname}-${pkgver}.tar.gz")
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${_pkgname}-${pkgver}"
|
||||
|
@ -29,4 +29,4 @@ package() {
|
|||
}
|
||||
|
||||
|
||||
md5sums=('60a6ca61dc34ba2d0cde44eb13cbca38')
|
||||
md5sums=('34e7032ac1d76a35bbfd31f6335ca138')
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# Maintainer: Padfoot <padfoot at exemail dot com dot au>
|
||||
|
||||
pkgname=lightdm-gtk-greeter
|
||||
pkgver=1.3.1
|
||||
pkgrel=1
|
||||
pkgver=1.5.0
|
||||
pkgrel=2
|
||||
pkgdesc="GTK+ greeter for LightDM"
|
||||
arch=('i686'
|
||||
'x86_64')
|
||||
|
@ -20,14 +20,19 @@ conflicts=('lightdm-gtk-greeter-osk'
|
|||
'lightdm-gtk-greeter-bzr')
|
||||
backup=('etc/lightdm/lightdm-gtk-greeter.conf')
|
||||
install='lightdm-gtk-greeter.install'
|
||||
source=("https://launchpad.net/$pkgname/1.4/$pkgver/+download/$pkgname-$pkgver.tar.gz"
|
||||
"lightdm-gtk-greeter.conf")
|
||||
md5sums=('f7e05d1057afb7728197f11c328d4ba2'
|
||||
'ca8634dfc2cc8a78546eaf27e95810f2')
|
||||
source=("https://launchpad.net/$pkgname/1.6/$pkgver/+download/$pkgname-$pkgver.tar.gz"
|
||||
"lightdm-gtk-greeter.conf"
|
||||
"lightdm-gtk-greeter.patch")
|
||||
md5sums=('226fbc12594cca01d5decabde1d42f2d'
|
||||
'76b48440baf59713304d6ea71ecdc325'
|
||||
'80555121f1f6b7b284308cb8122128fc')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
export AUTOMAKE=automake
|
||||
|
||||
patch -p1 -i $srcdir/lightdm-gtk-greeter.patch
|
||||
|
||||
./autogen.sh --prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--libexecdir=/usr/lib/lightdm \
|
||||
|
|
|
@ -4,7 +4,6 @@
|
|||
# theme-name = GTK+ theme to use
|
||||
# icon-theme-name = Icon theme to use
|
||||
# font-name = Font to use
|
||||
# cursor-name = Cursor theme to use
|
||||
# xft-antialias = Whether to antialias Xft fonts (true or false)
|
||||
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
|
||||
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
|
||||
|
@ -17,7 +16,6 @@ background=#000000
|
|||
theme-name=default
|
||||
icon-theme-name=default
|
||||
font-name=Sans Regular 11
|
||||
cursor-name=default
|
||||
xft-antialias=true
|
||||
xft-dpi=96
|
||||
xft-hintstyle=slight
|
||||
|
|
11
aur/lightdm-gtk-greeter/lightdm-gtk-greeter.patch
Normal file
11
aur/lightdm-gtk-greeter/lightdm-gtk-greeter.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -aur lightdm-gtk-greeter-1.5.0.src/src/lightdm-gtk-greeter.c lightdm-gtk-greeter-1.5.0.patch/src/lightdm-gtk-greeter.c
|
||||
--- lightdm-gtk-greeter-1.5.0.src/src/lightdm-gtk-greeter.c 2013-01-25 01:31:00.000000000 +1100
|
||||
+++ lightdm-gtk-greeter-1.5.0.patch/src/lightdm-gtk-greeter.c 2013-01-30 19:42:27.612325811 +1100
|
||||
@@ -872,6 +872,7 @@
|
||||
g_warning ("Failed to load background: %s", error->message);
|
||||
g_clear_error (&error);
|
||||
g_free (path);
|
||||
+ default_background_pixbuf=gdk_pixbuf_add_alpha (default_background_pixbuf,FALSE,255,255,255);
|
||||
}
|
||||
else
|
||||
{
|
|
@ -1,7 +1,9 @@
|
|||
#Mantainer: M0Rf30
|
||||
#Contributor: ossfm
|
||||
#Contributor: shosca
|
||||
pkgname=lightdm
|
||||
pkgver=1.4.0
|
||||
pkgrel=6
|
||||
pkgrel=8
|
||||
pkgdesc="A lightweight display manager"
|
||||
arch=('i686' 'x86_64')
|
||||
url="https://launchpad.net/lightdm"
|
||||
|
@ -12,7 +14,10 @@ source=("https://launchpad.net/lightdm/1.4/$pkgver/+download/$pkgname-$pkgver.ta
|
|||
lightdm.tmpfiles
|
||||
xsession
|
||||
lightdm-autologin.pam
|
||||
lightdm.pam)
|
||||
lightdm.pam
|
||||
lightdm.rules
|
||||
lightdm-1.4.0-systemd_login1_power.patch
|
||||
lightdm-lock-screen-before-switch.patch)
|
||||
depends=('dbus-glib' 'libxklavier')
|
||||
options=(!libtool)
|
||||
install=lightdm.install
|
||||
|
@ -36,6 +41,10 @@ backup=(etc/apparmor.d/lightdm-guest-session
|
|||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
||||
patch -p1 -i ../lightdm-1.4.0-systemd_login1_power.patch
|
||||
patch -p1 -i ../lightdm-lock-screen-before-switch.patch
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc --disable-static --libexecdir=/usr/lib/lightdm \
|
||||
--localstatedir=/var --with-greeter-user=lightdm \
|
||||
|
@ -66,6 +75,10 @@ package() {
|
|||
# Doing Autologin and security fixes
|
||||
cp ../lightdm-autologin.pam $pkgdir/etc/pam.d/lightdm-autologin
|
||||
cp ../lightdm.pam $pkgdir/etc/pam.d/lightdm
|
||||
sed 's#\[UserAccounts\]#\[UserList\]#g' -i $pkgdir/etc/lightdm/users.conf
|
||||
|
||||
install -d -m700 $pkgdir/usr/share/polkit-1/rules.d/
|
||||
install -m644 ../lightdm.rules $pkgdir/usr/share/polkit-1/rules.d/lightdm.rules
|
||||
}
|
||||
|
||||
md5sums=('622d9087ec773dd0626a250a5868f88c'
|
||||
|
@ -74,4 +87,7 @@ md5sums=('622d9087ec773dd0626a250a5868f88c'
|
|||
'b1e1baf7351ff58c7b3b9b204472f6bb'
|
||||
'683bc8bc3f423157065dc6295f9fecef'
|
||||
'9e39da461e36f9d3fdd4447a80ebd878'
|
||||
'a5c60ec8739a698e4127b47ef417e517')
|
||||
'a5c60ec8739a698e4127b47ef417e517'
|
||||
'2a7326f4de1d949b8c96749b62cc5021'
|
||||
'1aac33da4bb5d6c5bb2b8fa72ae922b9'
|
||||
'43314fcf13397aaf2321a86d7ed9452c')
|
||||
|
|
209
aur/lightdm/lightdm-1.4.0-systemd_login1_power.patch
Normal file
209
aur/lightdm/lightdm-1.4.0-systemd_login1_power.patch
Normal file
|
@ -0,0 +1,209 @@
|
|||
diff -up lightdm-1.4.0/liblightdm-gobject/power.c.systemd_login1_power lightdm-1.4.0/liblightdm-gobject/power.c
|
||||
--- lightdm-1.4.0/liblightdm-gobject/power.c.systemd_login1_power 2011-12-08 19:51:23.000000000 -0600
|
||||
+++ lightdm-1.4.0/liblightdm-gobject/power.c 2013-01-10 22:34:41.782151231 -0600
|
||||
@@ -18,6 +18,7 @@
|
||||
|
||||
static GDBusProxy *upower_proxy = NULL;
|
||||
static GDBusProxy *ck_proxy = NULL;
|
||||
+static GDBusProxy *login1_proxy = NULL;
|
||||
|
||||
static gboolean
|
||||
upower_call_function (const gchar *function, gboolean default_result, GError **error)
|
||||
@@ -148,6 +149,59 @@ ck_call_function (const gchar *function,
|
||||
return function_result;
|
||||
}
|
||||
|
||||
+static gboolean
|
||||
+login1_call_function (const gchar *function, GVariant *parameters, gboolean default_result, GError **error)
|
||||
+{
|
||||
+ GVariant *result;
|
||||
+ gboolean function_result = FALSE;
|
||||
+ const gchar *true_result = "yes";
|
||||
+ gchar *str_result;
|
||||
+
|
||||
+ if (!login1_proxy)
|
||||
+ {
|
||||
+ login1_proxy = g_dbus_proxy_new_for_bus_sync (G_BUS_TYPE_SYSTEM,
|
||||
+ G_DBUS_PROXY_FLAGS_NONE,
|
||||
+ NULL,
|
||||
+ "org.freedesktop.login1",
|
||||
+ "/org/freedesktop/login1",
|
||||
+ "org.freedesktop.login1.Manager",
|
||||
+ NULL,
|
||||
+ error);
|
||||
+ if (!login1_proxy)
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+
|
||||
+ result = g_dbus_proxy_call_sync (login1_proxy,
|
||||
+ function,
|
||||
+ parameters,
|
||||
+ G_DBUS_CALL_FLAGS_NONE,
|
||||
+ -1,
|
||||
+ NULL,
|
||||
+ error);
|
||||
+
|
||||
+ if (!result)
|
||||
+ return default_result;
|
||||
+
|
||||
+ if (g_variant_is_of_type (result, G_VARIANT_TYPE ("(b)")))
|
||||
+ g_variant_get (result, "(s)", &function_result);
|
||||
+
|
||||
+ /**
|
||||
+ * CanReboot, CanPowerOff returns a string "yes", "no", or "challenge", not a boolean as ConsoleKit
|
||||
+ **/
|
||||
+ if (g_variant_is_of_type (result, G_VARIANT_TYPE ("(s)"))) {
|
||||
+ g_variant_get (result, "(b)", str_result);
|
||||
+ if(g_strcmp0(str_result,true_result) == 0) {
|
||||
+ function_result = TRUE;
|
||||
+ }
|
||||
+ else {
|
||||
+ function_result = default_result;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ g_variant_unref (result);
|
||||
+ return function_result;
|
||||
+}
|
||||
+
|
||||
/**
|
||||
* lightdm_get_can_restart:
|
||||
*
|
||||
@@ -158,7 +212,11 @@ ck_call_function (const gchar *function,
|
||||
gboolean
|
||||
lightdm_get_can_restart (void)
|
||||
{
|
||||
- return ck_call_function ("CanRestart", FALSE, NULL);
|
||||
+ gboolean function_result = FALSE;
|
||||
+ function_result = login1_call_function ("CanReboot", NULL, FALSE, NULL);
|
||||
+ if (!function_result)
|
||||
+ function_result = ck_call_function ("CanRestart", FALSE, NULL);
|
||||
+ return function_result;
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -172,7 +230,11 @@ lightdm_get_can_restart (void)
|
||||
gboolean
|
||||
lightdm_restart (GError **error)
|
||||
{
|
||||
- return ck_call_function ("Restart", TRUE, error);
|
||||
+ gboolean function_result = FALSE;
|
||||
+ function_result = login1_call_function ("Reboot", g_variant_new("(b)",0), TRUE, error);
|
||||
+ if (!function_result)
|
||||
+ function_result = ck_call_function ("Restart", TRUE, error);
|
||||
+ return function_result;
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -185,7 +247,11 @@ lightdm_restart (GError **error)
|
||||
gboolean
|
||||
lightdm_get_can_shutdown (void)
|
||||
{
|
||||
- return ck_call_function ("CanStop", FALSE, NULL);
|
||||
+ gboolean function_result = FALSE;
|
||||
+ function_result = login1_call_function ("CanPowerOff", NULL, FALSE, NULL);
|
||||
+ if (!function_result)
|
||||
+ function_result = ck_call_function ("CanStop", FALSE, NULL);
|
||||
+ return function_result;
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -199,5 +265,9 @@ lightdm_get_can_shutdown (void)
|
||||
gboolean
|
||||
lightdm_shutdown (GError **error)
|
||||
{
|
||||
- return ck_call_function ("Stop", TRUE, error);
|
||||
+ gboolean function_result = FALSE;
|
||||
+ function_result = login1_call_function ("PowerOff", g_variant_new("(b)",0), TRUE, error);
|
||||
+ if (!function_result)
|
||||
+ function_result = ck_call_function ("Stop", TRUE, error);
|
||||
+ return function_result;
|
||||
}
|
||||
diff -up lightdm-1.4.0/liblightdm-qt/power.cpp.systemd_login1_power lightdm-1.4.0/liblightdm-qt/power.cpp
|
||||
--- lightdm-1.4.0/liblightdm-qt/power.cpp.systemd_login1_power 2011-12-08 19:51:23.000000000 -0600
|
||||
+++ lightdm-1.4.0/liblightdm-qt/power.cpp 2013-01-10 22:57:15.458512125 -0600
|
||||
@@ -16,6 +16,7 @@
|
||||
#include <QtCore/QVariant>
|
||||
#include <QtDBus/QDBusInterface>
|
||||
#include <QtDBus/QDBusReply>
|
||||
+#include <QDebug>
|
||||
|
||||
#include "config.h"
|
||||
|
||||
@@ -27,11 +28,13 @@ public:
|
||||
PowerInterfacePrivate();
|
||||
QScopedPointer<QDBusInterface> powerManagementInterface;
|
||||
QScopedPointer<QDBusInterface> consoleKitInterface;
|
||||
+ QScopedPointer<QDBusInterface> login1Interface;
|
||||
};
|
||||
|
||||
PowerInterface::PowerInterfacePrivate::PowerInterfacePrivate() :
|
||||
powerManagementInterface(new QDBusInterface("org.freedesktop.UPower","/org/freedesktop/UPower", "org.freedesktop.UPower", QDBusConnection::systemBus())),
|
||||
- consoleKitInterface(new QDBusInterface("org.freedesktop.ConsoleKit", "/org/freedesktop/ConsoleKit/Manager", "org.freedesktop.ConsoleKit.Manager", QDBusConnection::systemBus()))
|
||||
+ consoleKitInterface(new QDBusInterface("org.freedesktop.ConsoleKit", "/org/freedesktop/ConsoleKit/Manager", "org.freedesktop.ConsoleKit.Manager", QDBusConnection::systemBus())),
|
||||
+ login1Interface(new QDBusInterface("org.freedesktop.login1", "/org/freedesktop/login1", "org.freedesktop.login1.Manager", QDBusConnection::systemBus()))
|
||||
{
|
||||
}
|
||||
|
||||
@@ -81,34 +84,53 @@ void PowerInterface::hibernate()
|
||||
|
||||
bool PowerInterface::canShutdown()
|
||||
{
|
||||
+ if ( d->login1Interface->isValid() ) {
|
||||
+ QDBusReply<QString> reply1 = d->login1Interface->call("CanPowerOff");
|
||||
+ if (reply1.isValid()) {
|
||||
+ return (reply1.value()=="yes");
|
||||
+ }
|
||||
+ }
|
||||
+ qWarning() << d->login1Interface->lastError();
|
||||
+
|
||||
QDBusReply<bool> reply = d->consoleKitInterface->call("CanStop");
|
||||
if (reply.isValid()) {
|
||||
return reply.value();
|
||||
}
|
||||
- else {
|
||||
- return false;
|
||||
- }
|
||||
+ return false;
|
||||
}
|
||||
|
||||
void PowerInterface::shutdown()
|
||||
{
|
||||
- d->consoleKitInterface->call("Stop");
|
||||
+ if ( d->login1Interface->isValid() )
|
||||
+ d->login1Interface->call("PowerOff",false);
|
||||
+ else
|
||||
+ d->consoleKitInterface->call("Stop");
|
||||
}
|
||||
|
||||
bool PowerInterface::canRestart()
|
||||
{
|
||||
+ if ( d->login1Interface->isValid() ) {
|
||||
+ QDBusReply<QString> reply1 = d->login1Interface->call("CanReboot");
|
||||
+ if (reply1.isValid()) {
|
||||
+ return (reply1.value()=="yes");
|
||||
+ }
|
||||
+ }
|
||||
+ qWarning() << d->login1Interface->lastError();
|
||||
+
|
||||
QDBusReply<bool> reply = d->consoleKitInterface->call("CanRestart");
|
||||
if (reply.isValid()) {
|
||||
return reply.value();
|
||||
}
|
||||
- else {
|
||||
- return false;
|
||||
- }
|
||||
+
|
||||
+ return false;
|
||||
}
|
||||
|
||||
void PowerInterface::restart()
|
||||
{
|
||||
- d->consoleKitInterface->call("Restart");
|
||||
+ if ( d->login1Interface->isValid() )
|
||||
+ d->login1Interface->call("Reboot",false);
|
||||
+ else
|
||||
+ d->consoleKitInterface->call("Restart");
|
||||
}
|
||||
|
||||
#include "power_moc.cpp"
|
55
aur/lightdm/lightdm-lock-screen-before-switch.patch
Normal file
55
aur/lightdm/lightdm-lock-screen-before-switch.patch
Normal file
|
@ -0,0 +1,55 @@
|
|||
# HG changeset patch
|
||||
# Parent b329fa1badaa454239690c3feb93d53324134915
|
||||
try to lock the screen before switching users
|
||||
|
||||
diff --git a/utils/gdmflexiserver b/utils/gdmflexiserver
|
||||
--- a/utils/gdmflexiserver
|
||||
+++ b/utils/gdmflexiserver
|
||||
@@ -9,9 +9,47 @@
|
||||
#
|
||||
# See http://www.gnu.org/copyleft/gpl.html for the full text of the license.
|
||||
|
||||
+PATH=/usr/local/bin:/bin:/usr/bin
|
||||
+export PATH
|
||||
+
|
||||
if [ -z "$XDG_SEAT_PATH" ]; then
|
||||
# something went wrong
|
||||
exit 1
|
||||
fi
|
||||
|
||||
+find_command () {
|
||||
+ cmd="$1"
|
||||
+ oIFS="${IFS}"; IFS=:
|
||||
+ set -- ${PATH}
|
||||
+ IFS="${oIFS}"
|
||||
+
|
||||
+ for part; do
|
||||
+ [ -x "${part}/${cmd}" ] && return 0
|
||||
+ done
|
||||
+ return 1
|
||||
+}
|
||||
+
|
||||
+lock_screen () {
|
||||
+ for lock_cmd in \
|
||||
+ "xscreensaver-command -lock" \
|
||||
+ "gnome-screensaver-command --lock" \
|
||||
+ "dbus-send --session --dest=org.freedesktop.ScreenSaver --type=method_call /ScreenSaver org.freedesktop.ScreenSaver.Lock"
|
||||
+ do
|
||||
+ ${lock_cmd} >/dev/null 2>&1 && return
|
||||
+ done
|
||||
+
|
||||
+ for lock_cmd in \
|
||||
+ "slock" \
|
||||
+ "xlock -mode blank"
|
||||
+ do
|
||||
+ set -- ${lock_cmd}
|
||||
+ if find_command "$1"; then
|
||||
+ ${lock_cmd} >/dev/null 2>&1 &
|
||||
+ return
|
||||
+ fi
|
||||
+ done
|
||||
+}
|
||||
+
|
||||
+lock_screen
|
||||
+
|
||||
dbus-send --system --type=method_call --print-reply --dest=org.freedesktop.DisplayManager $XDG_SEAT_PATH org.freedesktop.DisplayManager.Seat.SwitchToGreeter
|
15
aur/lightdm/lightdm.rules
Normal file
15
aur/lightdm/lightdm.rules
Normal file
|
@ -0,0 +1,15 @@
|
|||
polkit.addRule(function(action, subject) {
|
||||
if (subject.user == "lightdm") {
|
||||
polkit.log("action=" + action);
|
||||
polkit.log("subject=" + subject);
|
||||
if (action.id.indexOf("org.freedesktop.login1.") == 0) {
|
||||
return polkit.Result.YES;
|
||||
}
|
||||
if (action.id.indexOf("org.freedesktop.consolekit.system.") == 0) {
|
||||
return polkit.Result.YES;
|
||||
}
|
||||
if (action.id.indexOf("org.freedesktop.upower.") == 0) {
|
||||
return polkit.Result.YES;
|
||||
}
|
||||
}
|
||||
});
|
|
@ -5,32 +5,33 @@
|
|||
# Contributor: Farhan Yousaf <farhany at xaviya dot com>
|
||||
|
||||
pkgname=netatalk
|
||||
pkgver=3.0.1
|
||||
pkgrel=5
|
||||
pkgver=3.0.2
|
||||
pkgrel=1
|
||||
pkgdesc='A kernel-level implementation of AFP services'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://netatalk.sourceforge.net'
|
||||
license=('GPL')
|
||||
depends=('avahi>=0.6' 'libldap' 'libgcrypt>=1.2.3' 'libevent')
|
||||
replaces=('netatalk-git' 'netatalk2')
|
||||
backup=('etc/afp.conf')
|
||||
backup=('etc/afp.conf'
|
||||
'etc/extmap.conf')
|
||||
options=('!libtool')
|
||||
install=$pkgname.install
|
||||
changelog=$pkgname.changelog
|
||||
source=(http://iweb.dl.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
|
||||
md5sums=('b4f5c932b2ca99f5292bd6b6d69b3ebc')
|
||||
md5sums=('b5f1c2c4b3a5e64f5bca219415aa1c75')
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
msg2 'Fixing...'
|
||||
sed -i 's/x"linux/x"generic/' macros/netatalk.m4
|
||||
sed -i -e 's:AC_CONFIG_SUBDIRS:#AC_CONFIG_SUBDIRS:' -e 's/x"linux/x"generic/' macros/netatalk.m4
|
||||
sed -i 's:/lib:/usr/lib:' distrib/initscripts/Makefile.{am,in}
|
||||
sed -i 's:model=%s:model:' etc/afpd/afp_mdns.c
|
||||
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' {configure.ac,libevent/configure.in}
|
||||
cp /usr/share/automake*/missing .
|
||||
autoreconf -i >/dev/null
|
||||
msg2 'Configuring...'
|
||||
CFLAGS="-Wno-unused-result" ./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc --with-init-style=systemd \
|
||||
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --without-libevent-header --without-libevent-lib
|
||||
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no
|
||||
sed -i -e s/-Ino// -e s/-Lno// etc/netatalk/Makefile
|
||||
msg2 'Making...'
|
||||
make >/dev/null
|
||||
|
|
|
@ -1,3 +1,10 @@
|
|||
2013-01-27 SJ_UnderWater
|
||||
|
||||
* 3.0.2-1:
|
||||
package update
|
||||
libevent fix
|
||||
copy newer ./missing
|
||||
|
||||
2013-01-05 SJ_UnderWater
|
||||
|
||||
* 3.0.1-5:
|
||||
|
|
|
@ -17,5 +17,5 @@ post_upgrade() {
|
|||
if [ -f /opt/netatalk/afp_signature.conf ] ||
|
||||
[ -f /opt/netatalk/afp_voluuid.conf ]; then
|
||||
echo '>>> Found *.conf in /opt/netatalk, please';
|
||||
echo '>>> migrate these to /etc/netatalk before restarting';fi
|
||||
echo '>>> migrate these to /var/state/netatalk before restarting';fi
|
||||
}
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
# Maintainer: Jouke Witteveen <j.witteveen@gmail.com>
|
||||
|
||||
pkgname=netctl
|
||||
pkgver=0.2
|
||||
pkgrel=1
|
||||
pkgver=0.3
|
||||
pkgrel=2
|
||||
arch=(any)
|
||||
pkgdesc="Network configuration and profile scripts"
|
||||
url="http://archlinux.org/netctl/"
|
||||
url="http://projects.archlinux.org/netctl.git/"
|
||||
license=("GPL")
|
||||
depends=("coreutils" "iproute2" "openresolv")
|
||||
makedepends=('asciidoc')
|
||||
|
@ -18,20 +18,19 @@ optdepends=('dialog: for the menu based wifi assistant'
|
|||
'ifenslave: for bond connections'
|
||||
'bridge-utils: for bridge connections'
|
||||
)
|
||||
conflicts=("netcfg" "netctl")
|
||||
provides=("netctl")
|
||||
conflicts=("netcfg")
|
||||
provides=("netcfg")
|
||||
|
||||
source=("https://github.com/joukewitteveen/$pkgname/archive/$pkgver.tar.gz"
|
||||
|
||||
source=("https://projects.archlinux.org/$pkgname.git/snapshot/$pkgver.tar.gz"
|
||||
'zsh-completion')
|
||||
md5sums=('cb144eda0e5dd09f5b07db00421a429f'
|
||||
'3428e0e7f061bbcde41f2fe64d8d96dd')
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
||||
make -C "$srcdir/$pkgname-$pkgver" DESTDIR="$pkgdir" install
|
||||
# Shell Completion
|
||||
install -D -m644 contrib/bash-completion "$pkgdir/usr/share/bash-completion/completions/netctl"
|
||||
install -D -m644 "$srcdir/$pkgname-$pkgver/contrib/bash-completion" "$pkgdir/usr/share/bash-completion/completions/netctl"
|
||||
install -Dm644 "$srcdir/zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_netctl"
|
||||
}
|
||||
|
||||
md5sums=('ec67fcb75fdb750847a9ebfcd10806df'
|
||||
'3428e0e7f061bbcde41f2fe64d8d96dd')
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# Contributor: plut0nium <charles(DOT)fourneau(AT)gmail(DOT)com >
|
||||
# tzervo <tzervo@gmail.com>
|
||||
pkgname="owfs"
|
||||
pkgver=2.8p20
|
||||
pkgver=2.8p21
|
||||
pkgrel=1
|
||||
pkgdesc="An easy way to use the powerful 1-wire system of Dallas/Maxim."
|
||||
arch=('any')
|
||||
|
@ -21,7 +21,7 @@ options=()
|
|||
install=
|
||||
source=(http://downloads.sourceforge.net/sourceforge/owfs/$pkgname-$pkgver.tar.gz)
|
||||
noextract=()
|
||||
md5sums=('9aebee6c0e724553f5be6a542494eae5')
|
||||
md5sums=('372361dc6316fcadc80029626f6c3d7f')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
pkgname=sabnzbd
|
||||
_pkgname=SABnzbd
|
||||
pkgver=0.7.9
|
||||
pkgver=0.7.10
|
||||
pkgrel=1
|
||||
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
|
||||
url="http://www.sabnzbd.org"
|
||||
|
@ -14,7 +14,7 @@ install="${pkgname}.install"
|
|||
backup=("etc/conf.d/sabnzbd" "opt/${pkgname}/${pkgname}.ini")
|
||||
source=("http://downloads.sourceforge.net/sabnzbdplus/${_pkgname}-${pkgver}-src.tar.gz"
|
||||
"${pkgname}" "${pkgname}.desktop" "addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}.confd")
|
||||
md5sums=('175edddbdcc8b2be51f0987c19bff0ae'
|
||||
md5sums=('fe5d40de2b3101c53266f2a854c1793d'
|
||||
'48d60a1c626503c7fef1bc5374390513'
|
||||
'f9bd5485072714b11f8c30a28024dc4d'
|
||||
'69b9bcbcf67ff3e7a4cdd9f26e001341'
|
||||
|
|
|
@ -4,8 +4,8 @@
|
|||
# Contributor: Augusto Born de Oliveira <augustoborn at gmail dot com>
|
||||
|
||||
pkgname=sickbeard-git
|
||||
pkgver=20121109
|
||||
pkgrel=2
|
||||
pkgver=20130126
|
||||
pkgrel=1
|
||||
pkgdesc="A PVR application that downloads and manages your TV shows"
|
||||
arch=(any)
|
||||
url="http://code.google.com/p/sickbeard/"
|
||||
|
@ -18,11 +18,11 @@ install=sickbeard.install
|
|||
backup=('etc/conf.d/sickbeard')
|
||||
conflicts=(sickbeard)
|
||||
source=('sickbeard.init' 'sickbeard.confd' 'sickbeard-system.service' 'sickbeard-user.service' 'sickbeard.tmpfile')
|
||||
md5sums=('276747cb646524bbee02e1b1c7cd537c'
|
||||
'b98110609108a554e8349552dc84ea9f'
|
||||
'a80cd5ff963fd75b5d65a8671b21d831'
|
||||
'2455963553a4ca61957fc61e509a9d15'
|
||||
'08bbd75c6cf2ef3e4797d9221f0ce385')
|
||||
sha256sums=('75430ca55c2d3d6feb4a47822f47fc389db1baaabc3fe1d7084e836193a57697'
|
||||
'fb54350688c181425c5fcd19a53201026dab1e97f5558f3245f233b516681d89'
|
||||
'aa2b6496bf622d2b235a47b80d950ba84411e879a08bc656d227e224653aeded'
|
||||
'bf2f9792d3d7e1d703fec9bf61a1562a34b8d08d1dba3d560e6299ea25bd5a72'
|
||||
'24f20de2445ff3998aad5d87d94e0fea3b22eb1d0a451ed33ec301ac36a7398d')
|
||||
|
||||
_gitroot="git://github.com/midgetspy/Sick-Beard.git"
|
||||
_gitname="sickbeardpvr"
|
||||
|
|
|
@ -5,7 +5,7 @@ After=network.target
|
|||
[Service]
|
||||
User=sickbeard
|
||||
Group=sickbeard
|
||||
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --config /opt/sickbeard/config.ini --datadir /opt/sickbeard
|
||||
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --quiet --config /opt/sickbeard/config.ini --datadir /opt/sickbeard
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
Description=SickBeard Daemon
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --config %h/.sickbeard/config.ini --datadir %h/.sickbeard
|
||||
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --quiet --config %h/.sickbeard/config.ini --datadir %h/.sickbeard
|
||||
|
||||
[Install]
|
||||
WantedBy=default.target
|
||||
|
|
|
@ -23,11 +23,6 @@ post_install() {
|
|||
chmod 775 /run/sickbeard
|
||||
fi
|
||||
|
||||
echo "You can now run sickbeard as a user service with 'systemctl --user start sickbeard'."
|
||||
echo "To make this work, first run 'mkdir ~/.sickbeard'. This will run sickbeard as your user."
|
||||
echo "The system service will run it as the sickbeard user."
|
||||
echo "If you have a previous install and want to keep the same show database, cache, etc., you can"
|
||||
echo "run 'cp -r /opt/sickbeard/{Logs,cache,cache.db,config.ini,sickbeard.db} ~/.sickbeard'."
|
||||
}
|
||||
## arg 1: the new package version
|
||||
## arg 2: the old package version
|
||||
|
@ -42,11 +37,6 @@ post_upgrade() {
|
|||
chmod 775 /run/sickbeard
|
||||
fi
|
||||
|
||||
echo "You can now run sickbeard as a user service with 'systemctl --user start sickbeard'."
|
||||
echo "To make this work, first run 'mkdir ~/.sickbeard'. This will run sickbeard as your user."
|
||||
echo "The system service will run it as the sickbeard user."
|
||||
echo "If you have a previous install and want to keep the same show database, cache, etc., you can"
|
||||
echo "run 'cp -r /opt/sickbeard/{Logs,cache,cache.db,config.ini,sickbeard.db} ~/.sickbeard'."
|
||||
}
|
||||
|
||||
## arg 1: the old package version
|
||||
|
|
Loading…
Reference in a new issue