extra/vigra to 1.11.1-1

This commit is contained in:
Kevin Mihelich 2017-05-30 23:37:48 +00:00
parent d0a7ac373e
commit 0064de9669
2 changed files with 5 additions and 37 deletions

View file

@ -7,24 +7,17 @@
pkgbase=vigra
pkgname=('vigra' 'vigra-doc')
pkgver=1.11.0
pkgrel=7
pkgver=1.11.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://hci.iwr.uni-heidelberg.de/vigra/"
url="https://ukoethe.github.io/vigra/"
license=('custom:MIT')
makedepends=(# runtime deps
'libpng' 'libtiff' 'openexr' 'gcc-libs' 'sh' 'hdf5' 'fftw'
# additional makedeps
'cmake' 'python-nose' 'doxygen' 'python-sphinx' 'boost' 'python-numpy')
source=(https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz
vigra-1.11.0-const-swap.patch)
md5sums=('7f80d289e03a2f2e8c8e85f3ff29d988'
'a571f3a8d4cd66c8a8071ca958091f7b')
prepare() {
cd "${srcdir}"/${pkgbase}-${pkgver}
patch -p1 -i "${srcdir}"/vigra-1.11.0-const-swap.patch
}
source=(https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz)
sha256sums=('a5564e1083f6af6a885431c1ee718bad77d11f117198b277557f8558fa461aaf')
build() {
cd "${srcdir}"/${pkgbase}-${pkgver}

View file

@ -1,25 +0,0 @@
From 18675a51fca27b324eb4e4b49593bcee9bc4535e Mon Sep 17 00:00:00 2001
From: Jonathan Wakely <jwakely@redhat.com>
Date: Fri, 17 Feb 2017 00:55:25 +0000
Subject: [PATCH] Fix parameter of ImagePyramid::swap
You can't swap with a const object. This fixes a compilation failure
with GCC 7 which rejects the incorrect function even if it isn't
instantiated.
---
include/vigra/imagecontainer.hxx | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/vigra/imagecontainer.hxx b/include/vigra/imagecontainer.hxx
index a6f0f80..636cc64 100644
--- a/include/vigra/imagecontainer.hxx
+++ b/include/vigra/imagecontainer.hxx
@@ -763,7 +763,7 @@ public:
/** swap contents of this array with the contents of other
(STL-Container interface)
*/
- void swap(const ImagePyramid<ImageType, Alloc> &other)
+ void swap(ImagePyramid<ImageType, Alloc> &other)
{
images_.swap(other.images_);
std::swap(lowestLevel_, other.lowestLevel_);