mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/mysql-workbench: add patch
This commit is contained in:
parent
fde6ab419a
commit
00690e880a
2 changed files with 17 additions and 5 deletions
13
community/mysql-workbench/0003-find-libssh.patch
Normal file
13
community/mysql-workbench/0003-find-libssh.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/build/cmake/Modules/FindLibSSH.cmake b/build/cmake/Modules/FindLibSSH.cmake
|
||||
index 3d31ed3..acbe292 100644
|
||||
--- a/build/cmake/Modules/FindLibSSH.cmake
|
||||
+++ b/build/cmake/Modules/FindLibSSH.cmake
|
||||
@@ -51,7 +51,7 @@ else()
|
||||
find_library(LibSSH_LIBRARY NAMES ${LibSSH_NAMES})
|
||||
endif()
|
||||
|
||||
-set(LibSSH_HEADER_FILE ${LibSSH_INCLUDE_DIR}/libssh/libssh.h)
|
||||
+set(LibSSH_HEADER_FILE ${LibSSH_INCLUDE_DIR}/libssh/libssh_version.h)
|
||||
file(STRINGS ${LibSSH_HEADER_FILE} LibSSH_VERSION_LINE_MAJOR REGEX "#define LIBSSH_VERSION_MAJOR[ ]+[0-9]+")
|
||||
if (LibSSH_VERSION_LINE_MAJOR)
|
||||
file(STRINGS ${LibSSH_HEADER_FILE} LibSSH_VERSION_LINE_MINOR REGEX "#define LIBSSH_VERSION_MINOR[ ]+[0-9]+")
|
|
@ -38,9 +38,9 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
|
|||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||
'0002-disable-unsupported-operating-system-warning.patch'
|
||||
'0003-find-libssh.patch'
|
||||
'0001-fix-buiild-for-32-bit.patch'
|
||||
'atomic.patch'
|
||||
'0003-find-libssh.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('56e0d6dde77a04867715c6946bf76922e7c1a0361a170156eba039a28727b853'
|
||||
'SKIP'
|
||||
|
@ -67,10 +67,6 @@ prepare() {
|
|||
# disable unsupported operating system warning
|
||||
patch -Np1 < "${srcdir}"/0002-disable-unsupported-operating-system-warning.patch
|
||||
|
||||
|
||||
# be happy with more recent antlr
|
||||
sed -i '/set(ANTLR_JAR_FILENAME/s/4.7.1/4.8/' CMakeLists.txt
|
||||
|
||||
# version macros moved to libssh/libssh_version.h
|
||||
patch -Np1 < "${srcdir}"/0003-find-libssh.patch
|
||||
|
||||
|
@ -86,6 +82,9 @@ prepare() {
|
|||
# make sure to link against bundled libraries
|
||||
sed -i "/target_link_libraries/s|\\$|-L${srcdir}/install-bundle/usr/lib/ \\$|" backend/wbpublic/CMakeLists.txt
|
||||
|
||||
# be happy with more recent antlr
|
||||
sed -i '/set(ANTLR_JAR_FILENAME/s/4.7.1/4.8/' CMakeLists.txt
|
||||
|
||||
# remove -Wno-deprecated-copy
|
||||
sed -i 's|-Wno-deprecated-copy||' CMakeLists.txt
|
||||
|
||||
|
|
Loading…
Reference in a new issue