extra/qt5-base to 5.6.0-5.1

This commit is contained in:
Kevin Mihelich 2016-05-21 03:27:29 +00:00
parent f1b75507b7
commit 00ade1ab0b
2 changed files with 2 additions and 16 deletions

View file

@ -11,7 +11,7 @@
pkgname=qt5-base
_qtver=5.6.0
pkgver=${_qtver/-/}
pkgrel=5
pkgrel=5.1
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@ -33,7 +33,7 @@ conflicts=('qt')
groups=('qt' 'qt5')
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz" qt5-alsa1.11.patch
qtbug-51648.patch qtbug-51649.patch qtbug-51676.patch qtbug-45812.patch bswap16-gcc6.patch)
qtbug-51648.patch qtbug-51649.patch qtbug-51676.patch qtbug-45812.patch)
md5sums=('d6b6cfd333c22829c6c85fc52ceed019'
'5e96b5cfa248b8b071919adb27abc715'
'b09aa4f5763f013b06153fbdbc844404'
@ -69,9 +69,6 @@ prepare() {
# Fix drag and drop from some applications
patch -p1 -i ../qtbug-45812.patch
# Fix for __builtin_bswqp16 now requiring NEON under GCC 6
patch -p0 -i ../bswap16-gcc6.patch
}
build() {

View file

@ -1,11 +0,0 @@
--- src/corelib/global/qendian.h.orig 2016-05-08 11:03:09.827707031 -0600
+++ src/corelib/global/qendian.h 2016-05-08 11:04:53.968007202 -0600
@@ -136,7 +136,7 @@
| ((source & 0xff000000) >> 24);
}
#endif // GCC & Clang intrinsics
-#if (defined(Q_CC_GNU) && Q_CC_GNU >= 408) || QT_HAS_BUILTIN(__builtin_bswap16)
+#if defined(__ARM_NEON__) && ((defined(Q_CC_GNU) && Q_CC_GNU >= 408) || QT_HAS_BUILTIN(__builtin_bswap16))
template <> inline quint16 qbswap<quint16>(quint16 source)
{
return __builtin_bswap16(source);