mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/powerdns-recursor to 4.3.5-3
This commit is contained in:
parent
68e85bb703
commit
00ae2c5e25
2 changed files with 61 additions and 1 deletions
|
@ -10,7 +10,7 @@
|
||||||
|
|
||||||
pkgname=powerdns-recursor
|
pkgname=powerdns-recursor
|
||||||
pkgver=4.3.5
|
pkgver=4.3.5
|
||||||
pkgrel=2
|
pkgrel=3
|
||||||
pkgdesc='Resolving DNS server'
|
pkgdesc='Resolving DNS server'
|
||||||
url='https://www.powerdns.com/'
|
url='https://www.powerdns.com/'
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
|
@ -22,9 +22,11 @@ provides=('pdns-recursor')
|
||||||
conflicts=('pdns-recursor')
|
conflicts=('pdns-recursor')
|
||||||
backup=('etc/powerdns/recursor.conf')
|
backup=('etc/powerdns/recursor.conf')
|
||||||
source=(https://downloads.powerdns.com/releases/pdns-recursor-${pkgver}.tar.bz2{,.asc}
|
source=(https://downloads.powerdns.com/releases/pdns-recursor-${pkgver}.tar.bz2{,.asc}
|
||||||
|
boost-1.73.patch
|
||||||
sysusers.conf)
|
sysusers.conf)
|
||||||
sha512sums=('2d39e6016000951c0beca38b26c41664b57c059dee762d7499f34e599ed6c2653af73edb31ba5a8d35f749534f24c0d85b6aedf4c35dc8a05777ffebd1b25851'
|
sha512sums=('2d39e6016000951c0beca38b26c41664b57c059dee762d7499f34e599ed6c2653af73edb31ba5a8d35f749534f24c0d85b6aedf4c35dc8a05777ffebd1b25851'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
|
'5000bcb3e58c559d4e59105cedc7befb037bca3ef62730718ee6113c940fdb462d0ff7b47b8881d30139d7dfd1e5832a33dbe7f57b48e385f5359406486de7fe'
|
||||||
'63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72')
|
'63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72')
|
||||||
validpgpkeys=('B76CD4671C0968BAA87DE61C5E50715BF2FFE1A7' # Pieter Lexis <pieter.lexis@powerdns.com>
|
validpgpkeys=('B76CD4671C0968BAA87DE61C5E50715BF2FFE1A7' # Pieter Lexis <pieter.lexis@powerdns.com>
|
||||||
'FBAE0323821C7706A5CA151BDCF513FA7EED19F3' # Peter van Dijk <peter.van.dijk@powerdns.com>
|
'FBAE0323821C7706A5CA151BDCF513FA7EED19F3' # Peter van Dijk <peter.van.dijk@powerdns.com>
|
||||||
|
@ -32,6 +34,7 @@ validpgpkeys=('B76CD4671C0968BAA87DE61C5E50715BF2FFE1A7' # Pieter Lexis <pieter
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd pdns-recursor-${pkgver}
|
cd pdns-recursor-${pkgver}
|
||||||
|
patch -Np1 -i ../boost-1.73.patch
|
||||||
autoreconf -i
|
autoreconf -i
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
57
community/powerdns-recursor/boost-1.73.patch
Normal file
57
community/powerdns-recursor/boost-1.73.patch
Normal file
|
@ -0,0 +1,57 @@
|
||||||
|
diff --git a/webserver.cc b/webserver.cc
|
||||||
|
index eafd305..b47cc6d 100644
|
||||||
|
--- a/webserver.cc
|
||||||
|
+++ b/webserver.cc
|
||||||
|
@@ -107,7 +107,7 @@ static void bareHandlerWrapper(WebServer::HandlerFunction handler, YaHTTP::Reque
|
||||||
|
|
||||||
|
void WebServer::registerBareHandler(const string& url, HandlerFunction handler)
|
||||||
|
{
|
||||||
|
- YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, _1, _2);
|
||||||
|
+ YaHTTP::THandlerFunction f = std::bind(&bareHandlerWrapper, handler, std::placeholders::_1, std::placeholders::_2);
|
||||||
|
YaHTTP::Router::Any(url, f);
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -179,7 +179,7 @@ void WebServer::apiWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
|
||||||
|
}
|
||||||
|
|
||||||
|
void WebServer::registerApiHandler(const string& url, HandlerFunction handler, bool allowPassword) {
|
||||||
|
- HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, _1, _2, allowPassword);
|
||||||
|
+ HandlerFunction f = std::bind(&WebServer::apiWrapper, this, handler, std::placeholders::_1, std::placeholders::_2, allowPassword);
|
||||||
|
registerBareHandler(url, f);
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -196,7 +196,7 @@ void WebServer::webWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
|
||||||
|
}
|
||||||
|
|
||||||
|
void WebServer::registerWebHandler(const string& url, HandlerFunction handler) {
|
||||||
|
- HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, _1, _2);
|
||||||
|
+ HandlerFunction f = std::bind(&WebServer::webWrapper, this, handler, std::placeholders::_1, std::placeholders::_2);
|
||||||
|
registerBareHandler(url, f);
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/ws-recursor.cc b/ws-recursor.cc
|
||||||
|
index 26f992f..21946e8 100644
|
||||||
|
--- a/ws-recursor.cc
|
||||||
|
+++ b/ws-recursor.cc
|
||||||
|
@@ -382,9 +382,9 @@ static void apiServerCacheFlush(HttpRequest* req, HttpResponse* resp) {
|
||||||
|
DNSName canon = apiNameToDNSName(req->getvars["domain"]);
|
||||||
|
bool subtree = (req->getvars.count("subtree") > 0 && req->getvars["subtree"].compare("true") == 0);
|
||||||
|
|
||||||
|
- int count = broadcastAccFunction<uint64_t>(boost::bind(pleaseWipeCache, canon, subtree));
|
||||||
|
- count += broadcastAccFunction<uint64_t>(boost::bind(pleaseWipePacketCache, canon, subtree));
|
||||||
|
- count += broadcastAccFunction<uint64_t>(boost::bind(pleaseWipeAndCountNegCache, canon, subtree));
|
||||||
|
+ int count = broadcastAccFunction<uint64_t>(std::bind(pleaseWipeCache, canon, subtree));
|
||||||
|
+ count += broadcastAccFunction<uint64_t>(std::bind(pleaseWipePacketCache, canon, subtree));
|
||||||
|
+ count += broadcastAccFunction<uint64_t>(std::bind(pleaseWipeAndCountNegCache, canon, subtree));
|
||||||
|
resp->setBody(Json::object {
|
||||||
|
{ "count", count },
|
||||||
|
{ "result", "Flushed cache." }
|
||||||
|
@@ -664,7 +664,7 @@ void AsyncServerNewConnectionMT(void *p) {
|
||||||
|
void AsyncServer::asyncWaitForConnections(FDMultiplexer* fdm, const newconnectioncb_t& callback)
|
||||||
|
{
|
||||||
|
d_asyncNewConnectionCallback = callback;
|
||||||
|
- fdm->addReadFD(d_server_socket.getHandle(), boost::bind(&AsyncServer::newConnection, this));
|
||||||
|
+ fdm->addReadFD(d_server_socket.getHandle(), std::bind(&AsyncServer::newConnection, this));
|
||||||
|
}
|
||||||
|
|
||||||
|
void AsyncServer::newConnection()
|
Loading…
Reference in a new issue