mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/cairo to 1.14.0-2
This commit is contained in:
parent
e33228b6dc
commit
00b4aa9ac3
3 changed files with 46 additions and 32 deletions
|
@ -7,7 +7,7 @@
|
||||||
|
|
||||||
pkgname=cairo
|
pkgname=cairo
|
||||||
pkgver=1.14.0
|
pkgver=1.14.0
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="Cairo vector graphics library"
|
pkgdesc="Cairo vector graphics library"
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
license=('LGPL' 'MPL')
|
license=('LGPL' 'MPL')
|
||||||
|
@ -19,8 +19,17 @@ makedepends=('mesa-libgl' 'librsvg' 'gtk2' 'poppler-glib' 'libspectre' 'gtk-doc'
|
||||||
#optdepends=('xcb-util: for XCB backend') # really needed?
|
#optdepends=('xcb-util: for XCB backend') # really needed?
|
||||||
provides=('cairo-xcb')
|
provides=('cairo-xcb')
|
||||||
replaces=('cairo-xcb')
|
replaces=('cairo-xcb')
|
||||||
source=(http://cairographics.org/releases/cairo-$pkgver.tar.xz)
|
source=(http://cairographics.org/releases/cairo-$pkgver.tar.xz
|
||||||
sha1sums=('53cf589b983412ea7f78feee2e1ba9cea6e3ebae')
|
git_fixes.diff)
|
||||||
|
sha1sums=('53cf589b983412ea7f78feee2e1ba9cea6e3ebae'
|
||||||
|
'0ebac538dfa510e8e3f07ba71a49dabc627b08ff')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd $pkgname-$pkgver
|
||||||
|
# fix some segfaults: https://bugs.freedesktop.org/show_bug.cgi?id=85151
|
||||||
|
# https://bugs.archlinux.org/task/42596
|
||||||
|
patch -Np1 -i ${srcdir}/git_fixes.diff
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
diff --git a/build/configure.ac.warnings b/build/configure.ac.warnings
|
|
||||||
index f984eb2..15b3da2 100644
|
|
||||||
--- a/build/configure.ac.warnings
|
|
||||||
+++ b/build/configure.ac.warnings
|
|
||||||
@@ -38,13 +38,18 @@ dnl options. Namely, the following:
|
|
||||||
|
|
||||||
dnl -flto working really needs a test link, not just a compile
|
|
||||||
|
|
||||||
-safe_MAYBE_WARN="$MAYBE_WARN"
|
|
||||||
-MAYBE_WARN="$MAYBE_WARN -flto"
|
|
||||||
-AC_TRY_LINK([],[
|
|
||||||
+AC_ARG_ENABLE(lto,
|
|
||||||
+ AS_HELP_STRING([--disable-lto],
|
|
||||||
+ [Do not try to use Link-Time Optimization]))
|
|
||||||
+if test "x$enable_lto" != "xno"; then
|
|
||||||
+ safe_MAYBE_WARN="$MAYBE_WARN"
|
|
||||||
+ MAYBE_WARN="$MAYBE_WARN -flto"
|
|
||||||
+ AC_TRY_LINK([],[
|
|
||||||
int main(int argc, char **argv) { return 0; }
|
|
||||||
-],[],[
|
|
||||||
+ ],[],[
|
|
||||||
MAYBE_WARN="$safe_MAYBE_WARN"
|
|
||||||
-])
|
|
||||||
+ ])
|
|
||||||
+fi
|
|
||||||
|
|
||||||
MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common"
|
|
||||||
|
|
||||||
|
|
34
extra/cairo/git_fixes.diff
Normal file
34
extra/cairo/git_fixes.diff
Normal file
|
@ -0,0 +1,34 @@
|
||||||
|
From 2de69581c28bf115852037ca41eba13cb7335976 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Massimo Valentini <mvalentini@src.gnome.org>
|
||||||
|
Date: Sun, 19 Oct 2014 09:19:10 +0200
|
||||||
|
Subject: tor-scan-converter: can't do_fullrow when intersection in row +
|
||||||
|
0.5subrow
|
||||||
|
|
||||||
|
the active edges list must be left sorted at the next possible use
|
||||||
|
and since full_row does not deal with intersections it is not usable
|
||||||
|
when there is an intersection in the top half of the next row first
|
||||||
|
subrow
|
||||||
|
|
||||||
|
Reported-and-tested-by: Matthew Leach
|
||||||
|
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85151
|
||||||
|
Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
|
||||||
|
|
||||||
|
diff --git a/src/cairo-tor-scan-converter.c b/src/cairo-tor-scan-converter.c
|
||||||
|
index 4adcafb..14922d0 100644
|
||||||
|
--- a/src/cairo-tor-scan-converter.c
|
||||||
|
+++ b/src/cairo-tor-scan-converter.c
|
||||||
|
@@ -1167,8 +1167,8 @@ can_do_full_row (struct active_list *active)
|
||||||
|
|
||||||
|
if (e->dy) {
|
||||||
|
struct quorem x = e->x;
|
||||||
|
- x.quo += e->dxdy_full.quo - e->dxdy.quo/2;
|
||||||
|
- x.rem += e->dxdy_full.rem - e->dxdy.rem/2;
|
||||||
|
+ x.quo += e->dxdy_full.quo;
|
||||||
|
+ x.rem += e->dxdy_full.rem;
|
||||||
|
if (x.rem < 0) {
|
||||||
|
x.quo--;
|
||||||
|
x.rem += e->dy;
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue