mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/seamonkey to 2.46-2
This commit is contained in:
parent
f0a8ece0ca
commit
01081cc26b
3 changed files with 82 additions and 6 deletions
|
@ -8,7 +8,7 @@ highmem=1
|
|||
|
||||
pkgname=seamonkey
|
||||
pkgver=2.46
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="SeaMonkey internet suite"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL')
|
||||
|
@ -23,12 +23,16 @@ source=(https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/s
|
|||
mozconfig
|
||||
seamonkey-2.0-lang.patch
|
||||
rhbz-966424.patch
|
||||
mozbug1323209.patch
|
||||
mozbug1329272.patch
|
||||
xulrunner-27.0-build-arm.patch)
|
||||
md5sums=('436a158e16eee151b97f96c053b82d45'
|
||||
'e904af9abed61515e17c2c7457aca74f'
|
||||
'25b6fe16ac24cd5c852213e5c1adb272'
|
||||
'8c1578232b7a60fa1caa9a0b322d1e2b'
|
||||
'f6f758612d23c2a6e1497889b70bc57a')
|
||||
sha256sums=('39c84ce6fa1ed7c30152473e0dcd858df07437e84b29e5a18973db437a28a912'
|
||||
'9a730ec71744e9e674a7922cd573fe2428f39ee53b0c3c8912053a910975f1d8'
|
||||
'ab19d10fbd6258aec37ab5e5efb12429814b2c24a1193284a48dd654311b4e2e'
|
||||
'746cb474c5a2c26fc474256e430e035e604b71b27df1003d4af85018fa263f4a'
|
||||
'87fb92e45f161d47b9e3ca31bcce60555bc33d633116dab4baa3bfba6ad965c4'
|
||||
'33c7031781357faf5fba7140d7723bf301c1569068922477742ac958ee82e62b'
|
||||
'bc83b8a51c81a401da2fbe1f7cd0843248c32607d3a51119585df074d797922e')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
@ -41,6 +45,12 @@ prepare() {
|
|||
# https://bugs.archlinux.org/task/41689
|
||||
patch -Np1 -d mozilla -i ../../rhbz-966424.patch
|
||||
|
||||
# Support NSS 3.28
|
||||
patch -Np1 -d mozilla -i ../../mozbug1323209.patch
|
||||
|
||||
# Bugfix for icu detection
|
||||
patch -Np1 -d mozilla -i ../../mozbug1329272.patch
|
||||
|
||||
# Don't exit with error when some libs are missing which we have in
|
||||
# system.
|
||||
sed -i '/^MOZ_PKG_FATAL_WARNINGS/s@= 1@= 0@' suite/installer/Makefile.in
|
||||
|
|
35
community/seamonkey/mozbug1323209.patch
Normal file
35
community/seamonkey/mozbug1323209.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Franziskus Kiefer <franziskuskiefer@gmail.com>
|
||||
# Date 1469717280 -7200
|
||||
# Node ID 361ac226da2a83516db8d4e4c5b41a69b3ba754f
|
||||
# Parent 5d5d3ef04f3f77bb95616f56c129256a89f57831
|
||||
Bug 1290037 - Update keybits in H2, r=mt
|
||||
|
||||
MozReview-Commit-ID: 35oWoDMqe1Y
|
||||
|
||||
diff --git a/netwerk/protocol/http/Http2Session.cpp b/netwerk/protocol/http/Http2Session.cpp
|
||||
--- a/netwerk/protocol/http/Http2Session.cpp
|
||||
+++ b/netwerk/protocol/http/Http2Session.cpp
|
||||
@@ -3544,18 +3544,18 @@ Http2Session::ConfirmTLSProfile()
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
}
|
||||
|
||||
uint32_t keybits = ssl->GetKEAKeyBits();
|
||||
if (kea == ssl_kea_dh && keybits < 2048) {
|
||||
LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
|
||||
this, keybits));
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
|
||||
- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
|
||||
+ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
|
||||
+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
|
||||
this, keybits));
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
}
|
||||
|
||||
int16_t macAlgorithm = ssl->GetMACAlgorithmUsed();
|
||||
LOG3(("Http2Session::ConfirmTLSProfile %p MAC Algortihm (aead==6) %d\n",
|
||||
this, macAlgorithm));
|
||||
if (macAlgorithm != nsISSLSocketControl::SSL_MAC_AEAD) {
|
||||
|
31
community/seamonkey/mozbug1329272.patch
Normal file
31
community/seamonkey/mozbug1329272.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Daniel Stenberg <daniel@haxx.se>
|
||||
# Date 1484000700 -3600
|
||||
# Node ID ebcbf47a83e7d3b89460cf1c991b6be5a79a967b
|
||||
# Parent 0759511f24e1b8d42acf5e9612f3ab91715842c2
|
||||
Bug 1329272 - add bracket for sed 4.3 compliance, r=glandium
|
||||
|
||||
diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
|
||||
--- a/build/autoconf/icu.m4
|
||||
+++ b/build/autoconf/icu.m4
|
||||
@@ -64,17 +64,17 @@ if test -n "$USE_ICU"; then
|
||||
icudir="$_topsrcdir/intl/icu/source"
|
||||
if test ! -d "$icudir"; then
|
||||
icudir="$_topsrcdir/../../intl/icu/source"
|
||||
if test ! -d "$icudir"; then
|
||||
AC_MSG_ERROR([Cannot find the ICU directory])
|
||||
fi
|
||||
fi
|
||||
|
||||
- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
if test x"$version" = x; then
|
||||
AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
|
||||
fi
|
||||
MOZ_ICU_VERSION="$version"
|
||||
|
||||
# TODO: the l is actually endian-dependent
|
||||
# We could make this set as 'l' or 'b' for little or big, respectively,
|
||||
# but we'd need to check in a big-endian version of the file.
|
||||
|
Loading…
Reference in a new issue