diff --git a/extra/pyqt4/PKGBUILD b/extra/pyqt4/PKGBUILD
index 0d1870116..5a30dd407 100644
--- a/extra/pyqt4/PKGBUILD
+++ b/extra/pyqt4/PKGBUILD
@@ -18,7 +18,7 @@ makedepends=('python-sip' 'python-dbus' 'python2-sip' 'phonon' 'mesa'
 source=("http://downloads.sourceforge.net/pyqt/PyQt-x11-gpl-${pkgver}.tar.gz"
         "PyQt4-4.7.3-qreal_float_support.patch")
 md5sums=('8b13d2ab64e4d2fd0037b81b7e78c15c'
-         'c493d8ea8e3199d649b60eeb45e07aec')
+         '7958e9e630963f1be44ea77c2329bb94')
 
 build() {
   cd "${srcdir}"/PyQt-x11-gpl-${pkgver}
diff --git a/extra/pyqt4/PyQt4-4.7.3-qreal_float_support.patch b/extra/pyqt4/PyQt4-4.7.3-qreal_float_support.patch
index 958fe56cb..9bf175c7f 100644
--- a/extra/pyqt4/PyQt4-4.7.3-qreal_float_support.patch
+++ b/extra/pyqt4/PyQt4-4.7.3-qreal_float_support.patch
@@ -1,30 +1,7 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 03_qreal_float_support.dpatch by Michael Casadevall <sonicmctails@gmail.com>
-##
-## DP: Corrects a configure test, and adds explicate double handling
-##     to qlist.sip on architectures where qreal != double
-
-@DPATCH@
-Index: python-qt4-4.7.2/configure.py
-===================================================================
---- python-qt4-4.7.2.orig/configure.py	2010-03-17 19:29:19.000000000 +0100
-+++ python-qt4-4.7.2/configure.py	2010-03-25 23:53:55.468631945 +0100
-@@ -1915,8 +1915,9 @@
-     out << "PyQt_NoOpenGLES\\n";
- #endif
- 
--    if (sizeof (qreal) != sizeof (double))
-+#if defined(QT_NO_FPU) || defined(QT_ARCH_ARM) || defined(QT_ARCH_WINDOWSCE)
-         out << "PyQt_qreal_double\\n";
-+#endif
- 
-     return 0;
- }
-Index: python-qt4-4.7.2/sip/QtCore/qlist.sip
-===================================================================
---- python-qt4-4.7.2.orig/sip/QtCore/qlist.sip	2010-03-17 19:29:26.000000000 +0100
-+++ python-qt4-4.7.2/sip/QtCore/qlist.sip	2010-03-25 23:53:55.468631945 +0100
-@@ -749,3 +749,227 @@
+diff -urN a/sip/QtCore/qlist.sip b/sip/QtCore/qlist.sip
+--- a/sip/QtCore/qlist.sip	2013-08-20 23:51:08.000000000 -0600
++++ b/sip/QtCore/qlist.sip	2013-08-22 11:04:16.951816724 -0600
+@@ -819,3 +819,227 @@
      return sipGetState(sipTransferObj);
  %End
  };