mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/calligra to 3.1.0-14
This commit is contained in:
parent
ed6605919e
commit
0111327004
2 changed files with 37 additions and 1 deletions
|
@ -10,7 +10,7 @@
|
|||
pkgname=calligra
|
||||
pkgdesc="A set of applications for productivity and creative usage"
|
||||
pkgver=3.1.0
|
||||
pkgrel=13
|
||||
pkgrel=14
|
||||
arch=(x86_64)
|
||||
url='https://www.calligra-suite.org/'
|
||||
license=(FDL1.2 GPL2 LGPL)
|
||||
|
@ -44,6 +44,7 @@ source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.x
|
|||
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
|
||||
calligra-poppler-0.71.patch
|
||||
calligra-poppler-0.72.patch
|
||||
calligra-poppler-0.73.patch
|
||||
'calligra-2.9.11-gcc6_arm.patch')
|
||||
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
|
||||
'SKIP'
|
||||
|
@ -51,6 +52,7 @@ sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
|
|||
'127cc5e0946fbf741279306b4e9d592f5f901a7fab09039fcfc6c7e60193fa80'
|
||||
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
|
||||
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
|
||||
'ef95f49f69c9f2a5b530e416003f2d6d106bb3c85e8458ae27494c64c8b474a8'
|
||||
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
|
||||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
||||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
||||
|
@ -67,6 +69,8 @@ prepare() {
|
|||
patch -p1 -i ../calligra-poppler-0.71.patch
|
||||
# Fix build with poppler 0.72
|
||||
patch -p1 -i ../calligra-poppler-0.72.patch
|
||||
# Fix build with poppler 0.73
|
||||
patch -p1 -i ../calligra-poppler-0.73.patch
|
||||
|
||||
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
|
||||
}
|
||||
|
|
32
extra/calligra/calligra-poppler-0.73.patch
Normal file
32
extra/calligra/calligra-poppler-0.73.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
From a1ddd91e6c354e8f0dda40f8a522053c3fa19c39 Mon Sep 17 00:00:00 2001
|
||||
From: Albert Astals Cid <aacid@kde.org>
|
||||
Date: Tue, 15 Jan 2019 22:24:08 +0100
|
||||
Subject: [PATCH] Guchar -> unsigned char
|
||||
|
||||
It was just a typdef and it's now gone
|
||||
---
|
||||
filters/karbon/pdf/SvgOutputDev.cpp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
|
||||
index 80f01a5f76f..1a5aa30bc40 100644
|
||||
--- a/filters/karbon/pdf/SvgOutputDev.cpp
|
||||
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
|
||||
@@ -496,7 +496,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
|
||||
if (maskColors) {
|
||||
for (int y = 0; y < height; y++) {
|
||||
dest = (unsigned int *)(buffer + y * 4 * width);
|
||||
- Guchar * pix = imgStr->getLine();
|
||||
+ unsigned char * pix = imgStr->getLine();
|
||||
colorMap->getRGBLine(pix, dest, width);
|
||||
|
||||
for (int x = 0; x < width; x++) {
|
||||
@@ -515,7 +515,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
|
||||
} else {
|
||||
for (int y = 0; y < height; y++) {
|
||||
dest = (unsigned int *)(buffer + y * 4 * width);
|
||||
- Guchar * pix = imgStr->getLine();
|
||||
+ unsigned char * pix = imgStr->getLine();
|
||||
colorMap->getRGBLine(pix, dest, width);
|
||||
}
|
||||
|
Loading…
Reference in a new issue