Added extra/chmlib

This commit is contained in:
Kevin Mihelich 2011-01-21 19:48:54 -05:00
parent 651236eaae
commit 0141dd71fd
2 changed files with 45 additions and 0 deletions

33
extra/chmlib/PKGBUILD Normal file
View file

@ -0,0 +1,33 @@
# $Id: PKGBUILD 42202 2009-06-11 18:57:27Z giovanni $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Alexander 'dma147' Mieland <dma147@linux-stats.org>
# Contributor: Simon Morgan <simon@16hz.net>
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
# - Added arm.patch, which aligns arm size types with i386/32-bit
plugrel=1
pkgname=chmlib
pkgver=0.40
pkgrel=1
pkgdesc="Library for dealing with Microsoft ITSS/CHM format files"
arch=('i686' 'x86_64')
url="http://morte.jedrea.com/~jedwin/projects/chmlib/"
options=('!libtool' '!emptydirs')
license=('LGPL')
depends=('glibc')
source=(http://morte.jedrea.com/~jedwin/projects/chmlib/${pkgname}-${pkgver}.tar.bz2
arm.patch)
md5sums=('7ea49ed8c335215c1edc6fae83e6b912'
'aae01483e3fc2d37ee1984cb936e58f3')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -p1 -i ${srcdir}/arm.patch
./configure --prefix=/usr \
--enable-examples=yes
make || return 1
make DESTDIR=${pkgdir} install
}

12
extra/chmlib/arm.patch Normal file
View file

@ -0,0 +1,12 @@
diff -urN chmlib-0.40.orig/src/chm_lib.c chmlib-0.40/src/chm_lib.c
--- chmlib-0.40.orig/src/chm_lib.c 2009-05-23 08:43:31.000000000 -0600
+++ chmlib-0.40/src/chm_lib.c 2011-01-21 17:42:45.000000000 -0700
@@ -153,7 +153,7 @@
/* Sparc */
/* MIPS */
/* PPC */
-#elif __i386__ || __sun || __sgi || __ppc__
+#elif __i386__ || __sun || __sgi || __ppc__ || __arm__
typedef unsigned char UChar;
typedef short Int16;
typedef unsigned short UInt16;