mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/meson to 0.56.1-1
This commit is contained in:
parent
bf27e2f601
commit
017b6558e8
2 changed files with 14 additions and 11 deletions
|
@ -6,8 +6,8 @@
|
|||
# - disable lto in arch-meson
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.56.0
|
||||
pkgrel=3
|
||||
pkgver=0.56.1
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='https://mesonbuild.com/'
|
||||
arch=('any')
|
||||
|
@ -22,11 +22,11 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
|||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver/rc/.rc}/meson-${pkgver}.tar.gz{,.asc}
|
||||
skip-test.diff
|
||||
arch-meson)
|
||||
sha512sums=('da426e2ac0f657da5672d66143b8f4f45513c269a9a544e8b4c48b4a702743a50d35cbaa37ef4c4fbd7e18b8784c788314927a54faba6a14bb2d468eeaa87607'
|
||||
sha512sums=('86ffbfb1147579b05dfbebbf7d0ff4fc75ebb92570e49aaa9027a0e3f6554e1305fdb201e066c6378025bcb6fa27bec0569c350d825c31d8ee5cdd996f0e0d67'
|
||||
'SKIP'
|
||||
'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
|
||||
'26ba3e3f0644a3cc6da716a6ea33f5b33caa1be87532aac51d71d2cb45d0b6d41a7ba309cb778da8836e759c42647c3b60b6674f713b6dbdfa49f23ce4276c46'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
|
|
@ -1,12 +1,15 @@
|
|||
diff --git i/run_unittests.py w/run_unittests.py
|
||||
index 90d4a628..f83bd61f 100755
|
||||
--- i/run_unittests.py
|
||||
+++ w/run_unittests.py
|
||||
@@ -4368,6 +4368,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
run_unittests.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git c/run_unittests.py i/run_unittests.py
|
||||
index 8025256fc..9c37cad9c 100755
|
||||
--- c/run_unittests.py
|
||||
+++ i/run_unittests.py
|
||||
@@ -6185,6 +6185,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise unittest.SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
raise unittest.SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
+ raise unittest.SkipTest('cannot run sanitizers in containers without ptrace')
|
||||
|
||||
testdir = os.path.join(self.framework_test_dir, '7 gnome')
|
||||
self.init(testdir, ['-Db_sanitize=address', '-Db_lundef=false'])
|
||||
self.init(testdir, extra_args=['-Db_sanitize=address', '-Db_lundef=false'])
|
||||
|
|
Loading…
Reference in a new issue