core/mkinitcpio to 33-1

This commit is contained in:
Kevin Mihelich 2022-11-24 16:39:57 +00:00
parent a9e325d4cf
commit 01821a6c9b
3 changed files with 18 additions and 22 deletions

View file

@ -1,4 +1,4 @@
From f0eddfb45bbe75257c679020838709e0c8e51a0c Mon Sep 17 00:00:00 2001
From 24a642d73cd76fd82ffb6e6eb395a1766113f2e8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 20 Feb 2021 10:02:34 -0700
Subject: [PATCH 1/2] use gzip for compression by default
@ -10,7 +10,7 @@ Subject: [PATCH 1/2] use gzip for compression by default
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/man/mkinitcpio.conf.5.txt b/man/mkinitcpio.conf.5.txt
index 0383360..46538d2 100644
index fdb8d91..d2ec118 100644
--- a/man/mkinitcpio.conf.5.txt
+++ b/man/mkinitcpio.conf.5.txt
@@ -55,7 +55,7 @@ Variables
@ -23,10 +23,10 @@ index 0383360..46538d2 100644
+
It's not hard to realize that a filter such as a *tac* or *rev* will cause
diff --git a/mkinitcpio b/mkinitcpio
index 2781e3a..1d48cc6 100755
index f6787a7..8f6c2ec 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -689,7 +689,7 @@ if [[ $_optgenimg ]]; then
@@ -725,7 +725,7 @@ if [[ $_optgenimg ]]; then
die 'Unable to write to %s' "$_optgenimg"
fi
@ -36,11 +36,11 @@ index 2781e3a..1d48cc6 100755
warning "Unable to locate compression method: %s" "$_optcompress"
_optcompress=cat
diff --git a/mkinitcpio.conf b/mkinitcpio.conf
index 3494fab..3c902f6 100644
index 710e05f..ac0de1c 100644
--- a/mkinitcpio.conf
+++ b/mkinitcpio.conf
@@ -52,7 +52,7 @@ FILES=()
HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)
HOOKS=(base udev autodetect modconf kms keyboard keymap consolefont block filesystems fsck)
# COMPRESSION
-# Use this to compress the initramfs image. By default, zstd compression

View file

@ -1,4 +1,4 @@
From 2dd521db90f82156b04a63576db946c97a75a0f1 Mon Sep 17 00:00:00 2001
From d8b51b2bfb33bfd0854a20c976eb4c9fa4c5fca5 Mon Sep 17 00:00:00 2001
From: Janne Grunau <j@jannau.net>
Date: Sun, 30 Jan 2022 10:01:43 +0000
Subject: [PATCH 2/2] functions: handle gzip compressed kernels in kver_generic
@ -9,12 +9,12 @@ Signed-off-by: Janne Grunau <j@jannau.net>
1 file changed, 5 insertions(+)
diff --git a/functions b/functions
index 2148ed8..f2b8bac 100644
index e0a68e2..5ad3106 100644
--- a/functions
+++ b/functions
@@ -160,6 +160,11 @@ kver_generic() {
@@ -221,6 +221,11 @@ kver_generic() {
read _ _ kver _ < <(grep -m1 -aoE 'Linux version .(\.[-[:alnum:]+]+)+' "$1")
read _ _ kver _ < <($reader "$1" | grep -m1 -aoE 'Linux version .(\.[-[:alnum:]+]+)+')
+ # try if the image is gzip compressed
+ if [[ -z "$kver" ]]; then

View file

@ -9,8 +9,8 @@
# - patch for gzip kernel image support (https://github.com/archlinux/mkinitcpio/pull/86)
pkgname=mkinitcpio
pkgver=32
pkgrel=2
pkgver=33
pkgrel=1
pkgdesc="Modular initramfs image creation utility"
arch=('any')
url='https://github.com/archlinux/mkinitcpio'
@ -26,26 +26,22 @@ optdepends=('xz: Use lzma or xz compression for the initramfs image'
provides=('initramfs')
backup=('etc/mkinitcpio.conf')
source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig}
"fix-strip.patch::https://github.com/archlinux/mkinitcpio/commit/dece596d569ca90af902bf2403227b478b629c03.patch"
'0001-use-gzip-for-compression-by-default.patch'
'0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch')
install=mkinitcpio.install
sha512sums=('c180bef8af774305e8c9779b3405daaa5be33588bf89c6625a28eac1cde424f447782737d85d810fed4971d38b31086a072293d42aad08398c090f9538b56a4e'
sha512sums=('13526e749d23f2933db4a9ed74f138b0fafaf9b93f455dcf686b29b950247f0b62f8f6a091d7006c41642b4106bf8bcd666af03ec44a9f0ee7cf2b57b5714cf0'
'SKIP'
'd19718f92916e00cece4e213bd7bd1cbf55b0094a39c459aaa995442342b64eb3fe8ec0bf023074f7ea26474a6fe2dc0370e0663823ed08ec5d33f6f645b833c'
'bd11bae0eca29839f97baa6085a046a78e0ed60c3e923e6813c32adb2519a5ac2c99d07660419811221cd34dc19244568905ed602c8173a60727af2eb678cf4a'
'99b50c857686d021441884311e50168dce65f082a9d0300831ce2c17d21b85f2c421188cfec953a60a1bc7e4baba9d8819eee436ac2d7546b65d64ff6285e878')
b2sums=('0c29659278e662eb58bc776f99e9579b5f0cf3268175382ecf2d635d54a6a8261ae173e387503a0c20a7492656c703a6699b52e1a6693c85c3211225d3e7abf8'
'711fa620fcd5685e07f19772626eb838f710e8eea8a47c33c48689935e57bfa60f6b420b70fdb351b8222d2fd5310859864be26f640c6d72c486f871dd61d48d'
'9f5d0129c93823175b04ec0a42c82fa4cc8adffb8a836773b9b08bb7d28767b1a1810f44b78501f1c501d19abd84a6d9a87d30e0d3e95c8d76f56ee5210fd5f3')
b2sums=('1a85152e6ce465e419e87a1915860be83c198f4e7a6ecab44277a68f2f1ecb316c7fed6e8af93b0282b646c2de1a8057831668749788030eb3e5256eeb28979b'
'SKIP'
'2b404010d5edb4b7eac36e25f0bf1c7958b7bc7b9740a1fda859579de48dc47552d9eee1d40abb8d2ebf1dffc523a64797c834bba59a22bab9e537ad12e991c7'
'97da54722c7c379a07f956e0d974a132b744d7b416b733a4c5bf8947725d613e82844506387d5b57652d277a01114d46a7403a325b04b48a5b918dad668928f7'
'9a4715b80f15bf1288aefe5fa76da68e7e715c163ef2a8605d29d2c8199abea3efea0f0235abd10c8a873a82d5b7ac427f64ef76d772db56ddec4d43a36106b1')
'5ce998c788e90abb22df2104f9cd58a5707fad2ebad21bf29b7e4e4d3f65cb99b74e3417b93c91c45c72569262403932c5f4af5ac5becf03a8ee2e4f38be2ebf'
'8804b5b1594de02e54530f6f07fb8c41d89fef19f597dd34f5fb9bc04b601a466daeffe5474e22d7139b59f20a82ac255301b16bb623e4dc3db1406d3cda6301')
validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB' # Giancarlo Razzolini
'C100346676634E80C940FB9E9C02FF419FECBE16') # Morten Linderud
prepare() {
cd $pkgname-$pkgver
patch -Np1 < "$srcdir/fix-strip.patch"
patch -p1 -i ../0001-use-gzip-for-compression-by-default.patch
patch -p1 -i ../0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch
}