mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/qt5: rpi patch fixes
This commit is contained in:
parent
be6dca2f55
commit
0198309ce7
4 changed files with 26 additions and 39 deletions
|
@ -46,15 +46,15 @@ source=("http://download.qt-project.org/official_releases/qt/5.1/${pkgver}/singl
|
|||
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
|
||||
'use-python2.patch'
|
||||
'deppath_gnu.patch' 'rpi.patch' 'undef_B0.patch')
|
||||
md5sums=('2cab3518d86fe8f0638c7faea8b46397'
|
||||
md5sums=('44a507beebef73eb364b5a2ec7bbe090'
|
||||
'b2897dd6a2967bccf8f10e397aafee55'
|
||||
'9638a78e502719ef8fe5f8d10d0361a9'
|
||||
'188da8f4c87316e730ebf1c6217bf5a0'
|
||||
'322b419b16c75d4de0ee7ad0a246caa1'
|
||||
'92831f79144d5cb8121915423ba47575'
|
||||
'27f2a06c6d363338ffe5e5dba96821d9'
|
||||
'54ce1583d83f5e7e4b64bf89ea7cab99'
|
||||
'3740dc700c9c43379b0da6c10d2f6c6e')
|
||||
'21e4389ed0dd9c37e7cb48712d3bff91'
|
||||
'3f8d2f8fb4e5715f7ce79950fac3c31f'
|
||||
'8a9ba2d990d8840a2114fcffb9f9d2a4')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -77,12 +77,10 @@ prepare() {
|
|||
|
||||
# Raspberry Pi
|
||||
if [ "$CARCH" == 'armv6h' ]; then
|
||||
cd qtbase
|
||||
patch -p1 -i "${srcdir}"/deppath_gnu.patch
|
||||
patch -p1 -i "${srcdir}"/rpi.patch
|
||||
patch -p1 -i "${srcdir}"/undef_B0.patch
|
||||
rbp_config="-device linux-rasp-pi-g++ -eglfs"
|
||||
cd ../
|
||||
fi
|
||||
}
|
||||
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
--- a/mkspecs/features/qt_functions.prf
|
||||
+++ b/mkspecs/features/qt_functions.prf
|
||||
@@ -242,7 +242,7 @@ defineTest(qtAddTargetEnv) {
|
||||
deppath += $$shell_path($$eval(QT.$${dep}.libs))
|
||||
diff -urN a/qtbase/mkspecs/features/qt_functions.prf b/qtbase/mkspecs/features/qt_functions.prf
|
||||
--- a/qtbase/mkspecs/features/qt_functions.prf 2013-07-02 01:09:32.000000000 -0600
|
||||
+++ b/qtbase/mkspecs/features/qt_functions.prf 2013-07-06 14:32:15.335100188 -0600
|
||||
@@ -256,7 +256,7 @@
|
||||
}
|
||||
equals(QMAKE_HOST.os, Windows) {
|
||||
deppath.name = PATH
|
||||
- } else:contains(QMAKE_HOST.os, Linux|FreeBSD) {
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2513,11 +2513,6 @@
|
||||
diff -urN a/qtbase/configure b/qtbase/configure
|
||||
--- a/qtbase/configure 2013-07-02 01:09:32.000000000 -0600
|
||||
+++ b/qtbase/configure 2013-07-06 14:25:04.356963083 -0600
|
||||
@@ -2725,11 +2725,6 @@
|
||||
else
|
||||
XQMAKESPEC="$relpath/mkspecs/${XPLATFORM}"
|
||||
fi
|
||||
|
@ -12,7 +13,7 @@
|
|||
|
||||
if [ "$BUILD_ON_MAC" = "yes" ]; then
|
||||
if [ `basename $QMAKESPEC` = "macx-xcode" ] || [ `basename $XQMAKESPEC` = "macx-xcode" ]; then
|
||||
@@ -2769,11 +2764,6 @@
|
||||
@@ -2997,11 +2992,6 @@
|
||||
if [ "$CFG_DEV" = "yes" ]; then
|
||||
CFG_BUILD_PARTS="$CFG_BUILD_PARTS tests"
|
||||
fi
|
||||
|
@ -24,10 +25,9 @@
|
|||
fi
|
||||
for nobuild in $CFG_NOBUILD_PARTS; do
|
||||
CFG_BUILD_PARTS=`echo "$CFG_BUILD_PARTS" | sed "s, $nobuild,,g"`
|
||||
diff --git a/mkspecs/devices/common/linux_device_post.conf b/mkspecs/devices/common/linux_device_post.conf
|
||||
index f8dbf76..b53c2a2 100644
|
||||
--- a/mkspecs/devices/common/linux_device_post.conf
|
||||
+++ b/mkspecs/devices/common/linux_device_post.conf
|
||||
diff -urN a/qtbase/mkspecs/devices/common/linux_device_post.conf b/qtbase/mkspecs/devices/common/linux_device_post.conf
|
||||
--- a/qtbase/mkspecs/devices/common/linux_device_post.conf 2013-07-02 01:09:32.000000000 -0600
|
||||
+++ b/qtbase/mkspecs/devices/common/linux_device_post.conf 2013-07-06 14:25:04.356963083 -0600
|
||||
@@ -1,15 +1,3 @@
|
||||
-contains(DISTRO_OPTS, deb-multi-arch) {
|
||||
- QMAKE_LFLAGS += -Wl,-rpath-link,$$[QT_SYSROOT]/usr/lib/$${GCC_MACHINE_DUMP} \
|
||||
|
@ -44,11 +44,10 @@ index f8dbf76..b53c2a2 100644
|
|||
QMAKE_CXXFLAGS += $$COMPILER_FLAGS
|
||||
|
||||
-deviceSanityCheckCompiler()
|
||||
diff --git a/mkspecs/devices/common/linux_device_pre.conf b/mkspecs/devices/common/linux_device_pre.conf
|
||||
index 51f04d9..4794b1e 100644
|
||||
--- a/mkspecs/devices/common/linux_device_pre.conf
|
||||
+++ b/mkspecs/devices/common/linux_device_pre.conf
|
||||
@@ -14,14 +14,3 @@ include(../../common/g++-unix.conf)
|
||||
diff -urN a/qtbase/mkspecs/devices/common/linux_device_pre.conf b/qtbase/mkspecs/devices/common/linux_device_pre.conf
|
||||
--- a/qtbase/mkspecs/devices/common/linux_device_pre.conf 2013-07-02 01:09:32.000000000 -0600
|
||||
+++ b/qtbase/mkspecs/devices/common/linux_device_pre.conf 2013-07-06 14:25:04.356963083 -0600
|
||||
@@ -11,14 +11,3 @@
|
||||
!load(device_config) {
|
||||
error(Could not successfully load device configuration)
|
||||
}
|
||||
|
@ -63,15 +62,3 @@ index 51f04d9..4794b1e 100644
|
|||
-QMAKE_AR = $${CROSS_COMPILE}ar cqs
|
||||
-QMAKE_OBJCOPY = $${CROSS_COMPILE}objcopy
|
||||
-QMAKE_STRIP = $${CROSS_COMPILE}strip
|
||||
--- a/mkspecs/devices/linux-rasp-pi-g++/qmake.conf
|
||||
+++ b/mkspecs/devices/linux-rasp-pi-g++/qmake.conf
|
||||
@@ -11,7 +11,7 @@
|
||||
QMAKE_LIBDIR_OPENGL_ES2 = $$[QT_SYSROOT]/opt/vc/lib
|
||||
QMAKE_LIBDIR_EGL = $$QMAKE_LIBDIR_OPENGL_ES2
|
||||
|
||||
-QMAKE_INCDIR_EGL = $$[QT_SYSROOT]/opt/vc/include $$[QT_SYSROOT]/opt/vc/include/interface/vcos/pthreads
|
||||
+QMAKE_INCDIR_EGL = $$[QT_SYSROOT]/opt/vc/include $$[QT_SYSROOT]/opt/vc/include/interface/vcos/pthreads $$[QT_SYSROOT]/opt/vc/include/interface/vmcs_host/linux
|
||||
QMAKE_INCDIR_OPENGL_ES2 = $${QMAKE_INCDIR_EGL}
|
||||
|
||||
QMAKE_LIBS_EGL = -lEGL -lGLESv2
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
--- qtbase-opensource-src-5.0.1+dfsg.orig/src/gui/painting/qpagedpaintdevice.h 2013-01-29 12:03:00.000000000 -0700
|
||||
+++ qtbase-opensource-src-5.0.1+dfsg/src/gui/painting/qpagedpaintdevice.h 2013-02-18 13:21:01.000000000 -0700
|
||||
diff -urN a/qtbase/src/gui/painting/qpagedpaintdevice.h b/qtbase/src/gui/painting/qpagedpaintdevice.h
|
||||
--- a/qtbase/src/gui/painting/qpagedpaintdevice.h 2013-07-02 01:09:54.000000000 -0600
|
||||
+++ b/qtbase/src/gui/painting/qpagedpaintdevice.h 2013-07-06 14:30:35.874606990 -0600
|
||||
@@ -44,6 +44,10 @@
|
||||
|
||||
#include <QtGui/qpaintdevice.h>
|
||||
|
@ -8,6 +9,6 @@
|
|||
+#undef B0 // Terminal hang-up. We assume that you do not want that.
|
||||
+#endif
|
||||
+
|
||||
QT_BEGIN_HEADER
|
||||
|
||||
QT_BEGIN_NAMESPACE
|
||||
|
||||
#if defined(B0)
|
||||
|
|
Loading…
Reference in a new issue