alarm/uboot-wandboard to 2015.10-1

This commit is contained in:
Kevin Mihelich 2015-11-03 01:11:03 +00:00
parent f5b03d07d9
commit 01a0c957ae
3 changed files with 78 additions and 154 deletions

View file

@ -1,108 +1,80 @@
From 8e362b4b2efcf028c06d04f7188b49503ca81ef5 Mon Sep 17 00:00:00 2001
From 901b53bdb99f888eb2a21cf8a50d9d49bdf2fb5e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 Jun 2015 10:32:52 -0600
Date: Sat, 31 Oct 2015 12:27:08 -0600
Subject: [PATCH] arch linux arm modifications
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
include/configs/wandboard.h | 129 +++++++++++++++++++++++---------------------
1 file changed, 67 insertions(+), 62 deletions(-)
include/configs/mx6_common.h | 4 ++-
include/configs/wandboard.h | 80 ++++++++++++++++++++++++++------------------
2 files changed, 51 insertions(+), 33 deletions(-)
diff --git a/include/configs/wandboard.h b/include/configs/wandboard.h
index b586803..542ed8b 100644
--- a/include/configs/wandboard.h
+++ b/include/configs/wandboard.h
@@ -51,7 +51,7 @@
#define CONFIG_CMD_BMODE
#define CONFIG_CMD_SETEXPR
diff --git a/include/configs/mx6_common.h b/include/configs/mx6_common.h
index ef4cb68..254458d 100644
--- a/include/configs/mx6_common.h
+++ b/include/configs/mx6_common.h
@@ -68,7 +68,7 @@
#define CONFIG_SYS_LOAD_ADDR CONFIG_LOADADDR
-#define CONFIG_BOOTDELAY 5
+#define CONFIG_BOOTDELAY 1
#ifndef CONFIG_BOOTDELAY
-#define CONFIG_BOOTDELAY 3
+#define CONFIG_BOOTDELAY 1
#endif
#define CONFIG_SYS_MEMTEST_START 0x10000000
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
@@ -76,7 +76,11 @@
#define CONFIG_BOUNCE_BUFFER
#define CONFIG_CMD_EXT2
#define CONFIG_CMD_FAT
+#define CONFIG_CMD_EXT4
+#define CONFIG_CMD_FS_GENERIC
/* allow to overwrite serial and ethaddr */
@@ -82,6 +82,8 @@
#define CONFIG_SUPPORT_RAW_INITRD
#define CONFIG_CMD_FS_GENERIC
#define CONFIG_DOS_PARTITION
+#define CONFIG_CMD_PART
+#define CONFIG_PARTITION_UUIDS
/* USB Configs */
#define CONFIG_CMD_USB
@@ -124,6 +128,8 @@
#define CONFIG_MXC_OCOTP
#endif
#define CONFIG_CMD_EXT2
#define CONFIG_CMD_EXT4
#define CONFIG_CMD_EXT4_WRITE
diff --git a/include/configs/wandboard.h b/include/configs/wandboard.h
index 6e8aec2..f8eb0ca 100644
--- a/include/configs/wandboard.h
+++ b/include/configs/wandboard.h
@@ -86,19 +86,26 @@
#define CONFIG_IMX_HDMI
#define CONFIG_IMX_VIDEO_SKIP
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+
#if defined(CONFIG_MX6DL) || defined(CONFIG_MX6S)
#define CONFIG_DEFAULT_FDT_FILE "imx6dl-wandboard.dtb"
#elif defined(CONFIG_MX6Q)
@@ -131,42 +137,33 @@
#endif
#define CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
#define CONFIG_EXTRA_ENV_SETTINGS \
- "script=boot.scr\0" \
- "image=zImage\0" \
- "console=ttymxc0\0" \
+ "bootfile=zImage\0" \
"script=boot.scr\0" \
"image=zImage\0" \
+ "bootdir=/boot\0" \
+ "console=ttymxc0,115200\0" \
"console=ttymxc0\0" \
"splashpos=m,m\0" \
"fdtfile=undefined\0" \
+ "fdtdir=/boot/dtbs\0" \
"fdt_high=0xffffffff\0" \
"initrd_high=0xffffffff\0" \
"fdt_addr=0x18000000\0" \
+ "rdaddr=0x12A00000\0" \
+ "rdfile=initramfs-linux.img\0" \
"initrd_high=0xffffffff\0" \
- "fdt_file=" CONFIG_DEFAULT_FDT_FILE "\0" \
- "fdt_addr=0x18000000\0" \
- "boot_fdt=try\0" \
+ "fdtfile=" CONFIG_DEFAULT_FDT_FILE "\0" \
+ "fdtdir=/boot/dtbs\0" \
+ "fdtaddr=0x18000000\0" \
"boot_fdt=try\0" \
+ "optargs=\0" \
"ip_dyn=yes\0" \
- "mmcdev=" __stringify(CONFIG_SYS_MMC_ENV_DEV) "\0" \
- "mmcpart=1\0" \
- "mmcroot=/dev/mmcblk0p2 rootwait rw\0" \
- "update_sd_firmware_filename=u-boot.imx\0" \
- "update_sd_firmware=" \
- "if test ${ip_dyn} = yes; then " \
- "setenv get_cmd dhcp; " \
- "else " \
- "setenv get_cmd tftp; " \
- "fi; " \
- "if mmc dev ${mmcdev}; then " \
- "if ${get_cmd} ${update_sd_firmware_filename}; then " \
- "setexpr fw_sz ${filesize} / 0x200; " \
- "setexpr fw_sz ${fw_sz} + 1; " \
- "mmc write ${loadaddr} 0x2 ${fw_sz}; " \
- "fi; " \
- "fi\0" \
- "mmcargs=setenv bootargs console=${console},${baudrate} " \
- "root=${mmcroot}; run videoargs\0" \
+ "optargs=\0" \
+ "video=\0" \
+ "mmcdev=0\0" \
+ "mmcroot=/dev/mmcblk0p1 rw rootwait\0" \
+ "mmcargs=setenv bootargs console=${console} " \
"mmcpart=1\0" \
"mmcroot=/dev/mmcblk0p2 rootwait rw\0" \
"update_sd_firmware_filename=u-boot.imx\0" \
@@ -116,7 +123,9 @@
"fi; " \
"fi\0" \
"mmcargs=setenv bootargs console=${console},${baudrate} " \
- "root=${mmcroot}; run videoargs\0" \
+ "${optargs} " \
+ "root=${root} " \
+ "video=${video}\0" \
"videoargs=" \
"setenv nextcon 0; " \
"if hdmidet; then " \
"setenv bootargs ${bootargs} " \
"video=mxcfb${nextcon}:dev=hdmi,1280x720M@60," \
"if=RGB24; " \
- "setenv fbmen fbmem=28M; " \
+ "setenv fbmem fbmem=28M; " \
"setexpr nextcon ${nextcon} + 1; " \
"else " \
"echo - no HDMI monitor;" \
@@ -186,41 +183,57 @@
@@ -143,27 +152,43 @@
"echo '- no FWBADAPT-7WVGA-LCD-F07A-0102 display';" \
"fi; " \
"setenv bootargs ${bootargs} ${fbmem}\0" \
@ -111,7 +83,7 @@ index b586803..542ed8b 100644
- "bootscript=echo Running bootscript from mmc ...; " \
- "source\0" \
- "loadimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${image}\0" \
- "loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
- "loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdtfile}\0" \
- "mmcboot=echo Booting from mmc ...; " \
- "run mmcargs; " \
- "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
@ -120,9 +92,9 @@ index b586803..542ed8b 100644
- "else " \
- "if test ${boot_fdt} = try; then " \
- "bootz; " \
+ "loadimage=load ${devtype} ${bootpart} ${loadaddr} ${bootdir}/${bootfile}\0" \
+ "loadimage=load ${devtype} ${bootpart} ${loadaddr} ${bootdir}/${image}\0" \
+ "loadrd=load ${devtype} ${bootpart} ${rdaddr} ${bootdir}/${rdfile}\0" \
+ "loadfdt=echo loading ${fdtdir}/${fdtfile} ...; load ${devtype} ${bootpart} ${fdtaddr} ${fdtdir}/${fdtfile}\0" \
+ "loadfdt=echo loading ${fdtdir}/${fdtfile} ...; load ${devtype} ${bootpart} ${fdt_addr} ${fdtdir}/${fdtfile}\0" \
+ "mmcboot=usb start;" \
+ "for devtype in mmc usb; do " \
+ "setenv devnum 0;" \
@ -146,9 +118,9 @@ index b586803..542ed8b 100644
+ "run mmcargs;" \
+ "if run loadfdt; then " \
+ "if run loadrd; then " \
+ "bootz ${loadaddr} ${rdaddr}:${filesize} ${fdtaddr};" \
+ "bootz ${loadaddr} ${rdaddr}:${filesize} ${fdt_addr};" \
+ "else " \
+ "bootz ${loadaddr} - ${fdtaddr};" \
+ "bootz ${loadaddr} - ${fdt_addr};" \
+ "fi;" \
+ "fi;" \
"else " \
@ -165,30 +137,11 @@ index b586803..542ed8b 100644
+ "done;\0" \
"netargs=setenv bootargs console=${console},${baudrate} " \
"root=/dev/nfs " \
- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
- "netboot=echo Booting from net ...; " \
+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
+ "netboot=echo Booting from net ...; " \
"run netargs; " \
"if test ${ip_dyn} = yes; then " \
"setenv get_cmd dhcp; " \
"else " \
"setenv get_cmd tftp; " \
"fi; " \
- "${get_cmd} ${image}; " \
+ "${get_cmd} ${bootfile}; " \
"if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
- "if ${get_cmd} ${fdt_addr} ${fdt_file}; then " \
- "bootz ${loadaddr} - ${fdt_addr}; " \
+ "if ${get_cmd} ${fdtaddr} ${fdtfile}; then " \
+ "bootz ${loadaddr} - ${fdtaddr}; " \
"else " \
"if test ${boot_fdt} = try; then " \
"bootz; " \
@@ -233,16 +246,7 @@
"fi;\0"
"ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
@@ -202,16 +227,7 @@
#define CONFIG_BOOTCOMMAND \
"run findfdt; " \
- "mmc dev ${mmcdev}; if mmc rescan; then " \
- "if run loadbootscript; then " \
- "run bootscript; " \
@ -199,18 +152,10 @@ index b586803..542ed8b 100644
- "fi; " \
- "fi; " \
- "else run netboot; fi"
+ "run mmcboot;"
+ "run mmcboot;"
/* Miscellaneous configurable options */
#define CONFIG_SYS_LONGHELP
@@ -280,6 +284,7 @@
#define CONFIG_OF_LIBFDT
#define CONFIG_CMD_BOOTZ
+#define CONFIG_SUPPORT_RAW_INITRD
#ifndef CONFIG_SYS_DCACHE_OFF
#define CONFIG_CMD_CACHE
/* Physical Memory Map */
#define CONFIG_NR_DRAM_BANKS 1
--
2.4.2
2.6.1

View file

@ -3,18 +3,20 @@
buildarch=4
pkgbase=uboot-wandboard
pkgname=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad')
pkgver=2015.04
pkgname=uboot-wandboard
pkgver=2015.10
pkgrel=1
pkgdesc="U-Boot for Wandboard"
arch=('armv7h')
url="http://git.denx.de/u-boot.git/"
license=('GPL')
makedepends=('git' 'bc')
replaces=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad')
install=${pkgname}.install
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
'0001-arch-linux-arm-modifications.patch')
md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
'7b1bcd38116d27e450705948cb8a87a7')
md5sums=('7c203b0fc3390a122d8e8b75f147eac5'
'710dbb0d9d4a2385f68ba14e86e97fdc')
prepare() {
cd u-boot-${pkgver}
@ -26,38 +28,14 @@ build() {
unset LDFLAGS
mkdir bins
for i in solo dl quad; do
make distclean
make wandboard_${i}_config
make
mv u-boot.imx bins/u-boot-${i}.imx
done
make distclean
make wandboard_defconfig
make
}
package_uboot-wandboard-solo() {
pkgdesc="U-Boot for Wandboard Solo"
conflicts=('uboot-wandboard-dual' 'uboot-wandboard-quad')
install=${pkgbase}.install
package() {
cd u-boot-${pkgver}
mkdir -p "${pkgdir}"/boot
cp u-boot-${pkgver}/bins/u-boot-solo.imx "${pkgdir}"/boot/u-boot.imx
}
package_uboot-wandboard-dual() {
pkgdesc="U-Boot for Wandboard Dual"
conflicts=('uboot-wandboard-solo' 'uboot-wandboard-quad')
install=${pkgbase}.install
mkdir -p "${pkgdir}"/boot
cp u-boot-${pkgver}/bins/u-boot-dl.imx "${pkgdir}"/boot/u-boot.imx
}
package_uboot-wandboard-quad() {
pkgdesc="U-Boot for Wandboard Quad"
conflicts=('uboot-wandboard-solo' 'uboot-wandboard-dual')
install=${pkgbase}.install
mkdir -p "${pkgdir}"/boot
cp u-boot-${pkgver}/bins/u-boot-quad.imx "${pkgdir}"/boot/u-boot.imx
cp SPL u-boot.img "${pkgdir}"/boot
}

View file

@ -1,13 +1,14 @@
flash_uboot() {
echo "A new U-Boot version needs to be flashed onto /dev/mmcblk0."
echo "Do you want to do this now? [y|N]"
echo "Do this now? [y|N]"
read -r shouldwe
if [[ $shouldwe =~ ^([yY][eE][sS]|[yY])$ ]]; then
dd if=/boot/u-boot.imx of=/dev/mmcblk0 bs=512 seek=2
sync
dd if=/boot/SPL of=/dev/mmcblk0 seek=1 bs=1k
dd if=/boot/u-boot.img of=/dev/mmcblk0 seek=69 bs=1k
else
echo "You can do this later by running:"
echo "# dd if=/boot/u-boot.imx of=/dev/mmcblk0 bs=512 seek=2"
echo "# dd if=/boot/SPL of=/dev/mmcblk0 seek=1 bs=1k"
echo "# dd if=/boot/u-boot.img of=/dev/mmcblk0 seek=69 bs=1k"
fi
}