mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
parent
355236be68
commit
01a25c335d
2 changed files with 43 additions and 3 deletions
32
community/libcec/0001-remove-default-to-zero.patch
Normal file
32
community/libcec/0001-remove-default-to-zero.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
From 4144242b59b65d36cf004778c172e351403b1a6a Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 3 Mar 2016 17:58:16 -0700
|
||||
Subject: [PATCH] remove default to zero
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
src/libcec/cmake/CheckPlatformSupport.cmake | 8 --------
|
||||
1 file changed, 8 deletions(-)
|
||||
|
||||
diff --git a/src/libcec/cmake/CheckPlatformSupport.cmake b/src/libcec/cmake/CheckPlatformSupport.cmake
|
||||
index b8a16c8..677469e 100644
|
||||
--- a/src/libcec/cmake/CheckPlatformSupport.cmake
|
||||
+++ b/src/libcec/cmake/CheckPlatformSupport.cmake
|
||||
@@ -22,14 +22,6 @@ set(PLATFORM_LIBREQUIRES "")
|
||||
include(CheckFunctionExists)
|
||||
include(FindPkgConfig)
|
||||
|
||||
-# defaults
|
||||
-set(HAVE_RANDR 0)
|
||||
-set(HAVE_LIBUDEV 0)
|
||||
-set(HAVE_RPI_API 0)
|
||||
-set(HAVE_TDA995X_API 0)
|
||||
-set(HAVE_EXYNOS_API 0)
|
||||
-set(HAVE_P8_USB_DETECT 0)
|
||||
-set(HAVE_DRM_EDID_PARSER 0)
|
||||
# Pulse-Eight devices are always supported
|
||||
set(HAVE_P8_USB 1)
|
||||
|
||||
--
|
||||
2.7.1
|
||||
|
|
@ -5,20 +5,28 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Exynos support on v7
|
||||
# - patch to remove default to zero forces
|
||||
|
||||
buildarch=14
|
||||
|
||||
pkgname=libcec
|
||||
pkgver=3.1.0
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://libcec.pulse-eight.com/"
|
||||
license=('GPL')
|
||||
makedepends=('cmake')
|
||||
depends=('udev' 'lockdev' 'libplatform' 'libxrandr')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz")
|
||||
sha256sums=('09109d21a1b03f42c9e341d12600f2e4c41038d640269fa75408e2d36126f921')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz"
|
||||
'0001-remove-default-to-zero.patch')
|
||||
sha256sums=('09109d21a1b03f42c9e341d12600f2e4c41038d640269fa75408e2d36126f921'
|
||||
'33ce3121e393d7f5c162487d82aac9372a246cdb6eca73f0cfbde61bfaffa50f')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgname-$pkgver"
|
||||
patch -p1 -i ../0001-remove-default-to-zero.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgname-$pkgver"
|
||||
|
|
Loading…
Reference in a new issue