extra/kwin to 5.2.0-1

This commit is contained in:
Kevin Mihelich 2015-01-27 13:02:48 +00:00
parent fbaa7bf27d
commit 01d1737bc3
3 changed files with 21 additions and 43 deletions

View file

@ -8,14 +8,14 @@
# - Proper upstream patches for the above are pending.
pkgname=kwin
pkgver=5.1.2
pkgver=5.2.0
pkgrel=1
pkgdesc='KDE Window manager'
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/workspace/kwin'
license=('LGPL')
depends=('qt5-multimedia' 'plasma-framework' 'knewstuff' 'libxcursor' 'kinit'
'hicolor-icon-theme' 'libepoxy')
'hicolor-icon-theme' 'libepoxy' 'kwayland' 'libinput' 'kdecoration')
makedepends=('extra-cmake-modules' 'qt5-tools' 'kdoctools')
groups=('plasma-next')
install=${pkgname}.install
@ -23,12 +23,12 @@ conflicts=('kdebase-workspace')
source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz"
"rpi_fix_build.patch"
"kwin_remove_eglonxbackend.patch")
md5sums=('feb97cc6591e2526406d988a8fcf2f20'
md5sums=('59c1998d48a706b8ac48222e48d392bd'
'3e11a42013f03d55b4b730463bdd6fe0'
'28a1e8bd701a8fd1421e6ec238b4c522')
prepare() {
mkdir -p build
mkdir build
cd "${pkgname}-${pkgver}"
@ -59,7 +59,6 @@ build() {
-DLIB_INSTALL_DIR=lib \
-DLIBEXEC_INSTALL_DIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DQML_INSTALL_DIR=lib/qt/qml \
-DBUILD_TESTING=OFF \
$CMAKE_EXTRA_CONFIG_OPTIONS
make

View file

@ -1,8 +1,7 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4058b34..a1f2060 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -397,10 +397,6 @@ if(KWIN_BUILD_ACTIVITIES)
diff -urN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2015-01-26 03:44:19.000000000 -0700
+++ b/CMakeLists.txt 2015-01-27 06:00:42.290677955 -0700
@@ -392,10 +392,6 @@
)
endif()
@ -13,11 +12,10 @@ index 4058b34..a1f2060 100644
if(HAVE_WAYLAND)
set(kwin_KDEINIT_SRCS
${kwin_KDEINIT_SRCS}
diff --git a/scene_opengl.cpp b/scene_opengl.cpp
index bacc980..e19bb00 100644
--- a/scene_opengl.cpp
+++ b/scene_opengl.cpp
@@ -28,7 +28,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
diff -urN a/scene_opengl.cpp b/scene_opengl.cpp
--- a/scene_opengl.cpp 2015-01-26 03:27:31.000000000 -0700
+++ b/scene_opengl.cpp 2015-01-27 06:00:42.295677953 -0700
@@ -28,7 +28,6 @@
*********************************************************************/
#include "scene_opengl.h"
#ifdef KWIN_HAVE_EGL
@ -25,7 +23,7 @@ index bacc980..e19bb00 100644
// for Wayland
#if HAVE_WAYLAND_EGL
#include "egl_wayland_backend.h"
@@ -437,10 +436,10 @@ SceneOpenGL *SceneOpenGL::createScene()
@@ -488,10 +487,10 @@
if (kwinApp()->shouldUseWaylandForCompositing()) {
backend = new EglWaylandBackend();
} else {

View file

@ -1,25 +1,7 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4745df..4058b34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -222,10 +222,12 @@ set(KWIN_BUILD_OPENGL FALSE)
set(KWIN_BUILD_OPENGLES FALSE)
if(OPENGL_FOUND AND (${Qt5Gui_OPENGL_IMPLEMENTATION} STREQUAL "GL"))
set(KWIN_BUILD_OPENGL TRUE)
+ include_directories(${OPENGL_INCLUDE_DIR})
message("Building KWin with OpenGL support")
endif()
if(OPENGLES_FOUND AND (${Qt5Gui_OPENGL_IMPLEMENTATION} STREQUAL "GLESv2"))
set(KWIN_BUILD_OPENGLES TRUE)
+ include_directories(${OPENGLES_INCLUDE_DIR} ${OPENGLES_EGL_INCLUDE_DIR})
message("Building KWin with OpenGL ES 2 support")
endif()
diff --git a/libkwineffects/kwinglplatform.cpp b/libkwineffects/kwinglplatform.cpp
index 548d459..5e5b25b 100644
--- a/libkwineffects/kwinglplatform.cpp
+++ b/libkwineffects/kwinglplatform.cpp
@@ -25,6 +25,8 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
diff -urN a/libkwineffects/kwinglplatform.cpp b/libkwineffects/kwinglplatform.cpp
--- a/libkwineffects/kwinglplatform.cpp 2015-01-26 03:27:31.000000000 -0700
+++ b/libkwineffects/kwinglplatform.cpp 2015-01-27 05:56:33.605773992 -0700
@@ -25,6 +25,8 @@
#include <QStringList>
#include <QDebug>
@ -28,11 +10,10 @@ index 548d459..5e5b25b 100644
#include <sys/utsname.h>
#include <iostream>
diff --git a/libkwineffects/kwingltexture.cpp b/libkwineffects/kwingltexture.cpp
index 97d2747..1dcf0e3 100644
--- a/libkwineffects/kwingltexture.cpp
+++ b/libkwineffects/kwingltexture.cpp
@@ -186,7 +186,7 @@ void GLTexturePrivate::cleanup()
diff -urN a/libkwineffects/kwingltexture.cpp b/libkwineffects/kwingltexture.cpp
--- a/libkwineffects/kwingltexture.cpp 2015-01-26 03:27:31.000000000 -0700
+++ b/libkwineffects/kwingltexture.cpp 2015-01-27 05:56:33.605773992 -0700
@@ -315,7 +315,7 @@
bool GLTexture::isNull() const
{
Q_D(const GLTexture);