community/v8 => 3.11.10, community/nodejs => 0.8.0

This commit is contained in:
WarheadsSE 2012-06-25 21:16:17 -04:00
parent 60b30a719a
commit 01d2c127d2
3 changed files with 6 additions and 39 deletions

View file

@ -9,7 +9,7 @@
plugrel=1
pkgname=nodejs
pkgver=0.6.19
pkgver=0.8.0
pkgrel=1
pkgdesc='Evented I/O for V8 javascript'
arch=('i686' 'x86_64' 'arm')
@ -19,10 +19,8 @@ depends=('python2' 'v8')
checkdepends=('curl') # curl used for check()
optdepends=('openssl: TLS support')
options=('!emptydirs')
source=("http://nodejs.org/dist/v${pkgver}/node-v${pkgver}.tar.gz"
'nodejs-armv5t.patch')
md5sums=('f5669a9717422b811c6bad1cc961b1e5'
'27eb4bfa8da9707b6b326e47e99995de')
source=("http://nodejs.org/dist/v${pkgver}/node-v${pkgver}.tar.gz")
md5sums=('7efde00ad3292d4c56ad607ab676d935')
build() {
cd node-v${pkgver}
@ -30,10 +28,9 @@ build() {
msg 'fixing for python2 name'
find -type f -exec sed -e 's_^#!/usr/bin/env python$_&2_' -e 's_^\(#!/usr/bin/python2\).[45]$_\1_' -e 's_^#!/usr/bin/python$_&2_' -e "s_'python'_'python2'_" -i {} \;
find test -type f -exec sed -e "s|python |python2 |" -i {} \;
sed -i "s|cmd_R = 'python |cmd_R = 'python2 |" wscript
sed -i "s|python |python2 |" Makefile
find test -type f -exec sed -e 's/python/&2/' -i {} \;
sed -i "s/python/&2/" configure
# find test -type f -exec sed -e 's/python/&2/' -i {} \;
sed -i "s/python /python2 /" configure
export PYTHON=python2
# we're going to attept to make use of this example

View file

@ -1,30 +0,0 @@
--- ../node-v0.6.8/deps/v8/SConstruct.org 2012-01-26 13:57:18.000000000 -0500
+++ ../node-v0.6.8/deps/v8/SConstruct 2012-01-26 15:08:37.000000000 -0500
@@ -79,7 +79,7 @@
},
'gcc': {
'all': {
- 'CCFLAGS': ['$DIALECTFLAGS', '$WARNINGFLAGS'],
+ 'CCFLAGS': ['$DIALECTFLAGS', '$WARNINGFLAGS', '-march=armv5t'],
'CXXFLAGS': ['-fno-rtti', '-fno-exceptions'],
},
'visibility:hidden': {
@@ -154,12 +154,12 @@
},
'armeabi:softfp' : {
'CPPDEFINES' : ['USE_EABI_HARDFLOAT=0'],
- 'vfp3:on': {
- 'CPPDEFINES' : ['CAN_USE_VFP_INSTRUCTIONS']
- },
- 'simulator:none': {
- 'CCFLAGS': ['-mfloat-abi=softfp'],
- }
+# 'vfp3:on': {
+# 'CPPDEFINES' : ['CAN_USE_VFP_INSTRUCTIONS']
+# },
+# 'simulator:none': {
+# 'CCFLAGS': ['-mfloat-abi=softfp'],
+# }
},
'armeabi:hard' : {
'CPPDEFINES' : ['USE_EABI_HARDFLOAT=1'],

View file

@ -3,7 +3,7 @@
# Contributor: tocer <tocer.deng@gmail.com>
pkgname=v8
pkgver=3.9.9
pkgver=3.11.10
pkgrel=1
plugrel=1
pkgdesc='A fast and modern javascript engine'