extra/chromium to 79.0.3945.130-2

This commit is contained in:
Kevin Mihelich 2020-01-17 19:00:54 +00:00
parent 8b76613ea7
commit 01d3bf3686
2 changed files with 34 additions and 1 deletions

View file

@ -16,7 +16,7 @@ highmem=1
pkgname=chromium
pkgver=79.0.3945.130
pkgrel=1
pkgrel=2
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
@ -37,6 +37,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
launch_manager.h-uses-std-vector.patch
include-algorithm-to-use-std-lower_bound.patch
icu65.patch
sync-enable-USSPasswords-by-default.patch
chromium-system-icu.patch
chromium-system-zlib.patch
chromium-system-hb.patch
@ -49,6 +50,7 @@ sha256sums=('56193431ab9d1193773b133d86b419bfae8d8b9196eea253660895e0e8f87ba0'
'bd0fae907c451252e91c4cbf1ad301716bc9f8a4644ecc60e9590a64197477d3'
'1f906676563e866e2b59719679e76e0b2f7f082f48ef0593e86da0351a586c73'
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
'08ef82476780e0864b5bf7f20eb19db320e73b9a5d4f595351e12e97dda8746f'
'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
'eb67eda4945a89c3b90473fa8dc20637511ca4dcb58879a8ed6bf403700ca9c8'
'c0ad3fa426cb8fc1a237ddc6309a6b2dd4055bbe41dd07f50071ee61f969b81a'
@ -122,6 +124,9 @@ prepare() {
# https://crbug.com/1014272
patch -Np1 -i ../icu65.patch
# https://crbug.com/1027929
patch -Np1 -i ../sync-enable-USSPasswords-by-default.patch
# Fixes from Gentoo
patch -Np1 -i ../chromium-system-icu.patch
patch -Np1 -i ../chromium-system-zlib.patch

View file

@ -0,0 +1,28 @@
From eb997db5527c01fd12c321a6abc52b7cff882e50 Mon Sep 17 00:00:00 2001
From: Mohamed Amir Yosef <mamir@chromium.org>
Date: Thu, 9 Jan 2020 21:22:19 +0000
Subject: [PATCH] [Sync] Enable USSPasswords by default
Change-Id: I021cd952d7a2917a8fb7203cabdac612251193df
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1963804
Auto-Submit: Mohamed Amir Yosef <mamir@chromium.org>
Reviewed-by: Mikel Astiz <mastiz@chromium.org>
Commit-Queue: Mohamed Amir Yosef <mamir@chromium.org>
Cr-Commit-Position: refs/heads/master@{#729902}
---
components/sync/driver/sync_driver_switches.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/components/sync/driver/sync_driver_switches.cc b/components/sync/driver/sync_driver_switches.cc
index ddff8b91419..999384aa68a 100644
--- a/components/sync/driver/sync_driver_switches.cc
+++ b/components/sync/driver/sync_driver_switches.cc
@@ -55,7 +55,7 @@ const base::Feature kStopSyncInPausedState{"StopSyncInPausedState",
// Enable USS implementation of Passwords datatype.
const base::Feature kSyncUSSPasswords{"SyncUSSPasswords",
- base::FEATURE_DISABLED_BY_DEFAULT};
+ base::FEATURE_ENABLED_BY_DEFAULT};
// Enable USS implementation of Nigori datatype.
const base::Feature kSyncUSSNigori{"SyncUSSNigori",