extra/chromium to 124.0.6367.155-1

This commit is contained in:
Kevin Mihelich 2024-05-08 00:46:32 +00:00
parent 1266b34c86
commit 021bcfccc4
3 changed files with 5 additions and 41 deletions

View file

@ -1,6 +1,6 @@
pkgbase = chromium
pkgdesc = A web browser built for speed, simplicity, and security
pkgver = 124.0.6367.118
pkgver = 124.0.6367.155
pkgrel = 1
url = https://www.chromium.org/Home
arch = x86_64
@ -53,7 +53,7 @@ pkgbase = chromium
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: support for storing passwords in KWallet on Plasma
options = !lto
source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-124.0.6367.118.tar.xz
source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-124.0.6367.155.tar.xz
source = https://github.com/foutrelis/chromium-launcher/archive/v8/chromium-launcher-8.tar.gz
source = https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/124/chromium-patches-124.tar.bz2
source = fix-a-missing-build-dependency.patch
@ -61,7 +61,7 @@ pkgbase = chromium
source = compiler-rt-adjust-paths.patch
source = qt-6.7.patch
source = use-oauth2-client-switches-as-default.patch
sha256sums = 8aa5a14aad1234b48b568da9ef23d6e0b1b72d7f4ca5c4039462e54e6ad45d96
sha256sums = 667d5b3522238b2458816b7e409540e47e9e70c8f2921f64342408fa2323bbc4
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
sha256sums = c2bc4e65ed2a4e23528dd10d5c15bf99f880b7bbb789cc720d451b78098a7e12
sha256sums = 75e1482d1b27c34ebe9d4bf27104fedcc219cdd95ce71fc41e77a486befd3f93

View file

@ -15,7 +15,7 @@
highmem=1
pkgname=chromium
pkgver=124.0.6367.118
pkgver=124.0.6367.155
pkgrel=1
_launcher_ver=8
_manual_clone=0
@ -41,18 +41,16 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
fix-a-missing-build-dependency.patch
drop-flag-unsupported-by-clang17.patch
compiler-rt-adjust-paths.patch
qt-6.7.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch)
sha256sums=('8aa5a14aad1234b48b568da9ef23d6e0b1b72d7f4ca5c4039462e54e6ad45d96'
sha256sums=('667d5b3522238b2458816b7e409540e47e9e70c8f2921f64342408fa2323bbc4'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'c2bc4e65ed2a4e23528dd10d5c15bf99f880b7bbb789cc720d451b78098a7e12'
'75e1482d1b27c34ebe9d4bf27104fedcc219cdd95ce71fc41e77a486befd3f93'
'3bd35dab1ded5d9e1befa10d5c6c4555fe0a76d909fb724ac57d0bf10cb666c1'
'b3de01b7df227478687d7517f61a777450dca765756002c80c4915f271e2d961'
'e30623f36c54f4af3a8aa7d9400f7d2bed6ef560f15d665d2aa8fd777cb2565f'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'2ed2148c3d2bfad4bf4025767d293b3b1b591c995a02a5cb0831040592bce4d9'
'71b879dd53bb6651ff621dc3e063f74f0865dd451fa707d3a1178854fa8dcee2'
@ -148,9 +146,6 @@ prepare() {
# Allow libclang_rt.builtins from compiler-rt >= 16 to be used
patch -Np1 -i ../compiler-rt-adjust-paths.patch
# Fix build with Qt 6.7
patch -Np1 -i ../qt-6.7.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../chromium-patches-*/chromium-117-material-color-include.patch

View file

@ -1,31 +0,0 @@
From 3a812de6e7e0b285eda21ebbb670ca809c4db2b5 Mon Sep 17 00:00:00 2001
From: Matt Jolly <Matt.Jolly@footclan.ninja>
Date: Thu, 11 Apr 2024 12:42:17 +1000
Subject: [PATCH] Add QtGui to the list of Qt modules
Re: https://bugreports.qt.io/browse/QTBUG-124135 - certain versions of QT
(6.6.3, 6.7.0) produce pkg-config files that no longer emit dependencies.
This causes Chromium builds to fail as due to not seeing QtGui as a dependency
of QtWidgets:
`gen/qt6/../../../../ui/qt/qt_shim.h:11:10: fatal error: 'QImage' file not found`
While this has been resolved upstream, there will certainly be some users
that are still using these versions of QT. This patch adds QtGui to the list of
Qt modules that are required to build the Chromium UI.
Bug: https://bugs.gentoo.org/928299
Suggested-by: Chris Pritchard <chris@christopherpritchard.co.uk>
Signed-off-by: Matt Jolly <kangie@gentoo.org>
--- a/ui/qt/BUILD.gn
+++ b/ui/qt/BUILD.gn
@@ -60,6 +60,7 @@ template("qt_shim") {
pkg_config("qt" + invoker.qt_version + "_config") {
packages = [
"Qt" + invoker.qt_version + "Core",
+ "Qt" + invoker.qt_version + "Gui",
"Qt" + invoker.qt_version + "Widgets",
]
}
--
2.44.0