extra/cantor to 17.04.2-2

This commit is contained in:
Kevin Mihelich 2017-06-26 00:21:36 +00:00
parent f948dacc51
commit 02321ad894
2 changed files with 22 additions and 3 deletions

View file

@ -7,7 +7,7 @@
pkgname=cantor
pkgver=17.04.2
pkgrel=1
pkgrel=2
pkgdesc="KDE Frontend to Mathematical Software"
url="https://kde.org/applications/education/cantor/"
arch=('i686' 'x86_64')
@ -24,13 +24,18 @@ optdepends=('maxima: Maxima backend'
'sagemath: SageMath backend')
conflicts=('kdeedu-cantor')
replaces=('kdeedu-cantor')
source=("https://download.kde.org/stable/applications/${pkgver}/src/cantor-${pkgver}.tar.xz"{,.sig})
source=("https://download.kde.org/stable/applications/${pkgver}/src/cantor-${pkgver}.tar.xz"{,.sig} cantor-julia-0.6.patch)
sha256sums=('f194eba838c08dea49877fecf17091f598b70f5357f4574388d91c8bc1392120'
'SKIP')
'SKIP'
'0d57a2edd7eb2c156ff0dee6c67b6e5679d68f55f2426e77c92f25c2ec3b1f61')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7) # Albert Astals Cid <aacid@kde.org>
prepare() {
mkdir -p build
cd $pkgname-$pkgver
# fix build with julia 0.6
patch -p1 -i ../cantor-julia-0.6.patch
}
build() {

View file

@ -0,0 +1,14 @@
diff --git a/src/backends/julia/juliaserver/juliaserver.cpp b/src/backends/julia/juliaserver/juliaserver.cpp
index dc8a48e5..91c2c338 100644
--- a/src/backends/julia/juliaserver/juliaserver.cpp
+++ b/src/backends/julia/juliaserver/juliaserver.cpp
@@ -40,7 +40,7 @@ JuliaServer::~JuliaServer()
void JuliaServer::login(const QString &path) const
{
QString dir_path = QFileInfo(path).dir().absolutePath();
- jl_init(dir_path.toLatin1().constData());
+ jl_init_with_image(dir_path.toLatin1().constData(), NULL);
}
void JuliaServer::runJuliaCommand(const QString &command)