mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/thunderbird to 52.0-1
This commit is contained in:
parent
aad5f52cf1
commit
0285d09f2f
5 changed files with 47 additions and 6162 deletions
|
@ -7,33 +7,32 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - mozconfig changes for ARM
|
||||
# - remove cargo makedepend
|
||||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=45.8.0
|
||||
pkgver=52.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone mail and news reader from mozilla.org"
|
||||
arch=(i686 x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
url="https://www.mozilla.org/thunderbird/"
|
||||
depends=(gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
|
||||
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
|
||||
libvpx libevent nss hunspell sqlite ttf-font icu)
|
||||
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils)
|
||||
optdepends=('libcanberra: for sound support')
|
||||
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
|
||||
autoconf2.13)
|
||||
optdepends=('libcanberra: sound support')
|
||||
options=(!emptydirs !makeflags)
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
|
||||
thunderbird.desktop
|
||||
thunderbird-install-dir.patch fix-wifi-scanner.diff
|
||||
firefox-gcc-6.0.patch mozilla-1228540.patch mozilla-1228540-1.patch)
|
||||
sha256sums=('743cbf4856ad460a791f6b17bff175053fccec2af1edd8e8295ac6fda2634c28'
|
||||
thunderbird-install-dir.patch rust-i686.patch fix-wifi-scanner.diff)
|
||||
sha256sums=('44e148b1ebd4135a6923a5403792035cf170745e7e99c4ec85142988dd6b26c6'
|
||||
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
|
||||
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
|
||||
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
|
||||
'4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf'
|
||||
'3a3e84c702ee31450a3e84698441aceb11cf44e64c9fedcaddb8cb50db759417'
|
||||
'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19')
|
||||
'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
|
||||
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
@ -47,7 +46,6 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
|
|||
# more information.
|
||||
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
|
||||
|
||||
|
||||
prepare() {
|
||||
mkdir path
|
||||
ln -s /usr/bin/python2 path/python
|
||||
|
@ -58,10 +56,8 @@ prepare() {
|
|||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
|
||||
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
|
||||
|
||||
# Required for GCC 6
|
||||
patch -d mozilla -Np1 < ../firefox-gcc-6.0.patch
|
||||
patch -d mozilla -Np1 < ../mozilla-1228540.patch
|
||||
patch -d mozilla -Np1 < ../mozilla-1228540-1.patch
|
||||
# Build with the rust targets we actually ship
|
||||
patch -d mozilla -Np1 < ../rust-i686.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
@ -76,6 +72,8 @@ ac_add_options --enable-pie
|
|||
|
||||
# Branding
|
||||
ac_add_options --enable-official-branding
|
||||
ac_add_options --enable-update-channel=release
|
||||
ac_add_options --with-distribution-id=org.archlinux
|
||||
|
||||
# Keys
|
||||
ac_add_options --with-google-api-keyfile=${PWD@Q}/google-api-key
|
||||
|
@ -97,8 +95,8 @@ ac_add_options --enable-system-pixman
|
|||
|
||||
# Features
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --disable-gstreamer
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --enable-alsa
|
||||
ac_add_options --disable-updater
|
||||
|
||||
STRIP_FLAGS="--strip-debug"
|
||||
|
@ -118,11 +116,11 @@ build() {
|
|||
# Hardening
|
||||
LDFLAGS+=" -Wl,-z,now"
|
||||
|
||||
# GCC 6
|
||||
CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
|
||||
# Do PGO
|
||||
#xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
|
||||
# make -f client.mk build MOZ_PGO=1
|
||||
make -f client.mk build
|
||||
}
|
||||
|
||||
|
@ -141,6 +139,19 @@ pref("mail.shell.checkDefaultMail", false);
|
|||
// Don't disable our bundled extensions in the application directory
|
||||
pref("extensions.autoDisableScopes", 11);
|
||||
pref("extensions.shownSelectionUI", true);
|
||||
END
|
||||
|
||||
_distini="$pkgdir/usr/lib/thunderbird/distribution/distribution.ini"
|
||||
install -Dm644 /dev/stdin "$_distini" <<END
|
||||
[Global]
|
||||
id=archlinux
|
||||
version=1.0
|
||||
about=Mozilla Thunderbird for Arch Linux
|
||||
|
||||
[Preferences]
|
||||
app.distributor=archlinux
|
||||
app.distributor.channel=$pkgname
|
||||
app.partner.archlinux=archlinux
|
||||
END
|
||||
|
||||
for i in 16 22 24 32 48 256; do
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
diff -up firefox-44.0/nsprpub/config/make-system-wrappers.pl.back firefox-44.0/nsprpub/config/make-system-wrappers.pl
|
||||
--- firefox-44.0/nsprpub/config/make-system-wrappers.pl.back 2016-01-24 00:23:49.000000000 +0100
|
||||
+++ firefox-44.0/nsprpub/config/make-system-wrappers.pl 2016-02-02 14:58:45.064112655 +0100
|
||||
@@ -19,7 +19,9 @@ while (<STDIN>) {
|
||||
open OUT, ">$output_dir/$_";
|
||||
print OUT "#pragma GCC system_header\n"; # suppress include_next warning
|
||||
print OUT "#pragma GCC visibility push(default)\n";
|
||||
+ print OUT "#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
|
||||
print OUT "#include_next \<$_\>\n";
|
||||
+ print OUT "#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
|
||||
print OUT "#pragma GCC visibility pop\n";
|
||||
close OUT;
|
||||
}
|
||||
diff -up firefox-44.0/mozglue/build/arm.cpp.old firefox-44.0/mozglue/build/arm.cpp
|
||||
--- firefox-44.0/mozglue/build/arm.cpp.old 2016-02-03 10:07:29.879526500 +0100
|
||||
+++ firefox-44.0/mozglue/build/arm.cpp 2016-02-03 10:08:11.062697517 +0100
|
||||
@@ -104,7 +104,9 @@ check_neon(void)
|
||||
|
||||
# elif defined(__linux__) || defined(ANDROID)
|
||||
# include <stdio.h>
|
||||
+#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS
|
||||
# include <stdlib.h>
|
||||
+#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS
|
||||
# include <string.h>
|
||||
|
||||
enum{
|
|
@ -1,84 +0,0 @@
|
|||
# HG changeset patch
|
||||
# User Jonathan Kew <jkew@mozilla.com>
|
||||
# Date 1452675061 0
|
||||
# Wed Jan 13 08:51:01 2016 +0000
|
||||
# Node ID cf699e95e98829b465b64a7e0281d95ec851ce8c
|
||||
# Parent 3c9f357598e86c2f593e9895d5725bf3498f8f5a
|
||||
Bug 1228540 - pt 2 - Remove our HBGetGlyphHOrigin callback, as the default behavior is sufficient.
|
||||
|
||||
diff --git a/gfx/thebes/gfxHarfBuzzShaper.cpp b/gfx/thebes/gfxHarfBuzzShaper.cpp
|
||||
--- a/gfx/thebes/gfxHarfBuzzShaper.cpp
|
||||
+++ b/gfx/thebes/gfxHarfBuzzShaper.cpp
|
||||
@@ -349,27 +349,16 @@ gfxHarfBuzzShaper::HBGetGlyphVAdvance(hb
|
||||
static_cast<const gfxHarfBuzzShaper::FontCallbackData*>(font_data);
|
||||
// Currently, we don't offer gfxFont subclasses a method to override this
|
||||
// and provide hinted platform-specific vertical advances (analogous to the
|
||||
// GetGlyphWidth method for horizontal advances). If that proves necessary,
|
||||
// we'll add a new gfxFont method and call it from here.
|
||||
return fcd->mShaper->GetGlyphVAdvance(glyph);
|
||||
}
|
||||
|
||||
-/* static */
|
||||
-hb_bool_t
|
||||
-gfxHarfBuzzShaper::HBGetGlyphHOrigin(hb_font_t *font, void *font_data,
|
||||
- hb_codepoint_t glyph,
|
||||
- hb_position_t *x, hb_position_t *y,
|
||||
- void *user_data)
|
||||
-{
|
||||
- // We work in horizontal coordinates, so no origin adjustment needed here.
|
||||
- return true;
|
||||
-}
|
||||
-
|
||||
struct VORG {
|
||||
AutoSwap_PRUint16 majorVersion;
|
||||
AutoSwap_PRUint16 minorVersion;
|
||||
AutoSwap_PRInt16 defaultVertOriginY;
|
||||
AutoSwap_PRUint16 numVertOriginYMetrics;
|
||||
};
|
||||
|
||||
struct VORGrec {
|
||||
@@ -1262,19 +1251,16 @@ gfxHarfBuzzShaper::Initialize()
|
||||
hb_font_funcs_set_glyph_func(sHBFontFuncs, HBGetGlyph,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_h_advance_func(sHBFontFuncs,
|
||||
HBGetGlyphHAdvance,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_v_advance_func(sHBFontFuncs,
|
||||
HBGetGlyphVAdvance,
|
||||
nullptr, nullptr);
|
||||
- hb_font_funcs_set_glyph_h_origin_func(sHBFontFuncs,
|
||||
- HBGetGlyphHOrigin,
|
||||
- nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_v_origin_func(sHBFontFuncs,
|
||||
HBGetGlyphVOrigin,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_extents_func(sHBFontFuncs,
|
||||
HBGetGlyphExtents,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_contour_point_func(sHBFontFuncs,
|
||||
HBGetContourPoint,
|
||||
diff --git a/gfx/thebes/gfxHarfBuzzShaper.h b/gfx/thebes/gfxHarfBuzzShaper.h
|
||||
--- a/gfx/thebes/gfxHarfBuzzShaper.h
|
||||
+++ b/gfx/thebes/gfxHarfBuzzShaper.h
|
||||
@@ -56,21 +56,16 @@ public:
|
||||
hb_codepoint_t glyph, void *user_data);
|
||||
|
||||
// get harfbuzz vertical advance in 16.16 fixed point format.
|
||||
static hb_position_t
|
||||
HBGetGlyphVAdvance(hb_font_t *font, void *font_data,
|
||||
hb_codepoint_t glyph, void *user_data);
|
||||
|
||||
static hb_bool_t
|
||||
- HBGetGlyphHOrigin(hb_font_t *font, void *font_data,
|
||||
- hb_codepoint_t glyph,
|
||||
- hb_position_t *x, hb_position_t *y,
|
||||
- void *user_data);
|
||||
- static hb_bool_t
|
||||
HBGetGlyphVOrigin(hb_font_t *font, void *font_data,
|
||||
hb_codepoint_t glyph,
|
||||
hb_position_t *x, hb_position_t *y,
|
||||
void *user_data);
|
||||
|
||||
hb_position_t GetHKerning(uint16_t aFirstGlyph,
|
||||
uint16_t aSecondGlyph) const;
|
||||
|
File diff suppressed because it is too large
Load diff
16
extra/thunderbird/rust-i686.patch
Normal file
16
extra/thunderbird/rust-i686.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
build/moz.configure/rust.configure | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
|
||||
index cd86b24153debb1b..44911715e25d95e3 100644
|
||||
--- c/build/moz.configure/rust.configure
|
||||
+++ i/build/moz.configure/rust.configure
|
||||
@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
|
||||
# OpenBSD
|
||||
('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
|
||||
# Linux
|
||||
- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
|
||||
+ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
|
||||
# Linux
|
||||
('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
|
||||
# OS X and iOS
|
Loading…
Reference in a new issue