mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/pacman to 3.5.4-3
This commit is contained in:
parent
dd1a641645
commit
029f841fa9
3 changed files with 59 additions and 18 deletions
|
@ -5,8 +5,8 @@
|
|||
plugrel=1
|
||||
|
||||
pkgname=netatalk
|
||||
pkgver=2.2
|
||||
pkgrel=2
|
||||
pkgver=2.2.0
|
||||
pkgrel=3
|
||||
pkgdesc="A kernel level implementation of the AppleTalk Protocol Suite"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://netatalk.sourceforge.net"
|
||||
|
@ -21,7 +21,7 @@ backup=('etc/netatalk/afpd.conf'
|
|||
'etc/avahi/services/afpd.service')
|
||||
depends=('libcups' 'tcp_wrappers' 'avahi' 'openssl' 'pam' 'coreutils>=7.1-2' 'db')
|
||||
makedepends=('make' 'patch' 'gcc')
|
||||
source=(http://voxel.dl.sourceforge.net/project/netatalk/netatalk/$pkgver/netatalk-$pkgver-beta4.tar.bz2 \
|
||||
source=(http://voxel.dl.sourceforge.net/project/netatalk/netatalk/2.2/netatalk-$pkgver.tar.bz2 \
|
||||
afpd atalkd papd cnid afpd.service)
|
||||
install=netatalk.install
|
||||
md5sums=('34be63cc07ed3ae606712028a9265216'
|
||||
|
@ -32,21 +32,25 @@ md5sums=('34be63cc07ed3ae606712028a9265216'
|
|||
'9b6b2fee54fe052bba0c69f00d335bdb')
|
||||
|
||||
build() {
|
||||
cd $startdir/src/netatalk-$pkgver-beta4
|
||||
cd "${srcdir}/netatalk-${pkgver}"
|
||||
./configure --prefix=/usr --with-cnid-cdb-backend --with-ssl-dir=/usr --localstatedir=/var --enable-fhs --enable-zeroconf=/usr --disable-srvloc --without-xfs
|
||||
make || return 1
|
||||
make DESTDIR=$startdir/pkg install
|
||||
}
|
||||
|
||||
mv $startdir/pkg/usr/include/netatalk{,2}
|
||||
package() {
|
||||
cd "${srcdir}/netatalk-${pkgver}"
|
||||
make DESTDIR=${pkgdir} install
|
||||
|
||||
install -d $startdir/pkg/etc/rc.d
|
||||
install -m755 ../{afpd,atalkd,papd,cnid} $startdir/pkg/etc/rc.d
|
||||
mv ${pkgdir}/usr/include/netatalk{,2}
|
||||
|
||||
install -d ${pkgdir}/etc/rc.d
|
||||
install -m755 ../{afpd,atalkd,papd,cnid} ${pkgdir}/etc/rc.d
|
||||
|
||||
install -d $startdir/pkg/etc/avahi/services
|
||||
install -m755 ../afpd.service $startdir/pkg/etc/avahi/services
|
||||
install -d ${pkgdir}/etc/avahi/services
|
||||
install -m755 ../afpd.service ${pkgdir}/etc/avahi/services
|
||||
|
||||
|
||||
# rm $startdir/pkg/usr/bin/timeout
|
||||
rm -f $startdir/pkg/usr/share/man/man1/timeout.1{,.gz}
|
||||
rm -f ${pkgdir}/usr/share/man/man1/timeout.1{,.gz}
|
||||
}
|
||||
|
||||
|
|
32
core/pacman/0001-makepkg-fix-removing-symbolic-link.patch
Normal file
32
core/pacman/0001-makepkg-fix-removing-symbolic-link.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
From c493eef643ecb3a54c79083c51a8975f816ed9de Mon Sep 17 00:00:00 2001
|
||||
From: Allan McRae <allan@archlinux.org>
|
||||
Date: Tue, 28 Jun 2011 22:47:35 +1000
|
||||
Subject: [PATCH] makepkg: fix removing symbolic link
|
||||
|
||||
The path was not being stripped from $file before prefixing with
|
||||
$srcdir resulting in the attempted removal of a very weird
|
||||
filename.
|
||||
|
||||
Signed-off-by: Allan McRae <allan@archlinux.org>
|
||||
Signed-off-by: Dan McGee <dan@archlinux.org>
|
||||
(cherry picked from commit e92905a2c8c14c7855e2841f44d3c139aa40844c)
|
||||
---
|
||||
scripts/makepkg.sh.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
|
||||
index 3ace945..b0b0882 100644
|
||||
--- a/scripts/makepkg.sh.in
|
||||
+++ b/scripts/makepkg.sh.in
|
||||
@@ -509,7 +509,7 @@ download_sources() {
|
||||
local file=$(get_filepath "$netfile" || true)
|
||||
if [[ -n "$file" ]]; then
|
||||
msg2 "$(gettext "Found %s")" "${file##*/}"
|
||||
- rm -f "$srcdir/$file"
|
||||
+ rm -f "$srcdir/${file##*/}"
|
||||
ln -s "$file" "$srcdir/"
|
||||
continue
|
||||
fi
|
||||
--
|
||||
1.7.6
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 126847 2011-06-07 19:50:19Z dan $
|
||||
# $Id: PKGBUILD 135272 2011-08-11 19:58:54Z dreisner $
|
||||
# Maintainer: Dan McGee <dan@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||
|
@ -10,14 +10,14 @@
|
|||
plugrel=1
|
||||
|
||||
pkgname=pacman
|
||||
pkgver=3.5.3
|
||||
pkgrel=1.1
|
||||
pkgver=3.5.4
|
||||
pkgrel=3
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('arm' 'armv7h')
|
||||
url="http://www.archlinux.org/pacman/"
|
||||
license=('GPL')
|
||||
groups=('base')
|
||||
depends=('bash' 'libarchive>=2.8.4' 'libfetch>=2.33' 'pacman-mirrorlist' 'xz>=5.0.1')
|
||||
depends=('bash' 'glibc>=2.14' 'libarchive>=2.8.4' 'libfetch>=2.33' 'pacman-mirrorlist' 'xz>=5.0.1')
|
||||
optdepends=('fakeroot: for makepkg usage as normal user'
|
||||
'curl: for rankmirrors usage')
|
||||
backup=(etc/pacman.conf etc/makepkg.conf)
|
||||
|
@ -26,17 +26,22 @@ options=(!libtool)
|
|||
source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
|
||||
pacman.conf
|
||||
pacman.conf.armv7
|
||||
makepkg.conf)
|
||||
md5sums=('c36c18ed4d8ec69c0ecb4f9684266901'
|
||||
makepkg.conf
|
||||
0001-makepkg-fix-removing-symbolic-link.patch)
|
||||
md5sums=('2dd3a85d55ee3dd89abd349aa837447c'
|
||||
'8a202e08a4e9ffe978c6aa6358e1b640'
|
||||
'5a572af37873bb8a521ffbf81aa2151e'
|
||||
'da2e78190c8677e3df4ed9744bc22e7e')
|
||||
'da2e78190c8677e3df4ed9744bc22e7e'
|
||||
'749a4ddc6d8418d8d031f1c9b4e09d6f')
|
||||
|
||||
# keep an upgrade path for older installations
|
||||
PKGEXT='.pkg.tar.gz'
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
||||
patch -Np1 < "$srcdir/0001-makepkg-fix-removing-symbolic-link.patch"
|
||||
|
||||
./configure --prefix=/usr --sysconfdir=/etc \
|
||||
--localstatedir=/var --enable-doc
|
||||
make
|
||||
|
|
Loading…
Reference in a new issue