mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/ruby to 2.6.0-4
This commit is contained in:
parent
7d5ae50b40
commit
02c8b4f1f9
2 changed files with 26 additions and 13 deletions
|
@ -1,24 +1,24 @@
|
|||
diff --git a/internal.h b/internal.h
|
||||
index 40916a5..785be49 100644
|
||||
index 433ab6635d..a4f7e9bde3 100644
|
||||
--- a/internal.h
|
||||
+++ b/internal.h
|
||||
@@ -250,16 +250,8 @@ struct rb_subclass_entry {
|
||||
@@ -941,19 +941,9 @@ struct rb_subclass_entry {
|
||||
rb_subclass_entry_t *next;
|
||||
};
|
||||
|
||||
-#if defined(HAVE_LONG_LONG)
|
||||
-typedef unsigned LONG_LONG rb_serial_t;
|
||||
-#define SERIALT2NUM ULL2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_LL_PREFIX
|
||||
-#elif defined(HAVE_UINT64_T)
|
||||
-typedef uint64_t rb_serial_t;
|
||||
-#define SERIALT2NUM SIZET2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_64_PREFIX
|
||||
-#else
|
||||
typedef unsigned long rb_serial_t;
|
||||
#define SERIALT2NUM ULONG2NUM
|
||||
#define PRI_SERIALT_PREFIX PRI_LONG_PREFIX
|
||||
-#endif
|
||||
|
||||
struct rb_classext_struct {
|
||||
struct st_table *iv_index_tbl;
|
||||
--
|
||||
1.9.0
|
||||
|
||||
|
|
|
@ -7,8 +7,8 @@
|
|||
# - patch to fix running ruby on v5 (#705)
|
||||
|
||||
pkgname=(ruby ruby-docs)
|
||||
pkgver=2.5.3
|
||||
pkgrel=1
|
||||
pkgver=2.6.0
|
||||
pkgrel=4
|
||||
arch=(x86_64)
|
||||
url='http://www.ruby-lang.org/en/'
|
||||
license=(BSD custom)
|
||||
|
@ -16,8 +16,8 @@ makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
|
|||
options=(!emptydirs)
|
||||
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
|
||||
0002-Use-only-unsigned-long-for-rb_serial_t.patch)
|
||||
sha512sums=('6dcae0e8d0bacdb2cbde636e2030596308b5af53f2eb85d3adccb67b02e6f8f9751e8117d12f8484829fdd9d995f6e327f701d9b433bcf94f1f59d13a1fd7518'
|
||||
'5b3a73b66ed35eb25997109076ec3146ff5f7f843b2e39e7a15b32349c3b38c6035668e8b5d6dd94d97030dea52187e481e8ccdcb6bfc7a79bb12043a322711e')
|
||||
sha512sums=('c56eaf85ef7b79deb34ee4590b143c07f4fc83eb79775290761aee5a7c63374659613538a41f25706ed6e19e49d5c67a1014c24d17f29948294c7abd0b0fcea8'
|
||||
'2b388e2f92149f331190e5ffb54ab2d1c585cb958406034b2350d41a895947864d3ca0fc7936cf54d9730faad0dbf0cac89ab7f0fe8e3fdda58704c7a7660cbe')
|
||||
|
||||
prepare() {
|
||||
cd ruby-${pkgver}
|
||||
|
@ -66,16 +66,29 @@ package_ruby() {
|
|||
|
||||
rubyver=${pkgver:0:3}.0
|
||||
|
||||
# remove rubygems as it shipped in a separate package
|
||||
# remove rubygems as it shipped as a separate package
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{rubygems,rubygems.rb}
|
||||
rm "${pkgdir}"/usr/bin/gem
|
||||
|
||||
# remove bundler as it shipped as a separate package
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{bundler,bundler.rb}
|
||||
rm "${pkgdir}"/usr/bin/{bundle,bundler}
|
||||
rm "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/specifications/default/bundler-*.gemspec
|
||||
rm "${pkgdir}"/usr/share/man/man1/{bundle,bundle-*}.1
|
||||
|
||||
# remove bundled rdoc gem
|
||||
# we are doing it here instead of prepare() because rdoc used doring Ruby build process
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/rdoc/
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{rdoc,rdoc.rb}
|
||||
rm "${pkgdir}"/usr/bin/{rdoc,ri}
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/gems/*
|
||||
rm "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/specifications/default/rdoc-*.gemspec
|
||||
|
||||
# remove irb as it is a separate package now
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{irb,irb.rb}
|
||||
rm "${pkgdir}"/usr/bin/irb
|
||||
rm "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/specifications/default/irb-*.gemspec
|
||||
rm "${pkgdir}"/usr/share/man/man1/irb.1
|
||||
|
||||
# remove all bundled gems to avoid conflicts with ruby-* Arch packages
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/gems/*
|
||||
}
|
||||
|
||||
package_ruby-docs() {
|
||||
|
|
Loading…
Reference in a new issue