extra/js68: v5/v6 fix

This commit is contained in:
Kevin Mihelich 2020-08-08 22:22:58 +00:00
parent 4c865bdc86
commit 02d8c2c4f7
2 changed files with 18 additions and 5 deletions

View file

@ -3,8 +3,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - configure with --disable-lto
# - patch to fix build on ARM
buildarch=12
# - patch to remove unnecessary rust build dependencies, removed rust from makedepends
pkgname=js68
pkgver=68.11.0
@ -14,14 +13,16 @@ arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
license=(MPL)
depends=(gcc-libs readline zlib sh)
makedepends=(python2 zip autoconf2.13 python rust llvm clang)
makedepends=(python2 zip autoconf2.13 python llvm clang)
checkdepends=(mercurial git)
_relver=${pkgver}esr
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
arm.patch)
arm.patch
remove-rust.patch)
sha256sums=('91c1f7caaf1ba785b74799865227456bf784ba614d17cf5f0f41a5f25d6d2160'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966')
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'78158bfe379801c075747d739144c5817a901f0ac7e584ea14d21f49861fa805')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Make sure the duplication between bin and lib is found
@ -31,6 +32,7 @@ prepare() {
cd firefox-$pkgver
mkdir obj
patch -p1 -i ../arm.patch
patch -p1 -i ../remove-rust.patch
}
build() {

View file

@ -0,0 +1,11 @@
--- a/js/moz.configure 2020-07-20 15:02:46.000000000 -0600
+++ b/js/moz.configure 2020-08-08 15:55:33.771501779 -0600
@@ -18,8 +18,6 @@
option(env='JS_STANDALONE', default=building_js,
help='Reserved for internal use')
-include('../build/moz.configure/rust.configure',
- when='--enable-compile-environment')
include('../build/moz.configure/bindgen.configure',
when='--enable-compile-environment')