mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed extra/appstream
This commit is contained in:
parent
bd0a57caf8
commit
0305427f18
3 changed files with 0 additions and 106 deletions
|
@ -1,25 +0,0 @@
|
|||
From 05e37466a1836f074ebe7601b1874762fedb9d1e Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 15 Oct 2019 20:42:47 -0600
|
||||
Subject: [PATCH] Remove -Wno-error=deprecated-copy
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 8556b544..36cef5ce 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -54,7 +54,7 @@ endif
|
||||
|
||||
# a few compiler warning flags we always want enabled
|
||||
add_global_arguments('-Werror=implicit-function-declaration', '-Wno-unused-parameter', language: 'c')
|
||||
-add_global_arguments('-Wno-unused-parameter', '-Wno-error=deprecated-copy', language: 'cpp')
|
||||
+add_global_arguments('-Wno-unused-parameter', language: 'cpp')
|
||||
add_global_arguments('-DAS_COMPILATION', language : 'c')
|
||||
|
||||
#
|
||||
--
|
||||
2.22.0
|
||||
|
|
@ -1,64 +0,0 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Contributor: Jameson Pugh <imntreal@gmail.com>
|
||||
# Contributor: Tim Jester-Pfadt <t.jp<at>gmx.de>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to remove invalid compiler option
|
||||
|
||||
pkgbase=appstream
|
||||
pkgname=(appstream appstream-qt)
|
||||
pkgver=0.12.11
|
||||
pkgrel=1
|
||||
pkgdesc="Provides a standard for creating app stores across distributions"
|
||||
arch=(x86_64)
|
||||
url="https://distributions.freedesktop.org/wiki/AppStream"
|
||||
license=(GPL)
|
||||
depends=(libyaml libxml2 libstemmer glib2 lmdb libsoup)
|
||||
makedepends=(meson xmlto gobject-introspection gtk-doc qt5-tools itstool vala gperf)
|
||||
source=("https://www.freedesktop.org/software/appstream/releases/AppStream-$pkgver.tar.xz"{,.asc}
|
||||
update-appstream-cache.hook
|
||||
0001-Remove-Wno-error-deprecated-copy.patch)
|
||||
sha256sums=('194d871ae057c6bf2b5a95e98d77da2b0107996f593b2ac0b0b88fa8ba452f11'
|
||||
'SKIP'
|
||||
'3a96a1479cfd18dad36c2ca3181aabe46af9bf772c00b965d86ec5f55cd0e0eb'
|
||||
'e4cfc8b0f72c6a659e70dbd7dc870431faa0cf3320a64c8ca4f0df3a5e13117e')
|
||||
validpgpkeys=(D33A3F0CA16B0ACC51A60738494C8A5FBF4DECEB) # Matthias Klumpp <matthias@tenstral.net>
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd AppStream-$pkgver
|
||||
patch -p1 -i ../0001-Remove-Wno-error-deprecated-copy.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
|
||||
meson ../AppStream-$pkgver \
|
||||
--prefix=/usr \
|
||||
-Dqt=true \
|
||||
-Dvapi=true
|
||||
ninja
|
||||
}
|
||||
|
||||
package_appstream() {
|
||||
cd build
|
||||
|
||||
DESTDIR="$pkgdir" ninja install
|
||||
|
||||
# provided by -qt subpackage
|
||||
rm -r "$pkgdir"/usr/{include/AppStreamQt,lib/cmake,lib/libAppStreamQt.*}
|
||||
|
||||
install -Dm644 "$srcdir"/update-appstream-cache.hook "$pkgdir"/usr/share/libalpm/hooks/update-appstream-cache.hook
|
||||
}
|
||||
|
||||
package_appstream-qt() {
|
||||
pkgdesc='Qt5 interface for AppStream'
|
||||
depends=(appstream qt5-base)
|
||||
|
||||
cd build
|
||||
DESTDIR="$pkgdir" ninja install
|
||||
|
||||
# provided by appstream
|
||||
rm -r "$pkgdir"{/etc,/usr/{bin,include/appstream,lib/{girepository-1.0,libappstream*,pkgconfig},share}}
|
||||
}
|
|
@ -1,17 +0,0 @@
|
|||
[Trigger]
|
||||
Type = Path
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Operation = Remove
|
||||
Target = usr/share/app-info/*
|
||||
|
||||
[Trigger]
|
||||
Type = Package
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Target = appstream
|
||||
|
||||
[Action]
|
||||
Description = Updating the appstream cache...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/appstreamcli refresh-cache --force
|
Loading…
Reference in a new issue