mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/claws-mail to 3.9.0-1
This commit is contained in:
parent
534f75bd0f
commit
0365b460b6
2 changed files with 4 additions and 21 deletions
|
@ -5,8 +5,8 @@
|
|||
# - removed valgrind from makedepends
|
||||
|
||||
pkgname=claws-mail
|
||||
pkgver=3.8.1
|
||||
pkgrel=3
|
||||
pkgver=3.9.0
|
||||
pkgrel=1
|
||||
pkgdesc="A GTK+ based e-mail client."
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL3')
|
||||
|
@ -22,17 +22,12 @@ replaces=('sylpheed-claws')
|
|||
provides=('claws')
|
||||
options=(!libtool)
|
||||
install=claws-mail.install
|
||||
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2
|
||||
gnutls313.diff)
|
||||
md5sums=('d388929fb1c8f04d4bcb2139faaf9e70'
|
||||
'21bdc9d324f9424e0071bb73be169977')
|
||||
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
|
||||
md5sums=('4c5ac7b21f0ed17d0f6404124c2229a4')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
# fix a bug in gnutls cert check triggered since gnutls 3.1.3 update
|
||||
patch -Np1 -i ${srcdir}/gnutls313.diff
|
||||
|
||||
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
|
||||
|
||||
./configure --prefix=/usr --disable-static \
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff --git a/src/common/ssl_certificate.c b/src/common/ssl_certificate.c
|
||||
index efc5c53..8303f3e 100644
|
||||
--- a/src/common/ssl_certificate.c
|
||||
+++ b/src/common/ssl_certificate.c
|
||||
@@ -92,6 +92,7 @@
|
||||
size_t size;
|
||||
gnutls_datum tmp;
|
||||
gnutls_x509_crt dest;
|
||||
+ size = 0;
|
||||
|
||||
if (gnutls_x509_crt_init(&dest) != 0) {
|
||||
g_warning("couldn't gnutls_x509_crt_init\n");
|
Loading…
Reference in a new issue