mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/polymake to 3.2-1
This commit is contained in:
parent
04f0c88ec8
commit
037f0e3ac2
3 changed files with 7 additions and 42 deletions
|
@ -1,46 +1,35 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - disable distcc, fails to build with it
|
||||
# - add LDFLAGS and CXXOPT to lower RAM usage
|
||||
# - make -j2 due to RAM constraints
|
||||
|
||||
highmem=1
|
||||
|
||||
pkgname=polymake
|
||||
pkgver=3.1
|
||||
pkgrel=6
|
||||
pkgver=3.2
|
||||
pkgrel=1
|
||||
pkgdesc="Open source software for research in polyhedral geometry"
|
||||
arch=(x86_64)
|
||||
url="https://polymake.org/"
|
||||
license=(GPL)
|
||||
options=('!distcc')
|
||||
depends=(mpfr perl-xml-writer perl-xml-libxml perl-xml-libxslt perl-term-readline-gnu perl-term-readkey)
|
||||
makedepends=(normaliz cddlib lrs ppl apache-ant boost singular bliss-graphs)
|
||||
depends=(mpfr normaliz perl-xml-writer perl-xml-libxml perl-xml-libxslt perl-term-readline-gnu perl-term-readkey)
|
||||
makedepends=(ninja cddlib lrs ppl apache-ant boost singular bliss-graphs)
|
||||
optdepends=('singular: ideal library' 'ppl: polytope library' 'java-runtime: java module')
|
||||
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-$pkgver-minimal.tar.bz2"
|
||||
gcc7.patch polymake-no-znow.patch)
|
||||
sha256sums=('f751e3c34e5ee3a015a99d1151b357130f15878c0bcea82827a19a12009e7fc0'
|
||||
'e93c6d16a13b2701c999ff076fd6510f024b130cd47db2f86f096864b52ae37c'
|
||||
'e56b49bfb60bdb2fc91d267efe09731f65d1f0a469322530bcc409b60fdb6578')
|
||||
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-$pkgver-minimal.tar.bz2")
|
||||
sha256sums=('fc714cec2e6902b982fe6dc420e3e5a6e871efedbc402070812679c2faa83b2b')
|
||||
|
||||
prepare() {
|
||||
cd polymake-$pkgver
|
||||
patch -Np0 -i ../gcc7.patch
|
||||
# fix lrs headers location
|
||||
sed -e 's|lrslib.h|lrslib/lrslib.h|g' -i bundled/lrs/apps/polytope/src/lrs_interface.cc \
|
||||
-i bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp
|
||||
sed -e 's|<lrslib.h>|<lrslib/lrslib.h>|g' -e 's|\$lrs_path\/include|$lrs_path/include/lrslib|g' -i bundled/lrs/configure.pl
|
||||
# Fix undefined symbols
|
||||
patch -p1 -i ../polymake-no-znow.patch
|
||||
sed -e 's|<lrslib.h>|<lrslib/lrslib.h>|g' -e 's|\$lrs_path\/include|$lrs_path/include/lrslib|g' -i bundled/lrs/support/configure.pl
|
||||
}
|
||||
|
||||
build() {
|
||||
cd polymake-$pkgver
|
||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
export LDFLAGS=${LDFLAGS/,-z,now} # Fix undefined symbols
|
||||
export CFLAGS=${CFLAGS/-fno-plt}
|
||||
export CXXFLAGS=${CXXFLAGS/-fno-plt}
|
||||
./configure --prefix=/usr CXXOPT="-O1"
|
||||
make -j2
|
||||
}
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- lib/core/include/Graph.h.orig 2017-03-28 03:30:14.000000000 -0600
|
||||
+++ lib/core/include/Graph.h 2017-03-28 21:33:36.040286583 -0600
|
||||
@@ -709,8 +709,8 @@ public:
|
||||
void swap(Table& t)
|
||||
{
|
||||
std::swap(R,t.R);
|
||||
- std::swap(node_maps, t.node_maps);
|
||||
- std::swap(edge_maps, t.edge_maps);
|
||||
+ node_maps.swap(t.node_maps);
|
||||
+ edge_maps.swap(t.edge_maps);
|
||||
std::swap(n_nodes, t.n_nodes);
|
||||
std::swap(free_node_id, t.free_node_id);
|
||||
std::swap(free_edge_ids, t.free_edge_ids);
|
|
@ -1,11 +0,0 @@
|
|||
--- polymake-3.1/support/configure.pl.orig 2017-12-03 09:21:44.528067697 +0000
|
||||
+++ polymake-3.1/support/configure.pl 2017-12-03 09:25:17.258583093 +0000
|
||||
@@ -450,6 +450,8 @@
|
||||
$Libs =$vars{LIBS} || "";
|
||||
|
||||
$LDsharedFlags=$Config::Config{lddlflags};
|
||||
+$LDsharedFlags =~ s/,-z,now//g;
|
||||
$LDcallableFlags= $options{callable} eq ".none." ? "none" : "$LDsharedFlags $Config::Config{ldflags}";
|
||||
+$LDcallableFlags =~ s/,-z,now//g;
|
||||
|
||||
print "checking C++ library ... ";
|
Loading…
Reference in a new issue