Modded core PKGBUILDs for ARM

This commit is contained in:
Mike Staszel 2009-10-10 00:27:44 -05:00
parent 73a3081974
commit 03ab385447
31 changed files with 14 additions and 792 deletions

View file

@ -1,33 +0,0 @@
# $Id: PKGBUILD 40883 2009-05-31 17:12:07Z thomas $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=crda
pkgver=1.1.0
pkgrel=1
pkgdesc="Central Regulatory Domain Agent"
arch=(i686 x86_64)
url="http://wireless.kernel.org/en/developers/Regulatory/CRDA"
license=('custom')
depends=('wireless-regdb' 'libnl' 'libgcrypt' 'udev' 'iw')
makedepends=('python-m2crypto')
install=crda.install
source=(http://wireless.kernel.org/download/crda/${pkgname}-${pkgver}.tar.bz2
crda.rc)
md5sums=('6004584d2e39e899f7642b141dd72028'
'014eef3f8655e9a130064ec6891317fc')
build() {
# Install crda, regdbdump and udev rules
msg "Compiling and installing crda ..."
cd ${srcdir}/${pkgname}-${pkgver}
make crda regdbdump || return 1
make DESTDIR=${pkgdir} install || return 1
# This rule automatically sets the regulatory domain when cfg80211 is loaded
echo 'ACTION=="add" SUBSYSTEM=="module", DEVPATH=="/module/cfg80211", RUN+="/etc/rc.d/wireless-regdom start >/dev/null"' >> ${pkgdir}/lib/udev/rules.d/85-regulatory.rules || return 1
msg "Installing license ..."
install -D -m644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/crda/LICENSE || return 1
msg "Installing boot script ..."
install -D -m755 ${srcdir}/crda.rc ${pkgdir}/etc/rc.d/wireless-regdom || return 1
}

View file

@ -1,18 +0,0 @@
## arg 1: the new package version
post_install() {
echo "Uncomment the right regulatory domain in /etc/conf.d/wireless-regdom."
echo "It will automatically be set when necessary."
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
# In an upgrade from 1.0.1-1 or older, the wireless-regdom file moves from the crda package
# to the new wireless-regdb package. If the user changed the file, it is save to overwrite the one
# from wireless-regdb by the user-defined one
if [ $(vercmp $2 1.0.1-2) -lt 0 ]; then
if [ -f /etc/conf.d/wireless-regdom.pacorig -a -n "$(grep -v ^# /etc/conf.d/wireless-regdom.pacorig 2>/dev/null | grep -v ^$)" ]; then
mv /etc/conf.d/wireless-regdom.pacorig /etc/conf.d/wireless-regdom
fi
fi
}

View file

@ -1,26 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
. /etc/conf.d/wireless-regdom
case "$1" in
start)
if [ -n "${WIRELESS_REGDOM}" ]; then
stat_busy "Setting wireless regulatory domain: ${WIRELESS_REGDOM}"
if iw reg set ${WIRELESS_REGDOM}; then
stat_done
else
stat_fail
fi
fi
;;
stop)
;;
restart)
$0 start
;;
*)
echo "usage: $0 start"
esac
exit 0

View file

@ -5,7 +5,7 @@ pkgver=1.6.4.1
pkgrel=1
pkgdesc="GIT - the stupid content tracker"
groups=('base-devel')
arch=(arm)
arch=('arm')
url="http://git-scm.com/"
license=('GPL2')
depends=('curl' 'expat>=2.0' 'perl-error' 'perl>=5.10.0')

View file

@ -1,10 +1,10 @@
# $Id: PKGBUILD 53876 2009-10-03 18:11:12Z paul $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=groff
pkgver=1.20.1
pkgrel=3
pkgdesc="GNU troff text-formatting system"
arch=(i686 x86_64)
arch=('arm')
url="http://www.gnu.org/software/groff/groff.html"
license=('GPL')
groups=('base')
@ -12,7 +12,6 @@ depends=('perl' 'gcc-libs' 'texinfo')
makedepends=('netpbm' 'psutils' 'ghostscript')
source=(ftp://ftp.gnu.org/gnu/groff/groff-$pkgver.tar.gz
site.tmac)
install=groff.install
md5sums=('48fa768dd6fdeb7968041dd5ae8e2b02'
'7b47109b2dd1797445c912574d8934a1')

View file

@ -1,20 +0,0 @@
infodir=/usr/share/info
filelist=(groff.info groff.info-1 groff.info-2 groff.info-3)
post_install() {
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
}
post_upgrade() {
post_install $1
}
pre_remove() {
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
}
# vim:set ts=2 sw=2 et:

View file

@ -1,11 +1,10 @@
# $Id: PKGBUILD 51328 2009-09-07 15:58:27Z tpowa $
# Maintainer: Paul Mattal <paul@archlinux.org>
pkgname=hdparm
pkgver=9.27
pkgrel=1
pkgdesc="A shell utility for manipulating Linux IDE drive/driver parameters"
arch=(i686 x86_64)
arch=('arm')
depends=('glibc')
optdepends=('sh: required by idectl and ultrabayd')
groups=('base')
@ -30,4 +29,3 @@ build() {
#install license file
install -D -m 644 LICENSE.TXT $pkgdir/usr/share/licenses/hdparm/LICENSE.TXT
}

View file

@ -1,26 +0,0 @@
# Maintainer: Krzysztof "hiciu" Warzecha <kwarzecha7@gmail.com>
pkgname=kernel-headers
pkgver=2.6.29.1
_basever=2.6.29
pkgrel=1
pkgdesc="Kernel headers sanitized for use in userspace"
arch=(arm)
license=('GPL')
url="http://www.gnu.org/software/libc"
groups=('base')
source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${_basever}.tar.bz2
http://www.kernel.org/pub/linux/kernel/v2.6/patch-${pkgver}.bz2)
md5sums=('64921b5ff5cdadbccfcd3820f03be7d8'
'87c6fbf4096b644d66d4da8bb00641a5')
build() {
cd ${srcdir}/linux-${_basever}
patch -Np1 -i ${srcdir}/patch-${pkgver} || return 1
make mrproper
make headers_check || return 1
make INSTALL_HDR_PATH=${pkgdir}/usr headers_install
rm -rf ${pkgdir}/usr/include/drm
}

View file

@ -1,91 +0,0 @@
From: Patrick McHardy <kaber@trash.net>
Date: Wed, 21 May 2008 21:08:38 +0000 (-0700)
Subject: netfilter: Move linux/types.h inclusions outside of #ifdef __KERNEL__
X-Git-Tag: v2.6.26-rc4~7^2~9
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=c8942f1f0a7e2160ebf2e51ba89e50ee5895a1e7
netfilter: Move linux/types.h inclusions outside of #ifdef __KERNEL__
Greg Steuck <greg@nest.cx> points out that some of the netfilter
headers can't be used in userspace without including linux/types.h
first. The headers include their own linux/types.h include statements,
these are stripped by make headers-install because they are inside
#ifdef __KERNEL__ however. Move them out to fix this.
Reported and Tested by Greg Steuck.
Signed-off-by: Patrick McHardy <kaber@trash.net>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
diff --git a/include/linux/netfilter.h b/include/linux/netfilter.h
index e4c6659..0c5eb7e 100644
--- a/include/linux/netfilter.h
+++ b/include/linux/netfilter.h
@@ -3,7 +3,6 @@
#ifdef __KERNEL__
#include <linux/init.h>
-#include <linux/types.h>
#include <linux/skbuff.h>
#include <linux/net.h>
#include <linux/netdevice.h>
@@ -14,6 +13,7 @@
#include <linux/list.h>
#include <net/net_namespace.h>
#endif
+#include <linux/types.h>
#include <linux/compiler.h>
/* Responses from hook functions. */
diff --git a/include/linux/netfilter_arp/arp_tables.h b/include/linux/netfilter_arp/arp_tables.h
index dd9c97f..590ac3d 100644
--- a/include/linux/netfilter_arp/arp_tables.h
+++ b/include/linux/netfilter_arp/arp_tables.h
@@ -11,11 +11,11 @@
#ifdef __KERNEL__
#include <linux/if.h>
-#include <linux/types.h>
#include <linux/in.h>
#include <linux/if_arp.h>
#include <linux/skbuff.h>
#endif
+#include <linux/types.h>
#include <linux/compiler.h>
#include <linux/netfilter_arp.h>
diff --git a/include/linux/netfilter_ipv4/ip_tables.h b/include/linux/netfilter_ipv4/ip_tables.h
index bfc889f..092bd50 100644
--- a/include/linux/netfilter_ipv4/ip_tables.h
+++ b/include/linux/netfilter_ipv4/ip_tables.h
@@ -17,11 +17,11 @@
#ifdef __KERNEL__
#include <linux/if.h>
-#include <linux/types.h>
#include <linux/in.h>
#include <linux/ip.h>
#include <linux/skbuff.h>
#endif
+#include <linux/types.h>
#include <linux/compiler.h>
#include <linux/netfilter_ipv4.h>
diff --git a/include/linux/netfilter_ipv6/ip6_tables.h b/include/linux/netfilter_ipv6/ip6_tables.h
index f2507dc..1089e33 100644
--- a/include/linux/netfilter_ipv6/ip6_tables.h
+++ b/include/linux/netfilter_ipv6/ip6_tables.h
@@ -17,11 +17,11 @@
#ifdef __KERNEL__
#include <linux/if.h>
-#include <linux/types.h>
#include <linux/in6.h>
#include <linux/ipv6.h>
#include <linux/skbuff.h>
#endif
+#include <linux/types.h>
#include <linux/compiler.h>
#include <linux/netfilter_ipv6.h>

View file

@ -1,10 +1,10 @@
# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=libtirpc
pkgver=0.2.0
pkgrel=1
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
arch=(i686 x86_64)
arch=('arm')
depends=('glibc')
url="http://libtirpc.sourceforge.net/"
license=('GPL2')

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 43131 2009-06-19 21:42:21Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
# Contributor: dibblethewrecker <dibblethewrecker.at.jiwe.org>
@ -9,7 +8,7 @@ pkgname=nfs-utils
pkgver=1.2.0
pkgrel=3
pkgdesc="Support programs for Network File Systems"
arch=('i686' 'x86_64')
arch=('arm')
url='http://nfs.sourceforge.net'
license=('GPL')
backup=(etc/{exports,gssapi_mech.conf,idmapd.conf} etc/conf.d/{nfs-common.conf,nfs-server.conf})

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 48336 2009-08-01 14:36:12Z jgc $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
@ -6,7 +5,7 @@ pkgname=reiserfsprogs
pkgver=3.6.21
pkgrel=2
pkgdesc="Reiserfs utilities"
arch=(i686 x86_64)
arch=('arm')
url=http://www.kernel.org/pub/linux/utils/fs/reiserfs/README
license=('GPL')
groups=('base')

View file

@ -1,11 +1,11 @@
# $Id: PKGBUILD 5374 2008-07-15 17:18:23Z daniel $
# Contributor: orelien <aurelien.foret@wanadoo.fr>
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=rp-pppoe
pkgver=3.10
pkgrel=1
pkgdesc="Roaring Penguin's Point-to-Point Protocol over Ethernet client"
arch=(i686 x86_64)
arch=('arm')
url="http://www.roaringpenguin.com/pppoe/"
license=('GPL')
groups=('base')

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 53911 2009-10-03 20:40:12Z giovanni $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: grimi@poczta.fm
@ -6,12 +5,14 @@ pkgname=sdparm
pkgver=1.04
pkgrel=1
pkgdesc="An utility similar to hdparm but for SCSI devices"
arch=('i686' 'x86_64')
arch=('arm')
url="http://sg.danny.cz/sg/sdparm.html"
groups=('base')
license=('BSD')
depends=('glibc')
source=("http://sg.danny.cz/sg/p/$pkgname-$pkgver.tgz")
source=(http://sg.danny.cz/sg/p/$pkgname-$pkgver.tgz)
md5sums=('b20c281bc185ea7d3c5e78a8c0be2a46')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
@ -20,4 +21,3 @@ build() {
make DESTDIR=${pkgdir}/ install || return 1
install -Dm644 COPYING $pkgdir/usr/share/licenses/sdparm/COPYING
}
md5sums=('b20c281bc185ea7d3c5e78a8c0be2a46')

View file

@ -1,20 +0,0 @@
# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
# Maintainer: James Rayner <iphitus@gmail.com>
pkgname=tiacx-firmware
pkgver=2
pkgrel=1
pkgdesc="Firmware for Texas Instruments ACX100/ACX111 wireless chips."
arch=('i686' 'x86_64')
url="http://acx100.sourceforge.net/"
license=('MPL')
install=tiacx-firmware.install
source=(http://www.kazer.org/acx-firmware-20060207.tar.bz2)
build() {
mkdir -p $startdir/pkg/usr/share
cp -r fw $startdir/pkg/usr/share/tiacx
find $startdir/pkg -type d -exec chmod 755 {} \;
find $startdir/pkg -type f -exec chmod 644 {} \;
}
md5sums=('b8efea38c2c598190604dfa297cc9675')

View file

@ -1,22 +0,0 @@
post_install() {
cat << 'EOM'
==>
==> PLEASE NOTE:
==> The firmware files for ACX100/111 devices are installed in
==> /usr/share/tiacx. Please identify the correct file(s) for your
==> device and copy them to /lib/firmware.
==>
==> See http://acx100.sourceforge.net/wiki/Firmware for details.
==>
EOM
}
post_upgrade() {
post_install
}
op=$1
shift
$op $*

View file

@ -1,28 +0,0 @@
# $Id: PKGBUILD 42270 2009-06-12 07:26:25Z tpowa $
# Maintainer: James Rayner <iphitus@gmail.com>
pkgname=tiacx
pkgver=20080210
pkgrel=10
pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock arch 2.6 kernel"
arch=(i686 x86_64)
url="http://acx100.sourceforge.net/"
license=('MPL')
depends=('wireless_tools' 'kernel26>=2.6.30' 'kernel26<2.6.31' 'tiacx-firmware')
install=acx.install
source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2
kernel-2.6.27.patch
kernel-2.6.30.patch)
_kernver=2.6.30-ARCH
build() {
cd $startdir/src/acx-$pkgver
patch -Np1 -i ../kernel-2.6.27.patch || return 1
patch -Np0 -i ../kernel-2.6.30.patch || return 1
make -C /lib/modules/${_kernver}/build M=`pwd` || return 1
install -D acx.ko $startdir/pkg/lib/modules/${_kernver}/kernel/drivers/net/wireless/tiacx/acx.ko
sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/*.install
}
md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12'
'9895f72f8d0c84956b0f6c3b16df0fe8'
'e2900aee839ce711a7f7606b3e3de36e')

View file

@ -1,23 +0,0 @@
# arg 1: the new package version
post_install() {
KERNEL_VERSION='2.6.30-ARCH'
depmod -v $KERNEL_VERSION > /dev/null 2>&1
}
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
KERNEL_VERSION='2.6.30-ARCH'
depmod -v $KERNEL_VERSION > /dev/null 2>&1
}
# arg 1: the old package version
post_remove() {
KERNEL_VERSION='2.6.30-ARCH'
depmod -v $KERNEL_VERSION > /dev/null 2>&1
}
op=$1
shift
$op $*

View file

@ -1,82 +0,0 @@
diff -Nur acx-20080210.orig/ioctl.c acx-20080210/ioctl.c
--- acx-20080210.orig/ioctl.c 2008-02-10 21:06:42.000000000 +0100
+++ acx-20080210/ioctl.c 2008-10-10 17:07:32.000000000 +0200
@@ -489,6 +489,7 @@
static char*
acx_s_scan_add_station(
acx_device_t *adev,
+ struct iw_request_info *info,
char *ptr,
char *end_buf,
struct client *bss)
@@ -503,14 +504,14 @@
iwe.u.ap_addr.sa_family = ARPHRD_ETHER;
MAC_COPY(iwe.u.ap_addr.sa_data, bss->bssid);
acxlog_mac(L_IOCTL, "scan, station address: ", bss->bssid, "\n");
- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_ADDR_LEN);
+ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_ADDR_LEN);
/* Add ESSID */
iwe.cmd = SIOCGIWESSID;
iwe.u.data.length = bss->essid_len;
iwe.u.data.flags = 1;
log(L_IOCTL, "scan, essid: %s\n", bss->essid);
- ptr = iwe_stream_add_point(ptr, end_buf, &iwe, bss->essid);
+ ptr = iwe_stream_add_point(info, ptr, end_buf, &iwe, bss->essid);
/* Add mode */
iwe.cmd = SIOCGIWMODE;
@@ -520,7 +521,7 @@
else
iwe.u.mode = IW_MODE_ADHOC;
log(L_IOCTL, "scan, mode: %d\n", iwe.u.mode);
- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_UINT_LEN);
+ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_UINT_LEN);
}
/* Add frequency */
@@ -528,7 +529,7 @@
iwe.u.freq.m = acx_channel_freq[bss->channel - 1] * 100000;
iwe.u.freq.e = 1;
log(L_IOCTL, "scan, frequency: %d\n", iwe.u.freq.m);
- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_FREQ_LEN);
+ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_FREQ_LEN);
/* Add link quality */
iwe.cmd = IWEVQUAL;
@@ -546,7 +547,7 @@
iwe.u.qual.updated = 7;
log(L_IOCTL, "scan, link quality: %d/%d/%d\n",
iwe.u.qual.level, iwe.u.qual.noise, iwe.u.qual.qual);
- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_QUAL_LEN);
+ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_QUAL_LEN);
/* Add encryption */
iwe.cmd = SIOCGIWENCODE;
@@ -556,7 +557,7 @@
iwe.u.data.flags = IW_ENCODE_DISABLED;
iwe.u.data.length = 0;
log(L_IOCTL, "scan, encryption flags: %X\n", iwe.u.data.flags);
- ptr = iwe_stream_add_point(ptr, end_buf, &iwe, bss->essid);
+ ptr = iwe_stream_add_point(info, ptr, end_buf, &iwe, bss->essid);
/* add rates */
iwe.cmd = SIOCGIWRATE;
@@ -570,7 +571,7 @@
if (rate & 1) {
iwe.u.bitrate.value = *p * 500000; /* units of 500kb/s */
log(L_IOCTL, "scan, rate: %d\n", iwe.u.bitrate.value);
- ptr_rate = iwe_stream_add_value(ptr, ptr_rate, end_buf,
+ ptr_rate = iwe_stream_add_value(info, ptr, ptr_rate, end_buf,
&iwe, IW_EV_PARAM_LEN);
}
rate >>= 1;
@@ -625,7 +626,7 @@
for (i = 0; i < ARRAY_SIZE(adev->sta_list); i++) {
struct client *bss = &adev->sta_list[i];
if (!bss->used) continue;
- ptr = acx_s_scan_add_station(adev, ptr,
+ ptr = acx_s_scan_add_station(adev, info, ptr,
extra + IW_SCAN_MAX_DATA, bss);
}
dwrq->length = ptr - extra;

View file

@ -1,16 +0,0 @@
--- wlan_compat.h~ 2009-06-12 09:17:30.000000000 +0200
+++ wlan_compat.h 2009-06-12 09:17:30.000000000 +0200
@@ -217,13 +217,6 @@
/*=============================================================*/
#define WLAN_PACKED __attribute__ ((packed))
-/* Interrupt handler backwards compatibility stuff */
-#ifndef IRQ_NONE
-#define IRQ_NONE
-#define IRQ_HANDLED
-typedef void irqreturn_t;
-#endif
-
#ifndef ARPHRD_IEEE80211_PRISM
#define ARPHRD_IEEE80211_PRISM 802
#endif

View file

@ -1,45 +0,0 @@
# $Id: PKGBUILD 49491 2009-08-09 20:53:06Z thomas $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=wireless-regdb
pkgver=2009.08.05
pkgrel=1
pkgdesc="Central Regulatory Domain Database"
arch=(any)
url="http://wireless.kernel.org/en/developers/Regulatory/CRDA"
license=('custom')
depends=()
install=wireless-regdb.install
source=(http://wireless.kernel.org/download/${pkgname}/${pkgname}-${pkgver}.tar.bz2
crda.conf.d)
md5sums=('1dc83ef1222c0dbb0be63e8e5698273a'
'2374dcf1c6530332f375e5362b80169b')
backup=(etc/conf.d/wireless-regdom)
build() {
# Install and verify regulatory.bin file
msg "Installing and verifying the regulatory.bin file ..."
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install || return 1
# If crda is installed, the wireless regdb can be verified using regdbdump
# Keep this step optional so no depend/makedepend loop is created
if [ -x /sbin/regdbdump ]; then
if /sbin/regdbdump ${pkgdir}/usr/lib/crda/regulatory.bin > /dev/null; then
msg "Regulatory database verification was succesful."
else
error "Regulatory database verification failed."
return 1
fi
else
warning "Crda is not installed, regulatory database could not be verified."
fi
msg "Installing /etc/conf.d/wireless-regdom ..."
install -D -m644 ${srcdir}/crda.conf.d ${pkgdir}/etc/conf.d/wireless-regdom || return 1
for dom in $(grep ^country ${srcdir}/${pkgname}-${pkgver}/db.txt | cut -d' ' -f2 | sed 's|:||g'); do
echo "#WIRELESS_REGDOM=\"${dom}\"" >> ${pkgdir}/etc/conf.d/wireless-regdom.tmp || return 1
done
sort -u ${pkgdir}/etc/conf.d/wireless-regdom.tmp >> ${pkgdir}/etc/conf.d/wireless-regdom || return 1
rm -f ${pkgdir}/etc/conf.d/wireless-regdom.tmp || return 1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
}

View file

@ -1,4 +0,0 @@
#
# Wireless regulatory domain configuration
#

View file

@ -1,13 +0,0 @@
post_install() {
post_upgrade
}
post_upgrade() {
# If crda is installed, we verify the integrity of the database
# If not, we skip this step silently
if [ -x /sbin/regdbdump ]; then
if ! /sbin/regdbdump /usr/lib/crda/regulatory.bin > /dev/null; then
echo "Failed to verify the integrity of the wireless regulatory database, CRDA will not work."
fi
fi
}

View file

@ -1,24 +0,0 @@
# Maintainer: Judd Vinet <jvinet@zeroflux.org>
# Contributer: Jason Chu <jchu@xentac.net>
pkgname=wireless_tools
pkgver=29
pkgrel=4
pkgdesc="Wireless Tools"
arch=(arm)
url="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html"
groups=('base')
license=('GPL')
depends=('glibc')
backup=('etc/conf.d/wireless')
source=(http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.29.tar.gz
wireless.conf.d)
md5sums=('e06c222e186f7cc013fd272d023710cb'
'027576534885b8d5dded9be546057b12')
build() {
cd $srcdir/wireless_tools.29
make || return 1
make INSTALL_DIR=$pkgdir/usr/sbin INSTALL_LIB=$pkgdir/usr/lib INSTALL_INC=$pkgdir/usr/include INSTALL_MAN=$pkgdir/usr/share/man install || return 1
install -D -m644 ../wireless.conf.d $startdir/pkg/etc/conf.d/wireless
}

View file

@ -1,12 +0,0 @@
#
# Settings for wireless cards
#
# For each wireless interface declared in INTERFACES (in rc.conf), declare
# a wlan_${IF} variable that contains the arguments to be passed to
# iwconfig(8). Then list the original interface name in the
# WLAN_INTERFACES array.
#
#wlan_eth0="eth0 mode managed essid default"
#WLAN_INTERFACES=(eth0)

View file

@ -1,32 +0,0 @@
# $Id: PKGBUILD 7972 2008-08-05 11:03:19Z tpowa $
# Maintainer: Tom Killian <tom@archlinux.org>
pkgname=wlan-ng26-utils
pkgver=0.2.9
pkgrel=1
pkgdesc="Wireless Lan userspace tools."
depends=('glibc' 'bash')
makedepends=('kernel26')
source=(ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/linux-wlan-ng-$pkgver.tar.bz2 \
wlan-ng.patch wlan kernel-2.6.26.patch)
url="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/"
backup=(etc/wlan/wlan.conf)
arch=('i686' 'x86_64')
license=('MPL')
build() {
cd $startdir/src/linux-wlan-ng-$pkgver
patch -Np0 -i ../kernel-2.6.26.patch || return 1
sed -i "s#TARGET_ROOT_ON_HOST=#TARGET_ROOT_ON_HOST=$startdir/pkg#;s#PRISM2_PLX=y#PRISM2_PLX=n#;s#PRISM2_PCI=y#PRISM2_PCI=n#" config.in
patch -p1 < ../wlan-ng.patch
make auto_config
make all || return 1
make install
mkdir -p $startdir/pkg/etc/rc.d
rm -r $startdir/pkg/{init.d,lib,etc/pcmcia}
install -m 755 $startdir/src/wlan $startdir/pkg/etc/rc.d/wlan
}
md5sums=('96130b36f9674521b08fb3e2a6ac0382'
'706464f9e6e127558aed25b9f454f905'
'1056365bdbe7102b1a668c84926ecb17'
'6ed5a5fefc2c149e0e0a98de211ba147')

View file

@ -1,120 +0,0 @@
diff -uNr linux-wlan-ng-0.2.8/CHANGES linux-wlan-ng-svn-1832/CHANGES
--- linux-wlan-ng-0.2.8/CHANGES 2007-05-04 13:29:27.000000000 +0100
+++ linux-wlan-ng-svn-1832/CHANGES 2007-06-27 11:28:14.000000000 +0100
@@ -41,6 +41,8 @@
* Intersil Corporation as part of PRISM(R) chipset product development.
*
* --------------------------------------------------------------------
+ - Tweaks to support Fedora 7 (Dan Williams)
+ - Support 2.6.22 kernels
0.2.8
- Fix up a pile of sparse warnings (Pavel Roskin)
- Support 2.6.20 kernels (Pavel Roskin)
diff -uNr linux-wlan-ng-0.2.8/Configure linux-wlan-ng-svn-1832/Configure
--- linux-wlan-ng-0.2.8/Configure 2007-05-07 23:00:22.000000000 +0100
+++ linux-wlan-ng-svn-1832/Configure 2007-06-27 11:28:14.000000000 +0100
@@ -277,9 +277,9 @@
fi
write_bool KERN_2_6_17
-if [ $VERSION_CODE -gt `version 2 6 21` ] ; then
+if [ $VERSION_CODE -gt `version 2 6 22` ] ; then
$ECHO "******* WARNING WARNING WARNING *******"
- $ECHO "Kernels newer than 2.6.21.x are not supported."
+ $ECHO "Kernels newer than 2.6.22.x are not supported."
$ECHO "******* WARNING WARNING WARNING *******"
fi
diff -uNr linux-wlan-ng-0.2.8/config.in linux-wlan-ng-svn-1832/config.in
--- linux-wlan-ng-0.2.8/config.in 2007-02-09 21:51:58.000000000 +0000
+++ linux-wlan-ng-svn-1832/config.in 2007-06-27 11:28:14.000000000 +0100
@@ -1,6 +1,6 @@
WLAN_VERSION=0
WLAN_PATCHLEVEL=2
-WLAN_SUBLEVEL=8
+WLAN_SUBLEVEL=9
WLAN_EXTRAVERSION=
#LINUX_SRC=/usr/src/linux
PCMCIA_SRC=
diff -uNr linux-wlan-ng-0.2.8/etc/udev/rules.d/40-prism2.rules linux-wlan-ng-svn-1832/etc/udev/rules.d/40-prism2.rules
--- linux-wlan-ng-0.2.8/etc/udev/rules.d/40-prism2.rules 2006-06-26 16:03:27.000000000 +0100
+++ linux-wlan-ng-svn-1832/etc/udev/rules.d/40-prism2.rules 2007-06-27 11:28:14.000000000 +0100
@@ -1 +1,2 @@
-ACTION=="add",BUS=="usb",DRIVER=="prism2_usb" ,RUN+="/etc/wlan/wlan-udev.sh %k"
+#ACTION=="add",BUS=="usb",DRIVER=="prism2_usb" ,RUN+="/etc/wlan/wlan-udev.sh %k"
+KERNEL="wlan*",ACTION=="add",DRIVERS=="prism2_usb" ,RUN+="/etc/wlan/wlan-udev.sh %k"
diff -uNr linux-wlan-ng-0.2.8/src/include/wlan/wlan_compat.h linux-wlan-ng-svn-1832/src/include/wlan/wlan_compat.h
--- linux-wlan-ng-0.2.8/src/include/wlan/wlan_compat.h 2007-02-28 15:44:02.000000000 +0000
+++ linux-wlan-ng-svn-1832/src/include/wlan/wlan_compat.h 2007-06-27 11:28:14.000000000 +0100
@@ -479,6 +479,13 @@
#endif
#endif /* _LINUX_PROC_FS_H */
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)
+#define skb_reset_mac_header(__a) (__a)->mac.raw = (__a)->data
+#define SKB_MAC_HEADER(__a) (__a)->mac.raw
+#else
+#define SKB_MAC_HEADER(__a) (__a)->mac_header
+#endif
+
#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0))
#ifndef INIT_TQUEUE
#define PREPARE_TQUEUE(_tq, _routine, _data) \
diff -uNr linux-wlan-ng-0.2.8/src/p80211/p80211conv.c linux-wlan-ng-svn-1832/src/p80211/p80211conv.c
--- linux-wlan-ng-0.2.8/src/p80211/p80211conv.c 2007-03-19 15:37:00.000000000 +0000
+++ linux-wlan-ng-svn-1832/src/p80211/p80211conv.c 2007-06-27 11:28:14.000000000 +0100
@@ -498,7 +498,7 @@
}
skb->protocol = eth_type_trans(skb, netdev);
- skb->mac.raw = (unsigned char *) e_hdr; /* new MAC header */
+ SKB_MAC_HEADER(skb) = (unsigned char *) e_hdr; /* new MAC header */
/* jkriegl: process signal and noise as set in hfa384x_int_rx() */
/* jkriegl: only process signal/noise if requested by iwspy */
diff -uNr linux-wlan-ng-0.2.8/src/p80211/p80211netdev.c linux-wlan-ng-svn-1832/src/p80211/p80211netdev.c
--- linux-wlan-ng-0.2.8/src/p80211/p80211netdev.c 2007-03-19 15:37:00.000000000 +0000
+++ linux-wlan-ng-svn-1832/src/p80211/p80211netdev.c 2007-06-27 11:28:14.000000000 +0100
@@ -389,7 +389,8 @@
/* set up various data fields */
skb->dev = dev;
- skb->mac.raw = skb->data ;
+ skb_reset_mac_header(skb);
+
skb->ip_summed = CHECKSUM_NONE;
skb->pkt_type = PACKET_OTHERHOST;
skb->protocol = htons(ETH_P_80211_RAW);
@@ -929,7 +930,7 @@
dev->open = p80211knetdev_open;
dev->stop = p80211knetdev_stop;
-#ifdef CONFIG_NET_WIRELESS
+#if defined(CONFIG_NET_WIRELESS) || defined(WIRELESS_EXT)
#if ((WIRELESS_EXT < 17) && (WIRELESS_EXT < 21))
dev->get_wireless_stats = p80211wext_get_wireless_stats;
#endif
diff -uNr linux-wlan-ng-0.2.8/src/prism2/driver/hfa384x.c linux-wlan-ng-svn-1832/src/prism2/driver/hfa384x.c
--- linux-wlan-ng-0.2.8/src/prism2/driver/hfa384x.c 2007-03-19 15:37:00.000000000 +0000
+++ linux-wlan-ng-svn-1832/src/prism2/driver/hfa384x.c 2007-06-27 11:28:14.000000000 +0100
@@ -3645,7 +3645,7 @@
/* the prism2 cards don't return the FCS */
datap = skb_put(skb, WLAN_CRC_LEN);
memset (datap, 0xff, WLAN_CRC_LEN);
- skb->mac.raw = skb->data;
+ skb_reset_mac_header(skb);
/* Attach the rxmeta, set some stuff */
p80211skb_rxmeta_attach(wlandev, skb);
diff -uNr linux-wlan-ng-0.2.8/src/prism2/driver/hfa384x_usb.c linux-wlan-ng-svn-1832/src/prism2/driver/hfa384x_usb.c
--- linux-wlan-ng-0.2.8/src/prism2/driver/hfa384x_usb.c 2007-03-19 15:37:00.000000000 +0000
+++ linux-wlan-ng-svn-1832/src/prism2/driver/hfa384x_usb.c 2007-06-27 11:28:14.000000000 +0100
@@ -4255,7 +4255,7 @@
/* The prism2 series does not return the CRC */
memset(skb_put(skb, WLAN_CRC_LEN), 0xff, WLAN_CRC_LEN);
- skb->mac.raw = skb->data;
+ skb_reset_mac_header(skb);
/* Attach the rxmeta, set some stuff */
p80211skb_rxmeta_attach(wlandev, skb);

View file

@ -1,14 +0,0 @@
Index: src/p80211/p80211netdev.c
===================================================================
--- src/p80211/p80211netdev.c (revision 1865)
+++ src/p80211/p80211netdev.c (working copy)
@@ -947,7 +947,9 @@
#endif
#endif
-#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,24) )
+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26) )
+ dev_net_set(dev, &init_net);
+#elif (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,24) )
dev->nd_net = &init_net;
#endif

View file

@ -1,68 +0,0 @@
#!/bin/sh
if [ ! -f /etc/wlan/shared ] ; then
echo "/etc/wlan/shared not present"
exit 0
fi
. /etc/wlan/shared
. /etc/rc.conf
. /etc/rc.d/functions
case "$1" in
start)
# This will implicitly fire off wland via hotplug.
stat_busy "Starting WLAN Devices"
if ! $MODPROBE p80211; then
echo "Failed to load p80211.o."
exit 1
fi
# NOTE: We don't explicitly insmod the card driver here. The
# best thing to do is to specify an alias in /etc/modules.conf.
for DEVICE in $WLAN_DEVICES; do
$MODPROBE $DEVICE
# if we don't have hotplug.. do things the old-fashioned way.
if [ $HAS_HOTPLUG = 'n' ] ; then
wlan_bring_it_up $DEVICE
fi
done
# And hotplug will take care of the rest, namely device
# initialization and whatnot.
add_daemon wlan
stat_done
;;
stop)
stat_busy "Shutting Down WLAN Devices"
# Do a reset on each device to make sure none of them are still
# trying to generate interrupts.
for DEVICE in $WLAN_DEVICES; do
wlan_disable $DEVICE
ifconfig $DEVICE down
$MODPROBE -r $DEVICE
done
# remove p80211, which will implictly kill wland.
$MODPROBE -r p80211
rm_daemon wlan
stat_done
;;
restart)
$0 stop
$0 start
EXITCODE=$?
;;
*)
echo "usage: $0 {start|stop|restart}"
;;
esac
exit 0

View file

@ -1,14 +0,0 @@
diff -ur linux-wlan-ng-0.2.1pre22/man/Makefile linux-wlan-ng-0.2.1pre22-new/man/Makefile
--- linux-wlan-ng-0.2.1pre22/man/Makefile 2004-08-04 14:09:27.000000000 -0700
+++ linux-wlan-ng-0.2.1pre22-new/man/Makefile 2004-10-18 12:23:19.000000000 -0700
@@ -48,8 +48,8 @@
@echo "Nothing to do..."
install:
- mkdir -p $(TARGET_ROOT_ON_HOST)/usr/local/man/man1
- cp *.1 $(TARGET_ROOT_ON_HOST)/usr/local/man/man1
+ mkdir -p $(TARGET_ROOT_ON_HOST)/usr/share/man/man1
+ cp *.1 $(TARGET_ROOT_ON_HOST)/usr/share/man/man1
clean:
rm -f core core.* *.o .*.o *.s *.a .depend tmp_make *~ tags

View file

@ -1,22 +0,0 @@
# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
# Maintainer: Dan McGee <dan@archlinux.org>
pkgname=zd1211-firmware
pkgver=1.4
pkgrel=2
pkgdesc="Firmware for the in-kernel26 zd1211rw wireless driver"
arch=(i686 x86_64)
url="http://zd1211.wiki.sourceforge.net/"
# firmware files are here:
# http://sourceforge.net/project/showfiles.php?group_id=129083
license=('GPL')
provides=('zd1211')
source=(http://downloads.sourceforge.net/zd1211/zd1211-firmware-$pkgver.tar.bz2)
md5sums=('19f28781d76569af8551c9d11294c870')
build() {
cd $startdir/src/zd1211-firmware
mkdir -p $startdir/pkg/lib/firmware/zd1211/
# just unpack the files to the firmware directory
install -m644 * $startdir/pkg/lib/firmware/zd1211/ || return 1
}