mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libreoffice-fresh to 5.2.1-1
This commit is contained in:
parent
d1072ef2b0
commit
03d4eab558
3 changed files with 8 additions and 202 deletions
|
@ -17,9 +17,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
|
|||
|
||||
pkgbase=libreoffice-fresh
|
||||
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
|
||||
_LOver=5.2.0.4
|
||||
pkgver=5.2.0
|
||||
pkgrel=4
|
||||
_LOver=5.2.1.2
|
||||
pkgver=5.2.1
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
license=('LGPL3')
|
||||
url="http://www.libreoffice.org/"
|
||||
|
@ -70,9 +70,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
libreoffice-fresh.sh libreoffice-fresh.csh
|
||||
update_liborcus_to_0.11.0.diff
|
||||
remove_unnecessary_orcus_external_usage_from_makefiles.diff
|
||||
buildfix.diff
|
||||
fix_gtk3_smooth_scolling.diff)
|
||||
remove_unnecessary_orcus_external_usage_from_makefiles.diff)
|
||||
noextract=(boost_1_60_0.tar.bz2
|
||||
ce12af00283eb90d9281956524250d6e-xmlsec1-1.2.20.tar.gz
|
||||
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
||||
|
@ -99,11 +97,11 @@ noextract=(boost_1_60_0.tar.bz2
|
|||
libfreehand-0.1.1.tar.bz2
|
||||
185d60944ea767075d27247c3162b3bc-unowinreg.dll)
|
||||
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
|
||||
md5sums=('40ee24812d171238981599843ca9f5b6'
|
||||
md5sums=('10c9de303065e877954ee3f9717b48ec'
|
||||
'SKIP'
|
||||
'c3f98b287d1464b4b7b410833a2d79a9'
|
||||
'fe34dd1f5019df55467b7557c244fae7'
|
||||
'SKIP'
|
||||
'584877f514a723403c0344cc84a0bc59'
|
||||
'2a9334350a7585468ef11cf390076a18'
|
||||
'SKIP'
|
||||
'65a840e1a0b13a558ff19eeb2c4f0cbe'
|
||||
'ce12af00283eb90d9281956524250d6e'
|
||||
|
@ -134,9 +132,7 @@ md5sums=('40ee24812d171238981599843ca9f5b6'
|
|||
'4195735a80876ae812fca5736b50192a'
|
||||
'e7e4b3e70e99e5cba8f8dfcacf3b0d87'
|
||||
'3f526b966a672d1237cfcbadae0e3f95'
|
||||
'ac71e21ecc0976b2ea6e233854963d4b'
|
||||
'd386f3a0b484cd3929329a294159f5bc'
|
||||
'7e827ccdda93cc70e94a0766c0509a11')
|
||||
'ac71e21ecc0976b2ea6e233854963d4b')
|
||||
|
||||
prepare() {
|
||||
|
||||
|
@ -148,12 +144,6 @@ prepare() {
|
|||
ln -s ${srcdir}/$source .
|
||||
done
|
||||
popd
|
||||
|
||||
# https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-2&id=e13db0f16c4ac5a243587e881d7b18979d07f478
|
||||
patch -Np1 -i ../buildfix.diff
|
||||
|
||||
# https://cgit.freedesktop.org/libreoffice/core/patch/?id=3e60438dad304c487973fb8cdb50f3d94932af2e
|
||||
patch -Np1 -i ../fix_gtk3_smooth_scolling.diff
|
||||
|
||||
# don't run broken tests on i686
|
||||
[ "$CARCH" = "i686" ] && sed -i "/CppunitTest_sw_ooxmlexport7/d" sw/Module_sw.mk
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From e13db0f16c4ac5a243587e881d7b18979d07f478 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Mon, 25 Jul 2016 12:08:35 +0100
|
||||
Subject: curl 7.50.0 has CURL as typedef struct Curl_easy
|
||||
|
||||
Change-Id: I22e5e2cdf78c38087579071c1b1570a8adc7d3c4
|
||||
(cherry picked from commit 0b8e589875ffd84150470832de18ebd79989efc0)
|
||||
Reviewed-on: https://gerrit.libreoffice.org/27513
|
||||
Reviewed-by: David Tardon <dtardon@redhat.com>
|
||||
Tested-by: Jenkins <ci@libreoffice.org>
|
||||
|
||||
diff --git a/ucb/source/ucp/ftp/ftploaderthread.cxx b/ucb/source/ucp/ftp/ftploaderthread.cxx
|
||||
index 25bc26d..5d1cfb5 100644
|
||||
--- a/ucb/source/ucp/ftp/ftploaderthread.cxx
|
||||
+++ b/ucb/source/ucp/ftp/ftploaderthread.cxx
|
||||
@@ -77,7 +77,7 @@ FTPLoaderThread::~FTPLoaderThread() {
|
||||
|
||||
|
||||
CURL* FTPLoaderThread::handle() {
|
||||
- CURL* ret = osl_getThreadKeyData(m_threadKey);
|
||||
+ CURL* ret = static_cast<CURL*>(osl_getThreadKeyData(m_threadKey));
|
||||
if(!ret) {
|
||||
ret = curl_easy_init();
|
||||
if (ret != nullptr) {
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
|
@ -1,157 +0,0 @@
|
|||
From 3e60438dad304c487973fb8cdb50f3d94932af2e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Thu, 23 Jun 2016 17:32:11 +0100
|
||||
Subject: Resolves: rhbz#1349501 gtk3: smooth scrolling events can be
|
||||
disabled...
|
||||
|
||||
by the user with GDK_CORE_DEVICE_EVENTS=1, and so manage to disable their wheel
|
||||
scrolling
|
||||
|
||||
Change-Id: I7df63f738983c90dea75b9f43a36133910446aba
|
||||
(cherry picked from commit 7dfd50f947671d79b9119f10259857700d5728d8)
|
||||
|
||||
Resolves: rhbz#1349501 gtk3: smooth scrolling events can be disabled...
|
||||
|
||||
better fix, if we listen to the eventbox we get either SMOOTH scrolling
|
||||
or not smooth events, not both. We get SMOOTH when supported, and not
|
||||
if not supported so no need to reintroduce the miserable hack, which
|
||||
doesn't work under wayland anyway
|
||||
|
||||
Change-Id: I993e71d3553322425a506cd93d812efe081bf3c9
|
||||
Reviewed-on: https://gerrit.libreoffice.org/26645
|
||||
Tested-by: Jenkins <ci@libreoffice.org>
|
||||
Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
|
||||
|
||||
diff --git a/vcl/unx/gtk3/gtk3gtkframe.cxx b/vcl/unx/gtk3/gtk3gtkframe.cxx
|
||||
index e8d12e3..2b7ade6 100644
|
||||
--- a/vcl/unx/gtk3/gtk3gtkframe.cxx
|
||||
+++ b/vcl/unx/gtk3/gtk3gtkframe.cxx
|
||||
@@ -1013,6 +1013,7 @@ void GtkSalFrame::InitCommon()
|
||||
m_aMouseSignalIds.push_back(g_signal_connect( G_OBJECT(pEventWidget), "drag-failed", G_CALLBACK(signalDragFailed), this ));
|
||||
m_aMouseSignalIds.push_back(g_signal_connect( G_OBJECT(pEventWidget), "drag-data-delete", G_CALLBACK(signalDragDelete), this ));
|
||||
m_aMouseSignalIds.push_back(g_signal_connect( G_OBJECT(pEventWidget), "drag-data-get", G_CALLBACK(signalDragDataGet), this ));
|
||||
+ m_aMouseSignalIds.push_back(g_signal_connect( G_OBJECT(pEventWidget), "scroll-event", G_CALLBACK(signalScroll), this ));
|
||||
|
||||
g_signal_connect( G_OBJECT(m_pFixedContainer), "draw", G_CALLBACK(signalDraw), this );
|
||||
g_signal_connect( G_OBJECT(m_pFixedContainer), "size-allocate", G_CALLBACK(sizeAllocated), this );
|
||||
@@ -1038,7 +1039,6 @@ void GtkSalFrame::InitCommon()
|
||||
g_signal_connect( G_OBJECT(m_pWindow), "key-release-event", G_CALLBACK(signalKey), this );
|
||||
g_signal_connect( G_OBJECT(m_pWindow), "delete-event", G_CALLBACK(signalDelete), this );
|
||||
g_signal_connect( G_OBJECT(m_pWindow), "window-state-event", G_CALLBACK(signalWindowState), this );
|
||||
- g_signal_connect( G_OBJECT(m_pWindow), "scroll-event", G_CALLBACK(signalScroll), this );
|
||||
g_signal_connect( G_OBJECT(m_pWindow), "leave-notify-event", G_CALLBACK(signalCrossing), this );
|
||||
g_signal_connect( G_OBJECT(m_pWindow), "enter-notify-event", G_CALLBACK(signalCrossing), this );
|
||||
g_signal_connect( G_OBJECT(m_pWindow), "visibility-notify-event", G_CALLBACK(signalVisibility), this );
|
||||
@@ -2664,9 +2664,6 @@ gboolean GtkSalFrame::signalScroll( GtkWidget*, GdkEventScroll* pEvent, gpointer
|
||||
{
|
||||
UpdateLastInputEventTime(pEvent->time);
|
||||
|
||||
- if (pEvent->direction != GDK_SCROLL_SMOOTH)
|
||||
- return false;
|
||||
-
|
||||
GtkSalFrame* pThis = static_cast<GtkSalFrame*>(frame);
|
||||
|
||||
SalWheelMouseEvent aEvent;
|
||||
@@ -2679,36 +2676,74 @@ gboolean GtkSalFrame::signalScroll( GtkWidget*, GdkEventScroll* pEvent, gpointer
|
||||
aEvent.mnY = (sal_uLong)pEvent->y;
|
||||
aEvent.mnCode = GetMouseModCode( pEvent->state );
|
||||
|
||||
- // rhbz#1344042 "Traditionally" in gtk3 we tool a single up/down event as
|
||||
- // equating to 3 scroll lines and a delta of 120. So scale the delta here
|
||||
- // by 120 where a single mouse wheel click is an incoming delta_x of 1
|
||||
- // and divide that by 40 to get the number of scrollines
|
||||
- if (pEvent->delta_x != 0.0)
|
||||
+ switch (pEvent->direction)
|
||||
{
|
||||
- aEvent.mnDelta = -pEvent->delta_x * 120;
|
||||
- aEvent.mnNotchDelta = aEvent.mnDelta < 0 ? -1 : +1;
|
||||
- if (aEvent.mnDelta == 0)
|
||||
- aEvent.mnDelta = aEvent.mnNotchDelta;
|
||||
- aEvent.mbHorz = true;
|
||||
- aEvent.mnScrollLines = std::abs(aEvent.mnDelta) / 40;
|
||||
- if (aEvent.mnScrollLines == 0)
|
||||
- aEvent.mnScrollLines = 1;
|
||||
+ case GDK_SCROLL_SMOOTH:
|
||||
+ // rhbz#1344042 "Traditionally" in gtk3 we tool a single up/down event as
|
||||
+ // equating to 3 scroll lines and a delta of 120. So scale the delta here
|
||||
+ // by 120 where a single mouse wheel click is an incoming delta_x of 1
|
||||
+ // and divide that by 40 to get the number of scrollines
|
||||
+ if (pEvent->delta_x != 0.0)
|
||||
+ {
|
||||
+ aEvent.mnDelta = -pEvent->delta_x * 120;
|
||||
+ aEvent.mnNotchDelta = aEvent.mnDelta < 0 ? -1 : +1;
|
||||
+ if (aEvent.mnDelta == 0)
|
||||
+ aEvent.mnDelta = aEvent.mnNotchDelta;
|
||||
+ aEvent.mbHorz = true;
|
||||
+ aEvent.mnScrollLines = std::abs(aEvent.mnDelta) / 40;
|
||||
+ if (aEvent.mnScrollLines == 0)
|
||||
+ aEvent.mnScrollLines = 1;
|
||||
+
|
||||
+ pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ }
|
||||
|
||||
- pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
- }
|
||||
+ if (pEvent->delta_y != 0.0)
|
||||
+ {
|
||||
+ aEvent.mnDelta = -pEvent->delta_y * 120;
|
||||
+ aEvent.mnNotchDelta = aEvent.mnDelta < 0 ? -1 : +1;
|
||||
+ if (aEvent.mnDelta == 0)
|
||||
+ aEvent.mnDelta = aEvent.mnNotchDelta;
|
||||
+ aEvent.mbHorz = false;
|
||||
+ aEvent.mnScrollLines = std::abs(aEvent.mnDelta) / 40;
|
||||
+ if (aEvent.mnScrollLines == 0)
|
||||
+ aEvent.mnScrollLines = 1;
|
||||
+
|
||||
+ pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ }
|
||||
|
||||
- if (pEvent->delta_y != 0.0)
|
||||
- {
|
||||
- aEvent.mnDelta = -pEvent->delta_y * 120;
|
||||
- aEvent.mnNotchDelta = aEvent.mnDelta < 0 ? -1 : +1;
|
||||
- if (aEvent.mnDelta == 0)
|
||||
- aEvent.mnDelta = aEvent.mnNotchDelta;
|
||||
- aEvent.mbHorz = false;
|
||||
- aEvent.mnScrollLines = std::abs(aEvent.mnDelta) / 40;
|
||||
- if (aEvent.mnScrollLines == 0)
|
||||
- aEvent.mnScrollLines = 1;
|
||||
+ break;
|
||||
+
|
||||
+ case GDK_SCROLL_UP:
|
||||
+ aEvent.mnDelta = 120;
|
||||
+ aEvent.mnNotchDelta = 1;
|
||||
+ aEvent.mnScrollLines = 3;
|
||||
+ aEvent.mbHorz = false;
|
||||
+ pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ break;
|
||||
+
|
||||
+ case GDK_SCROLL_DOWN:
|
||||
+ aEvent.mnDelta = -120;
|
||||
+ aEvent.mnNotchDelta = -1;
|
||||
+ aEvent.mnScrollLines = 3;
|
||||
+ aEvent.mbHorz = false;
|
||||
+ pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ break;
|
||||
+
|
||||
+ case GDK_SCROLL_LEFT:
|
||||
+ aEvent.mnDelta = 120;
|
||||
+ aEvent.mnNotchDelta = 1;
|
||||
+ aEvent.mnScrollLines = 3;
|
||||
+ aEvent.mbHorz = true;
|
||||
+ pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ break;
|
||||
|
||||
- pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ case GDK_SCROLL_RIGHT:
|
||||
+ aEvent.mnDelta = -120;
|
||||
+ aEvent.mnNotchDelta = -1;
|
||||
+ aEvent.mnScrollLines = 3;
|
||||
+ aEvent.mbHorz = true;
|
||||
+ pThis->CallCallback(SalEvent::WheelMouse, &aEvent);
|
||||
+ break;
|
||||
}
|
||||
|
||||
return true;
|
||||
--
|
||||
cgit v0.10.2
|
Loading…
Reference in a new issue