core/openssl-cryptodev to 1.0.2.g-1

This commit is contained in:
Kevin Mihelich 2016-03-06 16:40:59 +00:00
parent 8c2bfc285c
commit 03d695142f
2 changed files with 35 additions and 3 deletions

View file

@ -13,7 +13,7 @@ buildarch=6
pkgname=openssl-cryptodev
_pkgname=openssl
_ver=1.0.2f
_ver=1.0.2g
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
#pkgver=$_ver
@ -32,12 +32,14 @@ _cryptover=1.8
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
'no-rpath.patch'
'ssl3-test-failure.patch'
'ca-dir.patch'
"http://download.gna.org/cryptodev-linux/cryptodev-linux-${_cryptover}.tar.gz"
'fix_sig-gen_and_allow_copy_evp_contexts.patch')
md5sums=('b3bf73f507172be9292ea2a8c28b659d'
md5sums=('f3c710c045cdee5fd114feb69feba7aa'
'dc78d3d06baffc16217519242ce92478'
'62fc492252edd3283871632bb77fadbe'
'3bf51be3a1bbd262be46dc619f92aa90'
'02644cc4cd02301e0b503a332eb2f0b5'
'91c72fe6b89e3134bc61cfb4311bf348')
@ -48,6 +50,10 @@ prepare() {
# remove rpath: http://bugs.archlinux.org/task/14367
patch -p0 -i $srcdir/no-rpath.patch
# disable a test that fails when ssl3 is disabled
patch -p1 -i $srcdir/ssl3-test-failure.patch
# set ca dir to /etc/ssl by default
patch -p0 -i $srcdir/ca-dir.patch
@ -73,7 +79,7 @@ build() {
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
-DHAVE_CRYPTODEV -DHASH_MAX_LEN=64 \
shared threads zlib \
shared threads no-ssl3-method \
"${openssltarget}" \
"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"

View file

@ -0,0 +1,26 @@
From: Kurt Roeckx <kurt@roeckx.be>
Date: Sun, 6 Sep 2015 16:04:11 +0200
Subject: Disable SSLv3 test in test suite
When testing SSLv3 the test program returns 0 for skip. The test for weak DH
expects a failure, but gets success.
It should probably be changed to return something other than 0 for a skipped
test.
---
test/testssl | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/testssl b/test/testssl
index 747e4ba..1e4370b 100644
--- a/test/testssl
+++ b/test/testssl
@@ -160,7 +160,7 @@ test_cipher() {
}
echo "Testing ciphersuites"
-for protocol in TLSv1.2 SSLv3; do
+for protocol in TLSv1.2; do
echo "Testing ciphersuites for $protocol"
for cipher in `../util/shlib_wrap.sh ../apps/openssl ciphers "RSA+$protocol" | tr ':' ' '`; do
test_cipher $cipher $protocol