extra/netpbm to 10.73.41-1

This commit is contained in:
Kevin Mihelich 2022-11-30 02:13:06 +00:00
parent ea83f946d9
commit 03e36cf852
2 changed files with 10 additions and 10 deletions

View file

@ -4,8 +4,8 @@
# - add armv7h and aarch64 for -fPIC flag
pkgname=netpbm
pkgver=10.73.37
pkgrel=2
pkgver=10.73.41
pkgrel=1
pkgdesc="A toolkit for manipulation of graphic images"
arch=('x86_64')
license=('custom' 'BSD' 'GPL' 'LGPL')
@ -18,11 +18,11 @@ source=(https://downloads.sourceforge.net/project/netpbm/super_stable/$pkgver/ne
https://sources.archlinux.org/other/packages/netpbm/netpbm-doc-31Jan2014.tar.xz{,.sig}
netpbm-CAN-2005-2471.patch netpbm-security-code.patch netpbm-security-scripts.patch
reproducible-man-gzip.patch use-source-date-epoch.patch)
sha256sums=('e8826b5bc9a283220a60e8a24c6f5a854f5825c15e4f5171e77b6884f191fafd'
sha256sums=('f572625514b52dde4e2b6e567b8e2738b133e50ee3c5b31d80016117440311fe'
'74bcf840ee643c6917330c382484010cb99c004a3fcf05391bebcac63815acb3'
'SKIP'
'991aba7897e0710687369b4e2edfba1397ecd77d62578eac496afbc47b5ca970'
'83d75a80ce999d8b69572e54f04c4d220c60b0d09f9e52d3236264535c3bf216'
'343a72eb67edb338bc593d823ced770a0fe44c4c1fa4f4ac1934b84da4431579'
'2c397588d9cba2c40dee55c07713d5e77e0e04245db939fdc1962d7de4cf4a33'
'8e3efdb4fcbfdc8e9a5c8e9663c7d6b9ecef3a2379ce38d2acc5669c339f6814'
'68055341833f482c6910a56c2fdfe046978a1a92fd8442a2a9209c82ce3e4d13')

View file

@ -232,14 +232,14 @@ index 9f7004a..60e8477 100644
--- a/converter/pbm/mgrtopbm.c
+++ b/converter/pbm/mgrtopbm.c
@@ -65,6 +65,8 @@ readMgrHeader(FILE * const ifP,
if (head.h_high < ' ' || head.l_high < ' ')
pm_error("Invalid width field in MGR header");
pad = 0; /* should never reach here */
}
+ overflow_add(*colsP, pad);
+
*colsP = (((int)head.h_wide - ' ') << 6) + ((int)head.l_wide - ' ');
*rowsP = (((int)head.h_high - ' ') << 6) + ((int) head.l_high - ' ');
*padrightP = ( ( *colsP + pad - 1 ) / pad ) * pad - *colsP;
interpHdrWidth (head, colsP);
interpHdrHeight(head, rowsP);
diff --git a/converter/pbm/pbmto4425.c b/converter/pbm/pbmto4425.c
index 1d97ac6..c4c8cbb 100644
--- a/converter/pbm/pbmto4425.c