mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/vulkan-tools: add patch
This commit is contained in:
parent
cc44304835
commit
0445379571
1 changed files with 36 additions and 0 deletions
|
@ -0,0 +1,36 @@
|
|||
From 8ee48dc62f7c0fc7b4dab7befc2f601b1873d620 Mon Sep 17 00:00:00 2001
|
||||
From: Tony-LunarG <tony@lunarg.com>
|
||||
Date: Thu, 7 May 2020 10:02:58 -0600
|
||||
Subject: [PATCH] cube: Remove dependency on VK_DYNAMIC_STATE_RANGE_SIZE
|
||||
|
||||
Change-Id: Id6b3906d2605c4742ad0af45747fc37c23cab03e
|
||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
||||
---
|
||||
cube/cube.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/cube/cube.c b/cube/cube.c
|
||||
index 602b4bdc..8c87b5c8 100644
|
||||
--- a/cube/cube.c
|
||||
+++ b/cube/cube.c
|
||||
@@ -1974,6 +1974,8 @@ static void demo_prepare_fs(struct demo *demo) {
|
||||
}
|
||||
|
||||
static void demo_prepare_pipeline(struct demo *demo) {
|
||||
+#define NUM_DYNAMIC_STATES 2 /*Viewport + Scissor*/
|
||||
+
|
||||
VkGraphicsPipelineCreateInfo pipeline;
|
||||
VkPipelineCacheCreateInfo pipelineCache;
|
||||
VkPipelineVertexInputStateCreateInfo vi;
|
||||
@@ -1983,7 +1985,7 @@ static void demo_prepare_pipeline(struct demo *demo) {
|
||||
VkPipelineDepthStencilStateCreateInfo ds;
|
||||
VkPipelineViewportStateCreateInfo vp;
|
||||
VkPipelineMultisampleStateCreateInfo ms;
|
||||
- VkDynamicState dynamicStateEnables[VK_DYNAMIC_STATE_RANGE_SIZE];
|
||||
+ VkDynamicState dynamicStateEnables[NUM_DYNAMIC_STATES];
|
||||
VkPipelineDynamicStateCreateInfo dynamicState;
|
||||
VkResult U_ASSERT_ONLY err;
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
Loading…
Reference in a new issue