mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/uboot-dragonboard to 2017.01-1
This commit is contained in:
parent
5948dd8236
commit
04710c30f0
4 changed files with 14 additions and 39 deletions
|
@ -1,24 +0,0 @@
|
|||
From 9c16cc6373f770338a55a5b9802257c8faf5dde0 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 5 Mar 2016 12:27:57 -0700
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
---
|
||||
configs/dragonboard410c_defconfig | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configs/dragonboard410c_defconfig b/configs/dragonboard410c_defconfig
|
||||
index 34250c3..b6dfa09 100644
|
||||
--- a/configs/dragonboard410c_defconfig
|
||||
+++ b/configs/dragonboard410c_defconfig
|
||||
@@ -1,6 +1,6 @@
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARCH_SNAPDRAGON=y
|
||||
-CONFIG_IDENT_STRING="\nQualcomm-DragonBoard 410C"
|
||||
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
||||
CONFIG_DEFAULT_DEVICE_TREE="dragonboard410c"
|
||||
# CONFIG_DISPLAY_CPUINFO is not set
|
||||
# CONFIG_DISPLAY_BOARDINFO is not set
|
||||
--
|
||||
2.10.2
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=8
|
||||
|
||||
pkgname=uboot-dragonboard
|
||||
pkgver=2016.11
|
||||
pkgver=2017.01
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for Dragonboard 410c"
|
||||
arch=('aarch64')
|
||||
|
@ -14,20 +14,12 @@ install=$pkgname.install
|
|||
backup=('boot/boot.txt' 'boot/boot.scr')
|
||||
makedepends=('bc' 'dtc' 'git' 'skales')
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'boot.txt'
|
||||
'mkscr')
|
||||
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
|
||||
'a573d5abed9bbdc7b9e699c38c4c7b53'
|
||||
'fd933e5a372406ab0a9606e2dd696ab9'
|
||||
md5sums=('ad2d82d5b4fa548b2b95bbc26c9bad79'
|
||||
'83c37689d37ae2ab7ac5def663d65284'
|
||||
'021623a04afd29ac3f368977140cfbfd')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
git apply ../0001-arch-linux-arm-modifications.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
|
@ -35,6 +27,7 @@ build() {
|
|||
|
||||
make distclean
|
||||
make dragonboard410c_config
|
||||
echo 'CONFIG_IDENT_STRING=" Arch Linux ARM"' >> .config
|
||||
make EXTRAVERSION=-${pkgrel}
|
||||
}
|
||||
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
test -n "${distro_bootpart}" || setenv distro_bootpart 1
|
||||
part uuid ${devtype} ${devnum}:${distro_bootpart} uuid
|
||||
setenv bootargs "console=tty1 console=ttyMSM0,115200n8 root=PARTUUID=${uuid} rw rootwait"
|
||||
setenv bootargs "console=tty1 console=ttyMSM0,115200n8 root=PARTUUID=${uuid} rw rootwait earlycon"
|
||||
|
||||
if load ${devtype} ${devnum}:${distro_bootpart} ${loadaddr} /boot/Image; then
|
||||
if load ${devtype} ${devnum}:${distro_bootpart} ${fdt_addr_r} /boot/dtbs/qcom/${fdtfile}; then
|
||||
|
|
|
@ -1,12 +1,18 @@
|
|||
flash_uboot() {
|
||||
echo "A new U-Boot version needs to be flashed onto /dev/mmcblk0p8."
|
||||
if [[ -e /dev/mmcblk0boot1 ]]; then
|
||||
dev="/dev/mmcblk0p8"
|
||||
else
|
||||
dev="/dev/mmcblk1p8"
|
||||
fi
|
||||
|
||||
echo "A new U-Boot version needs to be flashed onto ${dev}."
|
||||
echo "Do you want to do this now? [y|N]"
|
||||
read -r shouldwe
|
||||
if [[ $shouldwe =~ ^([yY][eE][sS]|[yY])$ ]]; then
|
||||
dd if=/boot/u-boot.img of=/dev/mmcblk0p8
|
||||
dd if=/boot/u-boot.img of=${dev}
|
||||
else
|
||||
echo "You can do this later by running:"
|
||||
echo "# dd if=/boot/u-boot.img of=/dev/mmcblk0p8"
|
||||
echo "# dd if=/boot/u-boot.img of=${dev}"
|
||||
fi
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue