core/binutils to 2.38-4

This commit is contained in:
Kevin Mihelich 2022-04-13 23:54:37 +00:00
parent ef26c02e55
commit 0490bef45f
2 changed files with 90 additions and 7 deletions

View file

@ -1,4 +1,6 @@
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org> # Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
# Maintainer: Frederik Schwan <freswa at archlinux dot org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org> # Contributor: Allan McRae <allan@archlinux.org>
# toolchain build order: linux-api-headers->glibc->binutils->gcc->glibc->binutils->gcc # toolchain build order: linux-api-headers->glibc->binutils->gcc->glibc->binutils->gcc
@ -10,11 +12,11 @@ noautobuild=1
pkgname=binutils pkgname=binutils
pkgver=2.38 pkgver=2.38
pkgrel=3 pkgrel=4
pkgdesc='A set of programs to assemble and manipulate binary and object files' pkgdesc='A set of programs to assemble and manipulate binary and object files'
arch=(x86_64) arch=(x86_64)
url='https://www.gnu.org/software/binutils/' url='https://www.gnu.org/software/binutils/'
license=(GPL) license=('GPL3' 'GPL' 'FDL1.3' 'custom:FSFAP')
groups=(base-devel) groups=(base-devel)
depends=(glibc zlib libelf) depends=(glibc zlib libelf)
checkdepends=(dejagnu debuginfod bc) checkdepends=(dejagnu debuginfod bc)
@ -23,9 +25,11 @@ options=(staticlibs !distcc !ccache debug)
#_commit=cb5f6a3e146cc70bc2d864989386df80acec5d3e #_commit=cb5f6a3e146cc70bc2d864989386df80acec5d3e
#source=(git+https://sourceware.org/git/binutils-gdb.git#commit=$_commit) #source=(git+https://sourceware.org/git/binutils-gdb.git#commit=$_commit)
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig} source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
gold-warn-unsupported.patch
fix-incorrect-undefined-symbol.patch) fix-incorrect-undefined-symbol.patch)
sha256sums=('e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024' sha256sums=('e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024'
'SKIP' 'SKIP'
'2d430b66f84a19c154725ec535280c493be1d34f1a90f95208dce02fecd0e4e4'
'fd33b2f8cac7561cecf3fdbb5a50fd2f2dfa6420516cbe57c47784a06fa16bf6') 'fd33b2f8cac7561cecf3fdbb5a50fd2f2dfa6420516cbe57c47784a06fa16bf6')
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F) validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
@ -38,8 +42,11 @@ prepare() {
# Turn off development mode (-Werror, gas run-time checks, date in sonames) # Turn off development mode (-Werror, gas run-time checks, date in sonames)
sed -i '/^development=/s/true/false/' bfd/development.sh sed -i '/^development=/s/true/false/' bfd/development.sh
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS" # Creds @Fedora
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure # Change the gold configuration script to only warn about
# unsupported targets. This allows the binutils to be built with
# BPF support enabled.
patch -Np1 -i "${srcdir}"/gold-warn-unsupported.patch
# fix incorrect "undefined reference" errors # fix incorrect "undefined reference" errors
# https://sourceware.org/bugzilla/show_bug.cgi?id=28879 # https://sourceware.org/bugzilla/show_bug.cgi?id=28879
@ -61,7 +68,6 @@ build() {
--enable-gold \ --enable-gold \
--enable-install-libiberty \ --enable-install-libiberty \
--enable-ld=default \ --enable-ld=default \
--enable-lto \
--enable-plugins \ --enable-plugins \
--enable-relro \ --enable-relro \
--enable-shared \ --enable-shared \
@ -78,6 +84,11 @@ build() {
$CONFIGFLAG $CONFIGFLAG
make -O tooldir=/usr make -O tooldir=/usr
# Extract the FSF All Permissive License
# <https://www.gnu.org/prep/maintain/html_node/License-Notices-for-Other-Files.html>
# used for some linker scripts.
tail -n 5 "${srcdir}"/binutils-${pkgver}/ld/scripttempl/README > FSFAP
} }
check() { check() {
@ -97,11 +108,17 @@ package() {
cd binutils-build cd binutils-build
make prefix="$pkgdir/usr" tooldir="$pkgdir/usr" install make prefix="$pkgdir/usr" tooldir="$pkgdir/usr" install
# install PIC version of libiberty
install -m644 libiberty/pic/libiberty.a "$pkgdir/usr/lib"
# Remove unwanted files # Remove unwanted files
rm -f "$pkgdir"/usr/share/man/man1/{dlltool,nlmconv,windres,windmc}* rm -f "$pkgdir"/usr/share/man/man1/{dlltool,windres,windmc}*
# No shared linking to these files outside binutils # No shared linking to these files outside binutils
rm -f "$pkgdir"/usr/lib/lib{bfd,opcodes}.so rm -f "$pkgdir"/usr/lib/lib{bfd,opcodes}.so
echo 'INPUT( /usr/lib/libbfd.a -liberty -lz -ldl )' > "$pkgdir/usr/lib/libbfd.so" echo 'INPUT( /usr/lib/libbfd.a -liberty -lz -ldl )' > "$pkgdir/usr/lib/libbfd.so"
echo 'INPUT( /usr/lib/libopcodes.a -lbfd )' > "$pkgdir/usr/lib/libopcodes.so" echo 'INPUT( /usr/lib/libopcodes.a -lbfd )' > "$pkgdir/usr/lib/libopcodes.so"
# install FSF All Permissive License
install -Dm644 -t "${pkgdir}"/usr/share/licenses/${pkgname}/ FSFAP
} }

View file

@ -0,0 +1,66 @@
Only in binutils-2.34/gold: autom4te.cache
diff -rup binutils.orig/gold/configure binutils-2.34/gold/configure
--- binutils.orig/gold/configure 2020-04-20 12:35:13.048297305 +0100
+++ binutils-2.34/gold/configure 2020-04-20 14:02:06.743725696 +0100
@@ -5180,7 +5180,8 @@ for targ in $target $canon_targets; do
. ${srcdir}/configure.tgt
if test "$targ_obj" = "UNKNOWN"; then
- as_fn_error $? "\"unsupported target $targ\"" "$LINENO" 5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: \"unsupported target $targ\"" >&5
+$as_echo "$as_me: WARNING: \"unsupported target $targ\"" >&2;}
else
targetobjs="$targetobjs ${targ_obj}.\$(OBJEXT)"
if test "$targ_extra_obj" != ""; then
diff -rup binutils.orig/gold/configure.ac binutils-2.34/gold/configure.ac
--- binutils.orig/gold/configure.ac 2020-04-20 12:35:13.050297291 +0100
+++ binutils-2.34/gold/configure.ac 2020-04-20 14:01:46.435868770 +0100
@@ -181,7 +181,7 @@ for targ in $target $canon_targets; do
. ${srcdir}/configure.tgt
if test "$targ_obj" = "UNKNOWN"; then
- AC_MSG_ERROR("unsupported target $targ")
+ AC_MSG_WARN("unsupported target $targ")
else
targetobjs="$targetobjs ${targ_obj}.\$(OBJEXT)"
if test "$targ_extra_obj" != ""; then
--- binutils.orig/ld/configure.tgt 2020-04-20 12:35:12.465301359 +0100
+++ binutils-2.34/ld/configure.tgt 2020-04-20 14:17:52.123066333 +0100
@@ -220,7 +220,7 @@ bfin-*-linux-uclibc*) targ_emul=elf32bfi
targ_extra_emuls="elf32bfin"
targ_extra_libpath=$targ_extra_emuls
;;
-bpf-*-*) targ_emul=elf64bpf
+bpf-* | bpf-*-*) targ_emul=elf64bpf
;;
cr16-*-elf*) targ_emul=elf32cr16
;;
@@ -1026,7 +1026,7 @@ z8k-*-coff) targ_emul=z8002
targ_extra_ofiles=
;;
*)
- echo 2>&1 "*** ld does not support target ${targ}"
+ echo 2>&1 "*** ld does not support target '${targ}' NO REALLY"
echo 2>&1 "*** see ld/configure.tgt for supported targets"
exit 1
--- binutils.orig/bfd/config.bfd 2020-04-20 12:35:13.038297375 +0100
+++ binutils-2.34/bfd/config.bfd 2020-04-20 14:25:26.452869193 +0100
@@ -473,7 +473,7 @@ case "${targ}" in
;;
#ifdef BFD64
- bpf-*-none)
+ bpf-*-none | bpf-*)
targ_defvec=bpf_elf64_le_vec
targ_selvecs=bpf_elf64_be_vec
targ_underscore=yes
@@ -1427,7 +1427,7 @@ case "${targ}" in
;;
*)
- echo 1>&2 "*** BFD does not support target ${targ}."
+ echo 1>&2 "*** BFD does not support target '${targ}'. Honest."
echo 1>&2 "*** Look in bfd/config.bfd for supported targets."
exit 1
;;