mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed community/python2-gevent
This commit is contained in:
parent
6acb1c4f51
commit
050b0a0560
2 changed files with 0 additions and 60 deletions
|
@ -1,42 +0,0 @@
|
|||
# $Id: PKGBUILD 70305 2012-05-04 08:21:08Z mtorromeo $
|
||||
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
|
||||
# Maintainer: Felix Yan <felixonmars@gmail.com>
|
||||
# Contributor: Ralf Schmitt <ralf@systemexit.de>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - fix build on v5 (https://github.com/surfly/gevent/issues/361)
|
||||
|
||||
pkgname=python2-gevent
|
||||
pkgver=1.0
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
pkgdesc="Python network library that uses greenlet and libev for easy and scalable concurrency"
|
||||
license=("MIT")
|
||||
url="http://www.gevent.org/"
|
||||
depends=('python2-greenlet')
|
||||
makedepends=('git' 'cython2')
|
||||
provides=('python2-gevent-beta')
|
||||
conflicts=('python2-gevent-beta')
|
||||
replaces=('python2-gevent-beta')
|
||||
source=("git://github.com/surfly/gevent.git#tag=$pkgver"
|
||||
'arm.patch')
|
||||
|
||||
build() {
|
||||
cd gevent
|
||||
patch -p1 -i ../arm.patch
|
||||
|
||||
LIBEV_EMBED=1 \
|
||||
CARES_EMBED=1 \
|
||||
CYTHON=cython2 \
|
||||
PYTHON=python2 \
|
||||
python2 setup.py build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd gevent
|
||||
python2 setup.py install -O1 --root="$pkgdir"
|
||||
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
||||
|
||||
md5sums=('SKIP'
|
||||
'236cc90a02935adfeb2c70cd90d3e63f')
|
|
@ -1,18 +0,0 @@
|
|||
diff -urN a/libev/ev.c b/libev/ev.c
|
||||
--- a/libev/ev.c 2014-01-02 23:06:39.749417954 -0700
|
||||
+++ b/libev/ev.c 2014-01-02 23:08:08.359034557 -0700
|
||||
@@ -617,9 +617,11 @@
|
||||
#if ECB_GCC_VERSION(4,7)
|
||||
/* see comment below (stdatomic.h) about the C11 memory model. */
|
||||
#define ECB_MEMORY_FENCE __atomic_thread_fence (__ATOMIC_SEQ_CST)
|
||||
- #elif defined __clang && __has_feature (cxx_atomic)
|
||||
- /* see comment below (stdatomic.h) about the C11 memory model. */
|
||||
- #define ECB_MEMORY_FENCE __c11_atomic_thread_fence (__ATOMIC_SEQ_CST)
|
||||
+ #elif defined __clang
|
||||
+ #if __has_feature (cxx_atomic)
|
||||
+ /* see comment below (stdatomic.h) about the C11 memory model. */
|
||||
+ #define ECB_MEMORY_FENCE __c11_atomic_thread_fence (__ATOMIC_SEQ_CST)
|
||||
+ #endif
|
||||
#elif ECB_GCC_VERSION(4,4) || defined __INTEL_COMPILER || defined __clang__
|
||||
#define ECB_MEMORY_FENCE __sync_synchronize ()
|
||||
#elif _MSC_VER >= 1400 /* VC++ 2005 */
|
Loading…
Reference in a new issue