mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added extra/qt5
This commit is contained in:
parent
6d433859ed
commit
0518262048
7 changed files with 443 additions and 0 deletions
297
extra/qt5/PKGBUILD
Normal file
297
extra/qt5/PKGBUILD
Normal file
|
@ -0,0 +1,297 @@
|
|||
# $Id: PKGBUILD 179039 2013-03-01 20:22:01Z andrea $
|
||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed libfbclient, ibase
|
||||
# - no x86/neon optimizations
|
||||
# - disabled distcc
|
||||
|
||||
pkgbase=qt5
|
||||
pkgname=('qt5-base'
|
||||
'qt5-declarative'
|
||||
'qt5-doc'
|
||||
'qt5-graphicaleffects'
|
||||
'qt5-imageformats'
|
||||
'qt5-jsbackend'
|
||||
'qt5-multimedia'
|
||||
'qt5-quick1'
|
||||
'qt5-script'
|
||||
'qt5-svg'
|
||||
'qt5-tools'
|
||||
'qt5-translations'
|
||||
'qt5-webkit'
|
||||
'qt5-xmlpatterns')
|
||||
pkgver=5.0.1
|
||||
pkgrel=5
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL')
|
||||
makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
|
||||
'mesa-libgl' 'at-spi2-core' 'alsa-lib' 'gstreamer0.10-base-plugins'
|
||||
'libjpeg-turbo' 'cups' 'libpulse' 'hicolor-icon-theme' 'desktop-file-utils'
|
||||
'postgresql-libs' 'libmysqlclient' 'sqlite' 'unixodbc'
|
||||
'python2' 'ruby' 'gperf')
|
||||
groups=('qt' 'qt5')
|
||||
options=('!libtool' '!distcc')
|
||||
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
||||
source=("http://releases.qt-project.org/${pkgbase}/${pkgver}/single/${_pkgfqn}.tar.xz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'use-python2.patch')
|
||||
md5sums=('00a577bd88e682d1b4d01d41d1d699cf'
|
||||
'f1837a03fd0ebbd2da58975845f278e3'
|
||||
'480fea1ed076992b688373c8db274be0'
|
||||
'5595c24d5bb942c21e3a4d299e6d0bf1'
|
||||
'ec3133b093550f16a21bb91e5f0f2943')
|
||||
|
||||
build() {
|
||||
cd ${_pkgfqn}
|
||||
|
||||
export QTDIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QTDIR}/lib:${LD_LIBRARY_PATH}
|
||||
|
||||
sed -i "s|-O2|${CXXFLAGS}|" qtbase/mkspecs/common/{g++,gcc}-base.conf
|
||||
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" qtbase/mkspecs/common/gcc-base-unix.conf
|
||||
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" qtbase/mkspecs/common/gcc-base.conf
|
||||
|
||||
# Use python2 for Python 2.x
|
||||
patch -p1 -i "${srcdir}"/use-python2.patch
|
||||
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
|
||||
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
|
||||
$(find . -name '*.py')
|
||||
|
||||
./configure -confirm-license -opensource \
|
||||
-prefix /usr \
|
||||
-docdir /usr/share/doc/qt \
|
||||
-headerdir /usr/include/qt5 \
|
||||
-archdatadir /usr/lib/qt \
|
||||
-datadir /usr/share/qt \
|
||||
-sysconfdir /etc/xdg \
|
||||
-examplesdir /usr/share/doc/qt/examples \
|
||||
-plugin-sql-{psql,mysql,sqlite,odbc} \
|
||||
-system-sqlite \
|
||||
-openssl-linked \
|
||||
-nomake docs \
|
||||
-nomake examples \
|
||||
-nomake tests \
|
||||
-no-rpath \
|
||||
-optimized-qmake \
|
||||
-dbus-linked \
|
||||
-reduce-relocations \
|
||||
-no-sse2 \
|
||||
-no-sse3 \
|
||||
-no-ssse3 \
|
||||
-no-sse4.1 \
|
||||
-no-sse4.2 \
|
||||
-no-avx \
|
||||
-no-avx2 \
|
||||
-no-neon
|
||||
|
||||
make
|
||||
|
||||
# Build docs
|
||||
make qmake_all
|
||||
make docs
|
||||
}
|
||||
|
||||
package_qt5-base() {
|
||||
pkgdesc=('A cross-platform application and UI framework')
|
||||
depends=('libjpeg-turbo' 'xcb-util-keysyms' 'libgl' 'dbus' 'fontconfig' 'systemd'
|
||||
'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'libpng' 'xcb-util-image'
|
||||
'hicolor-icon-theme' 'xdg-utils')
|
||||
optdepends=('postgresql-libs: PostgreSQL driver'
|
||||
'libmysqlclient: MySQL driver'
|
||||
'unixodbc: ODBC driver')
|
||||
install='qt5-base.install'
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtbase
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
cd "${srcdir}"
|
||||
install -D -m644 ${_pkgfqn}/qtbase/LGPL_EXCEPTION.txt \
|
||||
${pkgdir}/usr/share/licenses/${pkgbase}/LGPL_EXCEPTION.txt
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
|
||||
# Fix wrong qmake path in pri file
|
||||
sed -i "s|${srcdir}/${_pkgfqn}/qtbase|/usr|" \
|
||||
"${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap.pri
|
||||
}
|
||||
|
||||
package_qt5-declarative() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtQml, QtQuick)')
|
||||
depends=('qt5-jsbackend' 'qt5-xmlpatterns')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtdeclarative
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-doc() {
|
||||
pkgdesc=('A cross-platform application and UI framework (Documentation)')
|
||||
depends=('qt5-base')
|
||||
conflicts=('qt-doc')
|
||||
replaces=('qt-doc')
|
||||
provides=('qt-doc')
|
||||
options=('docs')
|
||||
groups=()
|
||||
|
||||
cd ${_pkgfqn}
|
||||
make INSTALL_ROOT="${pkgdir}" install_docs
|
||||
}
|
||||
|
||||
package_qt5-jsbackend() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtV8)')
|
||||
depends=('qt5-base')
|
||||
|
||||
cd ${_pkgfqn}/qtjsbackend
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-xmlpatterns() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtXmlPatterns)')
|
||||
depends=('qt5-base')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtxmlpatterns
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-translations() {
|
||||
pkgdesc=('A cross-platform application and UI framework (Translations)')
|
||||
depends=('qt5-base')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qttranslations
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_qt5-multimedia() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtMultimedia)')
|
||||
depends=('qt5-declarative' 'libpulse' 'gstreamer0.10-base')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtmultimedia
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-graphicaleffects() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtGraphicalEffects)')
|
||||
depends=('qt5-declarative')
|
||||
|
||||
cd ${_pkgfqn}/qtgraphicaleffects
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_qt5-imageformats() {
|
||||
pkgdesc=('A cross-platform application and UI framework (Images plugins)')
|
||||
depends=('qt5-base' 'libtiff')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtimageformats
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_qt5-quick1() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtDeclarative)')
|
||||
depends=('qt5-webkit' 'qt5-script')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtquick1
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-script() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtScript)')
|
||||
depends=('qt5-base')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtscript
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-svg() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtSvg)')
|
||||
depends=('qt5-base')
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qtsvg
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-tools() {
|
||||
pkgdesc=('A cross-platform application and UI framework (Development Tools, QtHelp)')
|
||||
depends=('qt5-webkit' 'desktop-file-utils' 'qt5-translations')
|
||||
optdepends=('qt5-doc: documentation')
|
||||
install='qt5-tools.install'
|
||||
conflicts=('qt')
|
||||
|
||||
cd ${_pkgfqn}/qttools
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# install missing icons and desktop files
|
||||
for icon in src/linguist/linguist/images/icons/linguist-*-32.png ; do
|
||||
size=$(echo $(basename ${icon}) | cut -d- -f2)
|
||||
install -p -D -m644 ${icon} \
|
||||
"${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/linguist.png"
|
||||
done
|
||||
|
||||
install -p -D -m644 src/assistant/assistant/images/assistant.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/32x32/apps/assistant.png"
|
||||
install -p -D -m644 src/assistant/assistant/images/assistant-128.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/assistant.png"
|
||||
install -p -D -m644 src/designer/src/designer/images/designer.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/designer.png"
|
||||
install -d "${pkgdir}/usr/share/applications"
|
||||
install -m644 "${srcdir}"/{linguist,designer,assistant}.desktop \
|
||||
"${pkgdir}/usr/share/applications/"
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt5-webkit() {
|
||||
pkgdesc=('A cross-platform application and UI framework (QtWebKit)')
|
||||
depends=('qt5-declarative' 'gstreamer0.10-base' 'icu')
|
||||
|
||||
cd ${_pkgfqn}/qtwebkit
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
|
||||
# Fix wrong path in pc file
|
||||
perl -pi -e "s, -L${srcdir}/?\S+,,g" "${pkgdir}"/usr/lib/pkgconfig/Qt5WebKit.pc
|
||||
}
|
8
extra/qt5/assistant.desktop
Normal file
8
extra/qt5/assistant.desktop
Normal file
|
@ -0,0 +1,8 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Assistant
|
||||
Comment=Shows Qt documentation and examples
|
||||
Exec=/usr/bin/assistant
|
||||
Icon=assistant
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Qt;Development;Documentation;
|
10
extra/qt5/designer.desktop
Normal file
10
extra/qt5/designer.desktop
Normal file
|
@ -0,0 +1,10 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Designer
|
||||
GenericName=Interface Designer
|
||||
Comment=Design GUIs for Qt applications
|
||||
Exec=/usr/bin/designer
|
||||
Icon=designer
|
||||
MimeType=application/x-designer;
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Qt;Development;
|
9
extra/qt5/linguist.desktop
Normal file
9
extra/qt5/linguist.desktop
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Linguist
|
||||
Comment=Add translations to Qt applications
|
||||
Exec=/usr/bin/linguist
|
||||
Icon=linguist
|
||||
MimeType=text/vnd.trolltech.linguist;application/x-linguist;
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Qt;Development;
|
11
extra/qt5/qt5-base.install
Normal file
11
extra/qt5/qt5-base.install
Normal file
|
@ -0,0 +1,11 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
12
extra/qt5/qt5-tools.install
Normal file
12
extra/qt5/qt5-tools.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
96
extra/qt5/use-python2.patch
Normal file
96
extra/qt5/use-python2.patch
Normal file
|
@ -0,0 +1,96 @@
|
|||
--- qt-everywhere-opensource-src-5.0.0/qtjsbackend/src/v8/v8.pri~ 2013-01-11 06:50:55.241495644 +0000
|
||||
+++ qt-everywhere-opensource-src-5.0.0/qtjsbackend/src/v8/v8.pri 2013-01-11 06:51:29.987894356 +0000
|
||||
@@ -303,7 +303,7 @@
|
||||
V8_EXPERIMENTAL_LIBRARY_FILES = \
|
||||
$$V8SRC/proxy.js \
|
||||
|
||||
-v8_js2c.commands = python $$V8DIR/tools/js2c.py $$V8_GENERATED_SOURCES_DIR/libraries.cpp CORE off
|
||||
+v8_js2c.commands = python2 $$V8DIR/tools/js2c.py $$V8_GENERATED_SOURCES_DIR/libraries.cpp CORE off
|
||||
v8_js2c.commands += $$V8SRC/macros.py ${QMAKE_FILE_IN}
|
||||
v8_js2c.output = $$V8_GENERATED_SOURCES_DIR/libraries.cpp
|
||||
v8_js2c.input = V8_LIBRARY_FILES
|
||||
@@ -314,7 +314,7 @@
|
||||
v8_js2c.name = generating[v8] ${QMAKE_FILE_IN}
|
||||
silent:v8_js2c.commands = @echo generating[v8] ${QMAKE_FILE_IN} && $$v8_js2c.commands
|
||||
|
||||
-v8_js2c_experimental.commands = python $$V8DIR/tools/js2c.py $$V8_GENERATED_SOURCES_DIR/experimental-libraries.cpp EXPERIMENTAL off
|
||||
+v8_js2c_experimental.commands = python2 $$V8DIR/tools/js2c.py $$V8_GENERATED_SOURCES_DIR/experimental-libraries.cpp EXPERIMENTAL off
|
||||
v8_js2c_experimental.commands += $$V8SRC/macros.py ${QMAKE_FILE_IN}
|
||||
v8_js2c_experimental.output = $$V8_GENERATED_SOURCES_DIR/experimental-libraries.cpp
|
||||
v8_js2c_experimental.input = V8_EXPERIMENTAL_LIBRARY_FILES
|
||||
--- qt-everywhere-opensource-src-5.0.0/qtwebkit/Source/JavaScriptCore/DerivedSources.pri~ 2013-01-09 11:29:16.452266719 +0000
|
||||
+++ qt-everywhere-opensource-src-5.0.0/qtwebkit/Source/JavaScriptCore/DerivedSources.pri 2013-01-09 11:30:18.188538725 +0000
|
||||
@@ -85,14 +85,14 @@
|
||||
retgen.output = RegExpJitTables.h
|
||||
retgen.script = $$PWD/create_regex_tables
|
||||
retgen.input = retgen.script
|
||||
-retgen.commands = python $$retgen.script > ${QMAKE_FILE_OUT}
|
||||
+retgen.commands = python2 $$retgen.script > ${QMAKE_FILE_OUT}
|
||||
GENERATORS += retgen
|
||||
|
||||
#GENERATOR: "KeywordLookup.h": decision tree used by the lexer
|
||||
klgen.output = KeywordLookup.h
|
||||
klgen.script = $$PWD/KeywordLookupGenerator.py
|
||||
klgen.input = KEYWORDLUT_FILES
|
||||
-klgen.commands = python $$klgen.script ${QMAKE_FILE_NAME} > ${QMAKE_FILE_OUT}
|
||||
+klgen.commands = python2 $$klgen.script ${QMAKE_FILE_NAME} > ${QMAKE_FILE_OUT}
|
||||
GENERATORS += klgen
|
||||
|
||||
EXTRACTOR_BINARY = LLIntOffsetsExtractor$$BIN_EXTENSION
|
||||
@@ -117,7 +117,7 @@
|
||||
disassembler.input = DISASSEMBLER_FILES
|
||||
disassembler.script = $$PWD/disassembler/udis86/itab.py
|
||||
disassembler.depends = $$DISASSEMBLER_DEPENDENCY
|
||||
- disassembler.commands = python $$disassembler.script ${QMAKE_FILE_NAME} --outputDir ${QMAKE_FUNC_FILE_OUT_PATH}
|
||||
+ disassembler.commands = python2 $$disassembler.script ${QMAKE_FILE_NAME} --outputDir ${QMAKE_FUNC_FILE_OUT_PATH}
|
||||
disassembler.CONFIG += no_link
|
||||
GENERATORS += disassembler
|
||||
}
|
||||
--- qt-everywhere-opensource-src-5.0.0/qtwebkit/Source/WebCore/DerivedSources.pri~ 2013-01-09 11:46:01.165612894 +0000
|
||||
+++ qt-everywhere-opensource-src-5.0.0/qtwebkit/Source/WebCore/DerivedSources.pri 2013-01-09 11:46:27.465404725 +0000
|
||||
@@ -779,7 +779,7 @@
|
||||
inspectorValidate.output = InspectorProtocolVersion.h
|
||||
inspectorValidate.input = INSPECTOR_JSON
|
||||
inspectorValidate.script = $$PWD/inspector/generate-inspector-protocol-version
|
||||
-inspectorValidate.commands = python $$inspectorValidate.script -o ${QMAKE_FILE_OUT} ${QMAKE_FILE_IN}
|
||||
+inspectorValidate.commands = python2 $$inspectorValidate.script -o ${QMAKE_FILE_OUT} ${QMAKE_FILE_IN}
|
||||
inspectorValidate.depends = $$PWD/inspector/generate-inspector-protocol-version
|
||||
inspectorValidate.add_output_to_sources = false
|
||||
GENERATORS += inspectorValidate
|
||||
@@ -787,7 +787,7 @@
|
||||
inspectorJSON.output = InspectorFrontend.cpp InspectorBackendDispatcher.cpp InspectorTypeBuilder.cpp
|
||||
inspectorJSON.input = INSPECTOR_JSON
|
||||
inspectorJSON.script = $$PWD/inspector/CodeGeneratorInspector.py
|
||||
-inspectorJSON.commands = python $$inspectorJSON.script $$PWD/inspector/Inspector.json --output_h_dir ${QMAKE_FUNC_FILE_OUT_PATH} --output_cpp_dir ${QMAKE_FUNC_FILE_OUT_PATH}
|
||||
+inspectorJSON.commands = python2 $$inspectorJSON.script $$PWD/inspector/Inspector.json --output_h_dir ${QMAKE_FUNC_FILE_OUT_PATH} --output_cpp_dir ${QMAKE_FUNC_FILE_OUT_PATH}
|
||||
inspectorJSON.depends = $$inspectorJSON.script
|
||||
GENERATORS += inspectorJSON
|
||||
|
||||
@@ -908,7 +908,7 @@
|
||||
entities.output = HTMLEntityTable.cpp
|
||||
entities.input = HTML_ENTITIES
|
||||
entities.script = $$PWD/html/parser/create-html-entity-table
|
||||
-entities.commands = python $$entities.script -o ${QMAKE_FILE_OUT} $$HTML_ENTITIES
|
||||
+entities.commands = python2 $$entities.script -o ${QMAKE_FILE_OUT} $$HTML_ENTITIES
|
||||
entities.clean = ${QMAKE_FILE_OUT}
|
||||
entities.depends = $$PWD/html/parser/create-html-entity-table
|
||||
GENERATORS += entities
|
||||
--- qt-everywhere-opensource-src-5.0.1/qtwebkit/Source/WebKit2/DerivedSources.pri~ 2013-02-10 13:48:49.800319915 +0000
|
||||
+++ qt-everywhere-opensource-src-5.0.1/qtwebkit/Source/WebKit2/DerivedSources.pri 2013-02-10 13:49:09.966867900 +0000
|
||||
@@ -120,14 +120,14 @@
|
||||
$$PWD/Scripts/webkit2/model.py \
|
||||
$$PWD/Scripts/webkit2/parser.py
|
||||
|
||||
-message_header_generator.commands = $${PYTHON} $${SOURCE_DIR}/WebKit2/Scripts/generate-messages-header.py ${QMAKE_FILE_IN} > ${QMAKE_FILE_OUT}
|
||||
+message_header_generator.commands = python2 $${SOURCE_DIR}/WebKit2/Scripts/generate-messages-header.py ${QMAKE_FILE_IN} > ${QMAKE_FILE_OUT}
|
||||
message_header_generator.input = MESSAGE_RECEIVERS
|
||||
message_header_generator.depends = $$SCRIPTS
|
||||
message_header_generator.output_function = message_header_generator_output
|
||||
message_header_generator.add_output_to_sources = false
|
||||
GENERATORS += message_header_generator
|
||||
|
||||
-message_receiver_generator.commands = $${PYTHON} $${SOURCE_DIR}/WebKit2/Scripts/generate-message-receiver.py ${QMAKE_FILE_IN} > ${QMAKE_FILE_OUT}
|
||||
+message_receiver_generator.commands = python2 $${SOURCE_DIR}/WebKit2/Scripts/generate-message-receiver.py ${QMAKE_FILE_IN} > ${QMAKE_FILE_OUT}
|
||||
message_receiver_generator.input = MESSAGE_RECEIVERS
|
||||
message_receiver_generator.depends = $$SCRIPTS
|
||||
message_receiver_generator.output_function = message_receiver_generator_output
|
Loading…
Reference in a new issue