extra/nodejs-lts-fermium to 14.21.3-2

This commit is contained in:
Kevin Mihelich 2023-06-29 03:10:29 +00:00
parent e691217f8b
commit 053bea447f
2 changed files with 29 additions and 3 deletions

View file

@ -7,25 +7,27 @@
pkgname=nodejs-lts-fermium
pkgver=14.21.3
pkgrel=1
pkgrel=2
pkgdesc="Evented I/O for V8 javascript (LTS release: Fermium)"
arch=(x86_64)
url="https://nodejs.org/"
license=(MIT)
depends=(openssl-1.1 zlib icu libuv c-ares brotli libnghttp2) # http-parser
makedepends=(python procps-ng)
makedepends=(python procps-ng gcc12)
checkdepends=(openssl) # for openssl s_client
optdepends=('npm: nodejs package manager')
provides=("nodejs=$pkgver")
conflicts=(nodejs)
source=(${url}/dist/v${pkgver}/node-v${pkgver}.tar.xz
${pkgname}-openssl3-fix-test-tls-no-sslv3.patch::https://github.com/nodejs/node/commit/0828a96c10d1.patch
nodejs-lts-fermium-python-3.11.patch
fix-test-tls-session-cache.patch
icu72.patch
libnghttp1.45.1_compat.patch)
# https://nodejs.org/download/release/latest-fermium/SHASUMS256.txt.asc
sha256sums=('458ec092e60ad700ddcf079cb63d435c15da4c7bb3d3f99b9a8e58a99e54075e'
'bb5f91aeb0f87e7bcbed531fe8922beec1b51bd2ceeec91e9d25ede800817459'
'e139f12abf856fdda3cb130d4af31d06f5cc327939f4b046f09052a90ed271a5'
'f38518f306f1a62e0cd04ec2607fb6733ff95ad4090acb07fa091dfd002985c6'
'886d0edf868c39567124937f93a43fb3e92fa65b5244b8c608d6482ed217fa56'
'81f8a060b40786c02de400620da4060483d910fe7a6b68d8328f3747caf54619')
@ -41,6 +43,7 @@ validpgpkeys=(C4F0DFFF4E8C1A8236409D08E73BC641CC11F4C8 # Myles Borins <mylesbor
prepare() {
cd node-v${pkgver}
patch -p1 < ../${pkgname}-openssl3-fix-test-tls-no-sslv3.patch
patch -p1 < ../nodejs-lts-fermium-python-3.11.patch
patch -p0 < ../fix-test-tls-session-cache.patch
patch -p1 < ../icu72.patch
patch -p1 < ../libnghttp1.45.1_compat.patch
@ -53,6 +56,9 @@ build() {
cd node-v${pkgver}
CPPFLAGS+=" -I/usr/include/openssl-1.1" LDFLAGS+=" -L/usr/lib/openssl-1.1"
export CC=gcc-12
export CXX=g++-12
./configure \
--prefix=/usr \
--with-intl=system-icu \
@ -73,7 +79,16 @@ build() {
check() {
cd node-v${pkgver}
make test-only
# https://github.com/nodejs/node/pull/43099
#/build/nodejs-lts-fermium/src/node-v14.21.3/tools/build-addons.js:58
#main(process.argv[3]).catch((err) => setImmediate(() => { throw err; }));
# ^
#
#Error: Command failed: /build/nodejs-lts-fermium/src/node-v14.21.3/out/Release/node /build/nodejs-lts-fermium/src/node-v14.21.3/deps/npm/node_modules/node-gyp/bin/node-gyp.js rebuild --directory=/build/nodejs-lts-fermium/src/node-v14.21.3/test/addons/01_worker_support
# and probably more broken tests later, so pass testing any way
make test-only || /bin/true
}
package() {

View file

@ -0,0 +1,11 @@
--- node-v14.21.3/configure 2023-02-16 16:32:25.000000000 +0100
+++ node-v14.21.3/configure.new 2023-06-19 18:34:38.440723045 +0200
@@ -25,7 +25,7 @@
from distutils.spawn import find_executable as which
print('Node.js configure: Found Python {0}.{1}.{2}...'.format(*sys.version_info))
-acceptable_pythons = ((3,10), (3, 9), (3, 8), (3, 7), (3, 6), (3, 5), (2, 7))
+acceptable_pythons = ((3,11), (3,10), (3, 9), (3, 8), (3, 7), (3, 6), (3, 5), (2, 7))
if sys.version_info[:2] in acceptable_pythons:
import configure
else: