mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed community/cpuburn
This commit is contained in:
parent
f9eb2fcffc
commit
0547d96619
2 changed files with 0 additions and 75 deletions
|
@ -1,34 +0,0 @@
|
||||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
|
||||||
# Contributor: Filip Wojciechowski, filip at loka dot pl
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - changes to build Cortex-A8/A9 tools
|
|
||||||
|
|
||||||
buildarch=4
|
|
||||||
|
|
||||||
pkgname=cpuburn
|
|
||||||
pkgver=1.4a
|
|
||||||
pkgrel=7
|
|
||||||
pkgdesc="CPU testing utilities in optimized assembler for maximum loading of CPUs"
|
|
||||||
arch=('x86_64')
|
|
||||||
url="https://launchpad.net/ubuntu/+source/cpuburn/"
|
|
||||||
license=('GPL')
|
|
||||||
depends=()
|
|
||||||
source=("https://launchpad.net/ubuntu/+archive/primary/+files/cpuburn_$pkgver.orig.tar.gz"
|
|
||||||
cpuburn.patch)
|
|
||||||
md5sums=('a9e1df40c660324eb08e91847cbc41b9'
|
|
||||||
'30f0eb72a0cb061955ab8dee8551d451')
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "$srcdir/$pkgname-$pkgver"
|
|
||||||
patch -Np1 -i ../cpuburn.patch
|
|
||||||
make -C ARM CC=gcc
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd "$srcdir/$pkgname-$pkgver"
|
|
||||||
install -Dm755 ARM/burnCortexA8 $pkgdir/usr/bin/burnCortexA8
|
|
||||||
install -Dm755 ARM/burnCortexA9 $pkgdir/usr/bin/burnCortexA9
|
|
||||||
install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
|
|
||||||
install -Dm644 Design "$pkgdir/usr/share/doc/$pkgname/Design"
|
|
||||||
}
|
|
|
@ -1,41 +0,0 @@
|
||||||
--- cpuburn-1.4.orig/burnP6.S
|
|
||||||
+++ cpuburn-1.4/burnP6.S
|
|
||||||
@@ -69,6 +69,7 @@
|
|
||||||
push %eax # *BSD syscall
|
|
||||||
int $0x80
|
|
||||||
#endif
|
|
||||||
+.data # Data allocation
|
|
||||||
.align 32,0
|
|
||||||
half: .long 0x7fffffff,0
|
|
||||||
e: .long 0xffffffff,0x3fdfffff
|
|
||||||
--- cpuburn-1.4.orig/burnK6.S
|
|
||||||
+++ cpuburn-1.4/burnK6.S
|
|
||||||
@@ -68,6 +68,7 @@
|
|
||||||
push %eax
|
|
||||||
int $0x80
|
|
||||||
#endif
|
|
||||||
+.data # Data allocation
|
|
||||||
.align 32,0
|
|
||||||
half: .long 0x7fffffff,0
|
|
||||||
e: .long 0xffffffff,0x3fdfffff
|
|
||||||
--- cpuburn-1.4.orig/Makefile
|
|
||||||
+++ cpuburn-1.4/Makefile
|
|
||||||
@@ -1,3 +1,3 @@
|
|
||||||
all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
|
|
||||||
.S:
|
|
||||||
- gcc -s -nostdlib -o $@ $<
|
|
||||||
+ gcc -m32 -s -nostdlib -static -o $@ $<
|
|
||||||
--- cpuburn-1.4.orig/burnK7.S
|
|
||||||
+++ cpuburn-1.4/burnK7.S
|
|
||||||
@@ -74,10 +74,9 @@
|
|
||||||
push %eax
|
|
||||||
int $0x80
|
|
||||||
#endif
|
|
||||||
+.data # Data allocation
|
|
||||||
.align 32,0
|
|
||||||
.fill 64
|
|
||||||
half: .long 0x7fffffff,0
|
|
||||||
e: .long 0xffffffff,0x3fdfffff
|
|
||||||
rt: .long 0xffffffff,0x3fefffff
|
|
||||||
-
|
|
||||||
-
|
|
Loading…
Reference in a new issue