mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt5-webkit-ng to tp5-4
This commit is contained in:
parent
4053e3dafe
commit
05488c38b5
2 changed files with 45 additions and 3 deletions
|
@ -6,7 +6,7 @@
|
|||
pkgname=qt5-webkit-ng
|
||||
_qtver=tp5
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=2
|
||||
pkgrel=4
|
||||
arch=(i686 x86_64)
|
||||
url='https://github.com/annulen/webkit/wiki'
|
||||
license=(GPL3 LGPL3 FDL custom)
|
||||
|
@ -17,9 +17,11 @@ optdepends=('gst-plugins-good: Webm codec support')
|
|||
conflicts=(qt5-webkit)
|
||||
provides=(qt5-webkit)
|
||||
source=("https://github.com/annulen/webkit/archive/qtwebkit-$pkgver.tar.gz"
|
||||
qtwebkit-ng-export-cmake-variables.patch::"https://github.com/annulen/webkit/commit/1467a945.patch")
|
||||
qtwebkit-ng-export-cmake-variables.patch::"https://github.com/annulen/webkit/commit/1467a945.patch"
|
||||
qt5-webkit-icu59.patch)
|
||||
sha256sums=('04bcb819675be6ebe0bba81519319dede6510512a73ef53d20465f91034ee719'
|
||||
'e7839c2eb2d4f998a6c7f6316f408bb8a948c769f8d987903368b0fe689558c6')
|
||||
'e7839c2eb2d4f998a6c7f6316f408bb8a948c769f8d987903368b0fe689558c6'
|
||||
'e1306e696ad7125fa00083aa966be0ea6fe6de555c9e1d119957f208f258edfe')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -27,6 +29,8 @@ prepare() {
|
|||
# Correctly export all needed cmake variables
|
||||
cd webkit-qtwebkit-$pkgver
|
||||
patch -p1 -i ../qtwebkit-ng-export-cmake-variables.patch
|
||||
# Fix build with ICU 59 (PLD linux)
|
||||
patch -p1 -i ../qt5-webkit-icu59.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
38
extra/qt5-webkit-ng/qt5-webkit-icu59.patch
Normal file
38
extra/qt5-webkit-ng/qt5-webkit-icu59.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2015-10-13 06:37:10.000000000 +0200
|
||||
+++ qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h 2017-04-24 12:26:42.495345570 +0200
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <stdbool.h>
|
||||
#endif
|
||||
#include <stddef.h> /* for size_t */
|
||||
+#include <uchar.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
@@ -43,7 +44,7 @@
|
||||
@typedef JSChar
|
||||
@abstract A Unicode character.
|
||||
*/
|
||||
- typedef unsigned short JSChar;
|
||||
+ typedef char16_t JSChar;
|
||||
#else
|
||||
typedef wchar_t JSChar;
|
||||
#endif
|
||||
--- qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h.orig 2015-10-13 06:37:12.000000000 +0200
|
||||
+++ qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h 2017-04-24 12:27:33.432011867 +0200
|
||||
@@ -31,6 +31,7 @@
|
||||
#ifndef __cplusplus
|
||||
#include <stdbool.h>
|
||||
#endif
|
||||
+#include <uchar.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
@@ -38,7 +39,7 @@
|
||||
|
||||
#if !defined(WIN32) && !defined(_WIN32) \
|
||||
&& !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
|
||||
- typedef unsigned short WKChar;
|
||||
+ typedef char16_t WKChar;
|
||||
#else
|
||||
typedef wchar_t WKChar;
|
||||
#endif
|
Loading…
Reference in a new issue