mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/firefox to 86.0-2
This commit is contained in:
parent
aa492557aa
commit
05522639a2
3 changed files with 43 additions and 4 deletions
|
@ -9,10 +9,10 @@ Subject: [PATCH] Use remoting name for GDK application names
|
|||
2 files changed, 6 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||
index df53d2f8358ba..684105058af38 100644
|
||||
index 9c7cb46079b5f..dfd4321f52742 100644
|
||||
--- a/toolkit/xre/nsAppRunner.cpp
|
||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||
@@ -4184,11 +4184,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
@@ -4225,11 +4225,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
// consistently.
|
||||
|
||||
// Set program name to the one defined in application.ini.
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Jeff Muizelaar <jmuizelaar@mozilla.com>
|
||||
Date: Thu, 25 Feb 2021 13:18:47 +0000
|
||||
Subject: [PATCH] Bug 1694670. Fix the OOB check in write_u32/u16. r=aosmond,
|
||||
a=RyanVM
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D106362
|
||||
---
|
||||
gfx/qcms/src/iccread.rs | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gfx/qcms/src/iccread.rs b/gfx/qcms/src/iccread.rs
|
||||
index 0113e17aff3e6..f1107d50a86b6 100644
|
||||
--- a/gfx/qcms/src/iccread.rs
|
||||
+++ b/gfx/qcms/src/iccread.rs
|
||||
@@ -229,16 +229,16 @@ fn read_uInt16Number(mem: &mut MemSource, offset: usize) -> uInt16Number {
|
||||
read_u16(mem, offset)
|
||||
}
|
||||
pub fn write_u32(mem: &mut [u8], offset: usize, value: u32) {
|
||||
- if offset <= mem.len() - std::mem::size_of_val(&value) {
|
||||
+ if offset > mem.len() - std::mem::size_of_val(&value) {
|
||||
panic!("OOB");
|
||||
}
|
||||
let mem = mem.as_mut_ptr();
|
||||
unsafe {
|
||||
std::ptr::write_unaligned(mem.add(offset) as *mut u32, cpu_to_be32(value));
|
||||
}
|
||||
}
|
||||
pub fn write_u16(mem: &mut [u8], offset: usize, value: u16) {
|
||||
- if offset <= mem.len() - std::mem::size_of_val(&value) {
|
||||
+ if offset > mem.len() - std::mem::size_of_val(&value) {
|
||||
panic!("OOB");
|
||||
}
|
||||
let mem = mem.as_mut_ptr();
|
|
@ -11,7 +11,7 @@ highmem=1
|
|||
|
||||
pkgname=firefox
|
||||
pkgver=86.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=(x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
|
@ -30,12 +30,14 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
|
|||
arm.patch
|
||||
build-arm-libopus.patch
|
||||
0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
0002-Bug-1694670.-Fix-the-OOB-check-in-write_u32-u16.-r-a.patch
|
||||
$pkgname.desktop)
|
||||
sha256sums=('c3ac474a2cf6a8e31a962f57c7357dbe67b5088b6aceea9980f25ce7a99b58dd'
|
||||
'SKIP'
|
||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
|
||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||
'9b4b36d525be7920413017a4e4300cf881836353d06f874637d368e3d293316d'
|
||||
'ea8c317a50e84829c3b94ad73b5b9cfb8a08a73e406f8bd9bfb7730854611539'
|
||||
'7ca4d5270c5bf4505ab867807bfff65b30cd1d0d8c50b76b406a3233ae3b5ad3'
|
||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
|
||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||
|
||||
|
@ -59,6 +61,9 @@ prepare() {
|
|||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
||||
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/69821
|
||||
patch -Np1 -i ../0002-Bug-1694670.-Fix-the-OOB-check-in-write_u32-u16.-r-a.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
|
Loading…
Reference in a new issue