mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
alarm/xbmc-rbp fix includes
This commit is contained in:
parent
58ee703330
commit
056056c03c
2 changed files with 30 additions and 1 deletions
|
@ -27,7 +27,8 @@ install="xbmc.install"
|
||||||
source=("https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
|
source=("https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
|
||||||
'xbmc.service'
|
'xbmc.service'
|
||||||
'polkit.rules'
|
'polkit.rules'
|
||||||
'panasonicCEC.patch')
|
'panasonicCEC.patch'
|
||||||
|
'fix_libnfs.patch')
|
||||||
|
|
||||||
sha256sums=('663b99f3e196ead51d90f06ccfa864b4e5ade385dfc5972acb0f854d525f2903'
|
sha256sums=('663b99f3e196ead51d90f06ccfa864b4e5ade385dfc5972acb0f854d525f2903'
|
||||||
'189804742290946424a401163e351f5158bfd1b71e5b86b864589254b13f9571'
|
'189804742290946424a401163e351f5158bfd1b71e5b86b864589254b13f9571'
|
||||||
|
@ -47,6 +48,9 @@ prepare() {
|
||||||
# http://archlinuxarm.org/forum/viewtopic.php?f=31&t=6376&start=10
|
# http://archlinuxarm.org/forum/viewtopic.php?f=31&t=6376&start=10
|
||||||
patch -Np1 -i ${srcdir}/panasonicCEC.patch
|
patch -Np1 -i ${srcdir}/panasonicCEC.patch
|
||||||
|
|
||||||
|
# Fix missing headers includes
|
||||||
|
patch -Np1 -i ${srcdir}/fix_libnfs.patch
|
||||||
|
|
||||||
# fix samba4 libsmbclient.h location
|
# fix samba4 libsmbclient.h location
|
||||||
sed -e 's/\(#include \)<libsmbclient\.h>/\1<samba-4.0\/libsmbclient\.h>/g' \
|
sed -e 's/\(#include \)<libsmbclient\.h>/\1<samba-4.0\/libsmbclient\.h>/g' \
|
||||||
-i xbmc/filesystem/SmbFile.cpp \
|
-i xbmc/filesystem/SmbFile.cpp \
|
||||||
|
|
25
alarm/xbmc-rbp/fix_libnfs.patch
Normal file
25
alarm/xbmc-rbp/fix_libnfs.patch
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
diff --git a/xbmc/filesystem/NFSDirectory.cpp b/xbmc/filesystem/NFSDirectory.cpp
|
||||||
|
index 85084a5..8efa7bf 100644
|
||||||
|
--- a/xbmc/filesystem/NFSDirectory.cpp
|
||||||
|
+++ b/xbmc/filesystem/NFSDirectory.cpp
|
||||||
|
@@ -37,6 +37,7 @@
|
||||||
|
using namespace XFILE;
|
||||||
|
using namespace std;
|
||||||
|
#include <limits.h>
|
||||||
|
+#include <nfsc/libnfs-zdr.h>
|
||||||
|
#include <nfsc/libnfs-raw-mount.h>
|
||||||
|
#include <nfsc/libnfs-raw-nfs.h>
|
||||||
|
|
||||||
|
diff --git a/xbmc/filesystem/NFSFile.cpp b/xbmc/filesystem/NFSFile.cpp
|
||||||
|
index 479f3fe..2aeea32 100644
|
||||||
|
--- a/xbmc/filesystem/NFSFile.cpp
|
||||||
|
+++ b/xbmc/filesystem/NFSFile.cpp
|
||||||
|
@@ -32,6 +32,7 @@
|
||||||
|
#include "network/DNSNameCache.h"
|
||||||
|
#include "threads/SystemClock.h"
|
||||||
|
|
||||||
|
+#include <nfsc/libnfs-zdr.h>
|
||||||
|
#include <nfsc/libnfs-raw-mount.h>
|
||||||
|
|
||||||
|
#ifdef TARGET_WINDOWS
|
||||||
|
|
Loading…
Reference in a new issue