extra/qemu to 2.12.0-2

This commit is contained in:
Kevin Mihelich 2018-07-11 19:49:16 +00:00
parent 1e80abaa06
commit 05752c5981
2 changed files with 34 additions and 1 deletions

View file

@ -13,7 +13,7 @@ pkgname=(qemu qemu-headless qemu-arch-extra qemu-headless-arch-extra
qemu-block-{iscsi,rbd,gluster} qemu-guest-agent)
pkgdesc="A generic and open source machine emulator and virtualizer"
pkgver=2.12.0
pkgrel=1
pkgrel=2
arch=(x86_64)
license=(GPL2 LGPL2.1)
url="http://wiki.qemu.org/"
@ -22,11 +22,13 @@ _headlessdeps=(gnutls libpng libaio jemalloc xfsprogs libnfs
depends=(virglrenderer sdl2 vte3 libpulse "${_headlessdeps[@]}")
makedepends=(spice-protocol python2 ceph libiscsi glusterfs)
source=(https://download.qemu.org/qemu-$pkgver.tar.xz{,.sig}
fix_card_passthru.patch
qemu-ga.service
65-kvm.rules
allow_elf64.patch)
sha256sums=('e69301f361ff65bf5dabd8a19196aeaa5613c1b5ae1678f0823bdf50e7d5c6fc'
'SKIP'
'4edd2d91509d4e6c641aa20487b3725f0ae2283c57d80a707995b29b0a2b8ae9'
'c39bcde4a09165e64419fd2033b3532378bba84d509d39e2d51694d44c1f8d88'
'a66f0e791b16b03b91049aac61a25950d93e962e1b2ba64a38c6ad7f609b532c'
'59751f1ed26ea61b2a37ebee4be6979e584a450b611282138a0893aa9173e2e4')
@ -47,6 +49,7 @@ prepare() {
sed -i 's/vte-2\.90/vte-2.91/g' configure
patch -p1 < ../allow_elf64.patch
patch -p1 < ../fix_card_passthru.patch
}
build() {

View file

@ -0,0 +1,30 @@
commit e58d64a16abc2304c4dcb644411eb9580bf63b1e
Author: Marc-André Lureau <marcandre.lureau@redhat.com>
Date: Tue May 15 17:30:39 2018 +0200
ccid-card-passthru: fix regression in realize()
Since cc847bfd16d894fd8c1a2ce25f31772f6cdbbc74, CCID card-passthru
fails to intialize, because it changed a debug line to an error,
probably by mistake. Change it back to a DPRINTF debug.
(solves Boxes creating VM with smartcard passthru failing to start)
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-id: 20180515153039.27514-1-marcandre.lureau@redhat.com
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
diff --git a/hw/usb/ccid-card-passthru.c b/hw/usb/ccid-card-passthru.c
index 7684db0cb3..25fb19b0d7 100644
--- a/hw/usb/ccid-card-passthru.c
+++ b/hw/usb/ccid-card-passthru.c
@@ -345,7 +345,7 @@ static void passthru_realize(CCIDCardState *base, Error **errp)
card->vscard_in_pos = 0;
card->vscard_in_hdr = 0;
if (qemu_chr_fe_backend_connected(&card->cs)) {
- error_setg(errp, "ccid-card-passthru: initing chardev");
+ DPRINTF(card, D_INFO, "ccid-card-passthru: initing chardev");
qemu_chr_fe_set_handlers(&card->cs,
ccid_card_vscard_can_read,
ccid_card_vscard_read,