community/strongswan to 5.6.0-2

This commit is contained in:
Kevin Mihelich 2017-10-13 23:51:55 +00:00
parent c9ae9df1c7
commit 0616203906
2 changed files with 26 additions and 7 deletions

View file

@ -14,14 +14,19 @@
pkgname=strongswan
pkgver=5.6.0
pkgrel=1
pkgrel=2
pkgdesc="open source IPsec implementation"
url='http://www.strongswan.org'
license=("GPL2")
arch=('i686' 'x86_64')
makedepends=('curl' 'gmp' 'iproute2' 'openssl' 'sqlite' 'libcap' 'libsystemd'
'systemd' 'pam' 'libnm-glib' 'python' 'ruby' 'mariadb' 'python-setuptools')
depends=('curl' 'gmp' 'iproute2' 'openssl' 'sqlite' 'libcap' 'libsystemd' 'pam')
makedepends=('curl' 'gmp' 'iproute2' 'openssl' 'sqlite' 'libcap' 'libsystemd' 'systemd' 'pam' 'libnm-glib')
optdepends=('libnm-glib: for networkmanager support')
optdepends=('libnm-glib: for networkmanager support'
'mariadb: MySQL support'
'ruby: Ruby support'
'python: Python support'
'openldap: LDAP support')
backup=(
etc/ipsec.conf
etc/ipsec.secrets
@ -41,13 +46,15 @@ vici.conf,x509.conf,xauth-eap.conf,xauth-generic.conf,xcbc.conf,unity.conf,curve
source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2"
"https://download.strongswan.org/strongswan-${pkgver}.tar.bz2.sig"
'configure_ac.patch'
'stdint.patch'
)
validpgpkeys=("948F158A4E76A27BF3D07532DF42C170B34DBA77")
sha512sums=('9362069a01c3642e62864d88fdb409a3c7514bf7c92cbe36e552c6a80915119cf5bb91c39592aab2d15b562684a0628a764e4fa7636d3b5fd2ebaf165c0ce649'
'SKIP'
'0e2c818f2f620410dda949d9016a4c1a686bf2946acb3b42a729b2376c077f4dad6762fe8d2f736c213c4895c1fbd60c0d654a1c36f72d06f58ba7cff635bc74')
'0e2c818f2f620410dda949d9016a4c1a686bf2946acb3b42a729b2376c077f4dad6762fe8d2f736c213c4895c1fbd60c0d654a1c36f72d06f58ba7cff635bc74'
'd24ec19bca6faa56c4f29f6d0b785fc70406850d2884b75982b0ca4f285119799f199a9f7dac3e2929a4380fb444d53b939f242c62d0630d5112bf4ac531ca80')
# We don't build libipsec because it would get loaded before kernel-netlink and netkey, which
# would case processing to be handled in user space. Also, the plugin is experimental. If you need it,
@ -55,6 +62,7 @@ sha512sums=('9362069a01c3642e62864d88fdb409a3c7514bf7c92cbe36e552c6a80915119cf5b
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -l < "${srcdir}/configure_ac.patch"
patch -p1 -l < "${srcdir}/stdint.patch"
autoreconf
}
@ -77,13 +85,13 @@ build() {
--enable-eap-gtc --enable-eap-aka --enable-eap-aka-3gpp2 \
--enable-eap-mschapv2 --enable-eap-radius --enable-xauth-eap \
--enable-ha --enable-vici --enable-swanctl --enable-systemd --enable-ext-auth \
--disable-mysql --disable-ldap --enable-cmd --enable-forecast --enable-connmark \
--enable-mysql --enable-ldap --enable-cmd --enable-forecast --enable-connmark \
--enable-eap-ttls --enable-radattr --enable-xauth-pam --enable-xauth-noauth \
--enable-eap-dynamic --enable-eap-peap --enable-eap-tls --enable-chapoly --enable-unity \
--with-capabilities=libcap --enable-newhope --enable-ntru --enable-mgf1 --enable-sha3 \
--enable-bliss --enable-dnscert \
--enable-nm --enable-agent
# --enable-ruby-gems --enable-python-eggs
--enable-nm --enable-agent --enable-bypass-lan \
--enable-ruby-gems --enable-python-eggs
make
}

View file

@ -0,0 +1,11 @@
--- strongswan-5.6.0-orig/src/libstrongswan/utils/utils/memory.h 2017-08-14 02:48:41.000000000 -0400
+++ strongswan-5.6.0/src/libstrongswan/utils/utils/memory.h 2017-09-12 01:15:29.690527667 -0400
@@ -14,6 +14,8 @@
* for more details.
*/
+#include <stdint.h> /* for uintptr_t */
+
/**
* @defgroup memory_i memory
* @{ @ingroup utils_i