mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/clisp to 2.49-6
This commit is contained in:
parent
2f96e8b355
commit
0636b95c7f
3 changed files with 28 additions and 6 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname=clisp
|
||||
pkgver=2.49
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
pkgdesc="ANSI Common Lisp interpreter, compiler and debugger"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
|
@ -18,16 +18,23 @@ makedepends=('ffcall')
|
|||
options=('!makeflags' '!emptydirs')
|
||||
source=("http://downloads.sourceforge.net/sourceforge/clisp/clisp-${pkgver}.tar.bz2"
|
||||
'clisp-gcc5.patch'
|
||||
"patch-modules_readline_readline.lisp"
|
||||
'clisp-arm.patch')
|
||||
md5sums=('1962b99d5e530390ec3829236d168649'
|
||||
'f576778ab7fc879d9509decfd559d32e'
|
||||
'e3008f96f6cd3059717d4a930b8c0e9c'
|
||||
'5b29c9301ab7c1b683da70c2f805609f'
|
||||
'f52b37840eaae76410f14f1adc8a00e2')
|
||||
|
||||
prepare() {
|
||||
cd $srcdir/${pkgname}-${pkgver}
|
||||
patch -Np1 -i ../clisp-gcc5.patch
|
||||
patch -Np0 -i ../patch-modules_readline_readline.lisp
|
||||
patch -p0 -i ../clisp-arm.patch
|
||||
ulimit -s unlimited
|
||||
|
||||
# https://sourceforge.net/p/clisp/clisp/ci/cebd289dfc19de4aa504113dfcb0284657787430/
|
||||
# http://hg.slitaz.org/wok/rev/d5a39f30f9f1#l2.28
|
||||
sed -i 's/clisp\.cons\.org/clisp.org/' src/cfgunix.lisp
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
case "$XCC_GCC_VERSION" in
|
||||
# gcc 2.7 introduced an annoying warning, but gcc 2.8 has a workaround:
|
||||
- 2.[8-9]* | 3.* | 4.* | egcs-2.*)
|
||||
+ 2.[8-9]* | 3.* | 4.* | 5.* | egcs-2.*)
|
||||
+ 2.[8-9]* | 3.* | 4.* | 5.* | 6.* | 7.* | 8.* | egcs-2.*)
|
||||
XCFLAGS=$XCFLAGS' -Wno-sign-compare -Wno-format-nonliteral'
|
||||
;;
|
||||
* ) ;;
|
||||
|
@ -14,7 +14,7 @@
|
|||
case "$XCC_GCC_VERSION" in
|
||||
# g++ 3.4 introduced an annoying warning, but has a workaround:
|
||||
- 3.[4-9]* | 4.*)
|
||||
+ 3.[4-9]* | 4.* | 5.*)
|
||||
+ 3.[4-9]* | 4.* | 5.* | 6.* | 7.* | 8.*)
|
||||
XCFLAGS=$XCFLAGS' -Wno-invalid-offsetof'
|
||||
;;
|
||||
* ) ;;
|
||||
|
@ -23,7 +23,7 @@
|
|||
# also fixed through the specs file of some Linux distributions).
|
||||
XCFLAGS=$XCFLAGS' -O2 -fexpensive-optimizations -fno-strength-reduce' ;;
|
||||
- 2.3.[2-9]* | 2.[4-9]* | 3.* | 4.* | egcs-2.*)
|
||||
+ 2.3.[2-9]* | 2.[4-9]* | 3.* | 4.* | 5.* | egcs-2.*)
|
||||
+ 2.3.[2-9]* | 2.[4-9]* | 3.* | 4.* | 5.* | 6.* | 7.* | 8.* | egcs-2.*)
|
||||
XCFLAGS=$XCFLAGS' -O2 -fexpensive-optimizations' ;;
|
||||
* )
|
||||
XCFLAGS=$XCFLAGS' -O' ;;
|
||||
|
@ -32,7 +32,7 @@
|
|||
fi # with_debug
|
||||
case "$XCC_GCC_VERSION" in
|
||||
- 3* | 4*)
|
||||
+ 3* | 4* | 5*)
|
||||
+ 3* | 4* | 5* | 6* | 7* | 8*)
|
||||
# When not optimizing on linux, or with Apple's gcc 4 on MacOS X,
|
||||
# or with GCC 4 when "gcc -Os" is used:
|
||||
# C_CODE_ALIGNMENT is wrong. &EVAL-WHEN = 0x806D512
|
||||
|
|
15
extra/clisp/patch-modules_readline_readline.lisp
Normal file
15
extra/clisp/patch-modules_readline_readline.lisp
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-modules_readline_readline.lisp,v 1.1 2016/09/20 14:10:25 wiz Exp $
|
||||
|
||||
rl_readline_state changed from int to unsigned long in readline-7.0.
|
||||
|
||||
--- modules/readline/readline.lisp.orig 2010-01-06 22:18:03.000000000 +0000
|
||||
+++ modules/readline/readline.lisp
|
||||
@@ -424,7 +424,7 @@ name in ~/.inputrc. This is preferred wa
|
||||
"The version of this incarnation of the readline library, e.g., 0x0402."))
|
||||
(def-c-var gnu-readline-p (:name "rl_gnu_readline_p") (:type int)
|
||||
(:documentation "True if this is real GNU readline."))
|
||||
-(def-c-var readline-state (:name "rl_readline_state") (:type int)
|
||||
+(def-c-var readline-state (:name "rl_readline_state") (:type ulong)
|
||||
(:documentation "Flags word encapsulating the current readline state."))
|
||||
(def-c-var editing-mode (:name "rl_editing_mode") (:type int)
|
||||
(:documentation "Says which editing mode readline is currently using.
|
Loading…
Reference in a new issue