extra/libvpx fixes

This commit is contained in:
Kevin Mihelich 2015-04-21 12:40:23 +00:00
parent fc87508131
commit 06b1b996fd
2 changed files with 42 additions and 9 deletions

View file

@ -4,7 +4,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building
# - disable neon
# - disable neon and neon-asm
pkgname=libvpx
pkgver=1.4.0
@ -19,7 +19,7 @@ provides=('libvpx.so')
source=($pkgname::git+http://code.google.com/p/webm.libvpx#tag=v$pkgver
fix-armhf-link.patch)
md5sums=('SKIP'
'3d54d292cdb5752f199e9551fbc1ac14')
'a2d92d01ecc336fe81682daa8a7fdafa')
prepare() {
cd $pkgname
@ -37,7 +37,7 @@ build() {
--enable-pic \
--disable-install-docs \
--disable-install-srcs \
--disable-neon
--disable-neon --disable-neon-asm
make
}

View file

@ -1,5 +1,5 @@
diff --git a/build/make/configure.sh b/build/make/configure.sh
index 25c9f80..396e5b0 100644
index 25c9f80..1675044 100644
--- a/build/make/configure.sh
+++ b/build/make/configure.sh
@@ -623,10 +623,14 @@ process_common_toolchain() {
@ -29,7 +29,26 @@ index 25c9f80..396e5b0 100644
*x86_64*|*amd64*)
tgt_isa=x86_64
;;
@@ -831,7 +839,6 @@ process_common_toolchain() {
@@ -811,7 +819,7 @@ process_common_toolchain() {
soft_enable neon
;;
armv7|armv7s)
- soft_enable neon
+ #soft_enable neon
# Only enable neon_asm when neon is also enabled.
enabled neon && soft_enable neon_asm
# If someone tries to force it through, die.
@@ -825,13 +833,16 @@ process_common_toolchain() {
soft_enable media
soft_enable fast_unaligned
;;
+ armv5)
+ soft_enable media
+ soft_enable fast_unaligned
+ ;;
esac
asm_conversion_cmd="cat"
case ${tgt_cc} in
gcc)
@ -37,7 +56,7 @@ index 25c9f80..396e5b0 100644
link_with_cc=gcc
setup_gnu_toolchain
arch_int=${tgt_isa##armv}
@@ -839,13 +846,6 @@ process_common_toolchain() {
@@ -839,13 +850,6 @@ process_common_toolchain() {
check_add_asflags --defsym ARCHITECTURE=${arch_int}
tune_cflags="-mtune="
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
@ -51,12 +70,26 @@ index 25c9f80..396e5b0 100644
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
@@ -854,6 +854,8 @@ EOF
@@ -854,8 +858,8 @@ EOF
check_add_asflags -mfpu=neon
fi
else
- check_add_cflags -march=${tgt_isa}
- check_add_asflags -march=${tgt_isa}
+ check_add_cflags -march=${tgt_isa} -mfloat-abi=${float_abi}
+ check_add_asflags -march=${tgt_isa} -mfloat-abi=${float_abi}
check_add_cflags -march=${tgt_isa}
check_add_asflags -march=${tgt_isa}
fi
enabled debug && add_asflags -g
diff --git a/configure b/configure
index f3708f9..7fb89ca 100755
--- a/configure
+++ b/configure
@@ -97,6 +97,7 @@ EOF
# all_platforms is a list of all supported target platforms. Maintain
# alphabetically by architecture, generic-gnu last.
+all_platforms="${all_platforms} armv5te-linux-gcc"
all_platforms="${all_platforms} armv6-darwin-gcc"
all_platforms="${all_platforms} armv6-linux-rvct"
all_platforms="${all_platforms} armv6-linux-gcc"