mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
linux-odroid: kernel-CVE-2016-0728.patch
This commit is contained in:
parent
718ac68354
commit
0710459533
2 changed files with 85 additions and 1 deletions
|
@ -8,7 +8,7 @@ pkgname=('linux-odroid-x' 'linux-odroid-x2' 'linux-odroid-u2' 'linux-headers-odr
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.8
|
||||
pkgver=${_basekernel}.13.30
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('armv7h')
|
||||
url="http://github.com/hardkernel/linux/"
|
||||
license=('GPL2')
|
||||
|
@ -19,6 +19,7 @@ source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
|||
'add-gcc5-support.patch'
|
||||
'gcc5-use-std89.patch'
|
||||
'rtl8812_to_v4_3_14_and_enable_rtl8821.patch.xz'
|
||||
'kernel-CVE-2016-0728.patch'
|
||||
'config_x'
|
||||
'config_x2'
|
||||
'config_u2')
|
||||
|
@ -26,6 +27,7 @@ md5sums=('9eec4534016d3bd8dc6fb372ec7ab574'
|
|||
'2873a50f4311434fd07d7d52bccaade7'
|
||||
'407619b134dd00b453ebba9f23dcabf5'
|
||||
'c6d56cc8134dd25d97d0416ef98a3dfe'
|
||||
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||
'98decab218ac0e376f2bd9b435f5634e'
|
||||
'28e8fe0251cecf2e05798f2ac4cce06a'
|
||||
'67abbc5dd3f81a03012230423618ec1e')
|
||||
|
@ -36,6 +38,7 @@ prepare() {
|
|||
patch -Np1 -i ${srcdir}/add-gcc5-support.patch
|
||||
patch -Np1 -i ${srcdir}/gcc5-use-std89.patch
|
||||
patch -p1 -i ${srcdir}/rtl8812_to_v4_3_14_and_enable_rtl8821.patch
|
||||
patch -p1 -i ${srcdir}/kernel-CVE-2016-0728.patch
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
|
81
core/linux-odroid/kernel-CVE-2016-0728.patch
Normal file
81
core/linux-odroid/kernel-CVE-2016-0728.patch
Normal file
|
@ -0,0 +1,81 @@
|
|||
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
|
||||
From: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
||||
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
|
||||
|
||||
This fixes CVE-2016-0728.
|
||||
|
||||
If a thread is asked to join as a session keyring the keyring that's already
|
||||
set as its session, we leak a keyring reference.
|
||||
|
||||
This can be tested with the following program:
|
||||
|
||||
#include <stddef.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
#include <keyutils.h>
|
||||
|
||||
int main(int argc, const char *argv[])
|
||||
{
|
||||
int i = 0;
|
||||
key_serial_t serial;
|
||||
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (keyctl(KEYCTL_SETPERM, serial,
|
||||
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
for (i = 0; i < 100; i++) {
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
}
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
If, after the program has run, there something like the following line in
|
||||
/proc/keys:
|
||||
|
||||
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
||||
|
||||
with a usage count of 100 * the number of times the program has been run,
|
||||
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
||||
has been garbage collected, then the problem is fixed.
|
||||
|
||||
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Signed-off-by: David Howells <dhowells@redhat.com>
|
||||
Acked-by: Don Zickus <dzickus@redhat.com>
|
||||
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||
Acked-by: Jarod Wilson <jarod@redhat.com>
|
||||
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
||||
---
|
||||
security/keys/process_keys.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
||||
index a3f85d2..e6d50172 100644
|
||||
--- a/security/keys/process_keys.c
|
||||
+++ b/security/keys/process_keys.c
|
||||
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
|
||||
ret = PTR_ERR(keyring);
|
||||
goto error2;
|
||||
} else if (keyring == new->session_keyring) {
|
||||
+ key_put(keyring);
|
||||
ret = 0;
|
||||
goto error2;
|
||||
}
|
||||
--
|
||||
cgit v0.12
|
||||
|
Loading…
Reference in a new issue