community/unbound to 1.13.2-1

This commit is contained in:
Kevin Mihelich 2021-08-25 12:46:31 +00:00
parent 5dca81bf9c
commit 075a9121c1
2 changed files with 40 additions and 16 deletions

View file

@ -8,8 +8,8 @@
# - disable LTO (--disable-flto)
pkgname=unbound
pkgver=1.13.1
pkgrel=2
pkgver=1.13.2
pkgrel=1
pkgdesc="Validating, recursive, and caching DNS resolver"
arch=(x86_64)
url="https://unbound.net/"
@ -24,19 +24,19 @@ optdepends=(
provides=(libunbound.so)
backup=(etc/${pkgname}/${pkgname}.conf)
source=("https://unbound.net/downloads/${pkgname}-${pkgver}.tar.gz"{,.asc}
unbound-fix-libpython-linking.patch
"${pkgname}-1.13.2-fix_libpython_linking.patch"
${pkgname}-sysusers.conf
${pkgname}-tmpfiles.conf
${pkgname}-trusted-key.hook)
sha512sums=('f4d26dca28dbcc33a5e65a55147fa01077c331292e88b6a87798cb6c3d4edb0515015d131fd893c92b74d22d9998a640f0adce404e6192d61ebe69a6a599287c'
sha512sums=('1e89441446e7a25c6a49bded645f8b348c1758c3be54e3a986041cb1f00c45d152fd469dc52666fb820574db9d51b16f1627dc8afcb9519508d4833ca358191a'
'SKIP'
'e810992fbf645bb804edd218881809cf894fccffcae0668ee40d053354ea6bbab5f3abf2e82fadc0c47877fcfe13263b6423f8ebd2a27e38aedb9c512085eb63'
'836ec61c79f91e429feed7fca7b8df64c0233aa621b3c49011ad39854b231bbc7ab73408785278b0b8b7d1038bd2c9c57548d973ce796cccdb575307ff5318c6'
'ef71d4e9b0eb0cc602d66bd0573d9424578fe33ef28a852c582d56f0fd34fdd63046c365ef7aed8b84a461b81254240af7ad3fd539da72f9587817d21bd6c585'
'6b1849ae9d7cf427f6fa6cd0590e8f8c3f06210d2d6795e543b0f325a9e866db0f5db2275a29fa90f688783c0dd16f19c8a49a9817d5f5444e13f8f2df3ff712'
'613826cdf5ab6e77f2805fa2aa65272508dcd11090add1961b3df6dfac3b67db016bc9f45fbcf0ef0de82b2d602c153d5263a488027a6cf13a72680b581b266d')
b2sums=('5fabb9205773a1983842e41cf7a4d6c3878fa8beb7c8ccc71ae1edf7738cb9506c3d7bb32cf887b305317ca695bf876d9f5bf9aeb0129b0e9e926d437b3e6eb3'
b2sums=('71806edc86b323ff1f9f2d7bd3f699b15da2cd1cfefe9ca6008d74915dd6c7b45690026fb0244531ae563a3ca1b142f21fc8aed97ba4bb0015d8ab9196ff045a'
'SKIP'
'e80e46e841e5ebcf261c2e1a5f4bb61d6f182afd95b3ce6609ac9c466a94a48eefe11adfb8d57a670896ea78dd71394ff75d2233d8efc6a03d621b049ab991bb'
'b2b7f27f1d339ea8ded8733cb71cbdb0d4b11c925a412fe78a0848c80fa401fc381a1c041b85879999a2c3f273021e6ff0bd748af479d914df2eb4b94614b821'
'292a3c2e5fde292a03b6c9b2ddabd5089f52e73b50a404c3d9f54c1a43184924b661a21eea61cc521c594c1005a3b40b630fa585a38195c61298f9b24b248b92'
'd3951006b43068be904c6b91a9e0563d56228225854e12b40abbdd4ba9b47338e97265837297a6de879acbc8051bb749163f9457683f5e12fc29ac2e7b687fd3'
'd28785390eb6c125bd26ca11f097fe8864b080482157deeb7c70e9bee47ff2844abaed574db59a7c152ed3ec0acba05cfee4c3751f7a9f553320b064578f86c7')
@ -48,7 +48,7 @@ prepare() {
sed '/# trust-anchor-file:/c\\ttrust-anchor-file: /etc/unbound/trusted-key.key' \
-i doc/example.conf.in
# backport https://github.com/NLnetLabs/unbound/pull/511
patch -p1 < ../unbound-fix-libpython-linking.patch
patch -Np1 -i ../"${pkgname}-1.13.2-fix_libpython_linking.patch"
autoreconf -vfi
}

View file

@ -1,4 +1,28 @@
From 98087a051e657c4604050c3d1e6735950b9ea76f Mon Sep 17 00:00:00 2001
From: Chih-Hsuan Yen <yan12125@gmail.com>
Date: Fri, 23 Jul 2021 13:23:05 +0800
Subject: [PATCH] - Reduce unnecessary linking
- Link to libpython only when needed, fixes #242
When pyunbound is enabled while pythonmodule is not (i.e., ./configure
--without-pythonmodule --with-pyunbound), only the Python library
_unbound.so uses Python functions, and main programs (unbound,
unbound-anchor, ...) and libunbound.so do not. This patch removes
unneeded linking.
- Link the Python library _unbound.so to Python only. _unbound.so does
not directly use libraries used by libunbound. This patch removes
unneeded linking mentioned in [1]
[1] https://github.com/NLnetLabs/unbound/pull/511#issuecomment-886072003
---
Makefile.in | 3 ++-
configure.ac | 12 ++++++++----
2 files changed, 10 insertions(+), 5 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index ff5dc8fae..58413d7a5 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -61,6 +61,7 @@ PYTHON_CPPFLAGS=-I. @PYTHON_CPPFLAGS@
@ -9,35 +33,35 @@ diff --git a/Makefile.in b/Makefile.in
LIBOBJS=@LIBOBJS@
# filter out ctime_r from compat obj.
LIBOBJ_WITHOUT_CTIME=@LIBOBJ_WITHOUT_CTIME@
@@ -474,7 +475,7 @@ libunbound/python/libunbound_wrap.c: $(srcdir)/libunbound/python/libunbound.i un
@@ -476,7 +477,7 @@ libunbound/python/libunbound_wrap.c: $(srcdir)/libunbound/python/libunbound.i un
# Pyunbound python unbound wrapper
_unbound.la: libunbound_wrap.lo libunbound.la
- $(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -module -avoid-version -no-undefined -shared -o $@ libunbound_wrap.lo -rpath $(PYTHON_SITE_PKG) -L. -L.libs -lunbound
+ $(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -module -avoid-version -no-undefined -shared -o $@ libunbound_wrap.lo -rpath $(PYTHON_SITE_PKG) -L. -L.libs -lunbound $(LIBS) $(PYTHON_LIBS)
- $(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -module -avoid-version -no-undefined -shared -o $@ libunbound_wrap.lo -rpath $(PYTHON_SITE_PKG) -L. -L.libs libunbound.la $(LIBS)
+ $(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -module -avoid-version -no-undefined -shared -o $@ libunbound_wrap.lo -rpath $(PYTHON_SITE_PKG) -L. -L.libs libunbound.la $(PYTHON_LIBS)
util/config_file.c: util/configparser.h
util/configlexer.c: $(srcdir)/util/configlexer.lex util/configparser.h
diff --git a/configure.ac b/configure.ac
index fe911723c..0fc1e00a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -699,11 +699,17 @@ if test x_$ub_test_python != x_no; then
@@ -699,11 +699,15 @@ if test x_$ub_test_python != x_no; then
AC_SUBST(PY_MAJOR_VERSION)
# Have Python
AC_DEFINE(HAVE_PYTHON,1,[Define if you have Python libraries and header files.])
- if test -n "$LIBS"; then
- LIBS="$PYTHON_LDFLAGS $LIBS"
- else
- LIBS="$PYTHON_LDFLAGS"
+ if test x_$ub_with_pythonmod != x_no; then
+ if test -n "$LIBS"; then
+ LIBS="$PYTHON_LDFLAGS $LIBS"
+ else
+ LIBS="$PYTHON_LDFLAGS"
+ fi
+ PYTHON_LIBS=""
else
- LIBS="$PYTHON_LDFLAGS"
+ PYTHON_LIBS="$PYTHON_LDFLAGS"
fi
+ PYTHON_LIBS="$PYTHON_LDFLAGS"
+ AC_SUBST(PYTHON_LIBS)
if test -n "$CPPFLAGS"; then
CPPFLAGS="$CPPFLAGS $PYTHON_CPPFLAGS"