mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
add aur/xrdp for Socaltom
This commit is contained in:
parent
c8fb95c6aa
commit
07623d8a40
4 changed files with 98 additions and 0 deletions
27
aur/xrdp/0001-Fix-the-build-with-automake-1.13.patch
Normal file
27
aur/xrdp/0001-Fix-the-build-with-automake-1.13.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
From 698a95edb64941495b781451a1e323155fe87c5f Mon Sep 17 00:00:00 2001
|
||||
From: Nuno Araujo <nuno.araujo@russo79.com>
|
||||
Date: Wed, 16 Jan 2013 09:27:03 +0100
|
||||
Subject: [PATCH] Fix the build with automake 1.13
|
||||
|
||||
In Automake 1.13, the long-deprecated macro AM_CONFIG_HEADER (deprecated
|
||||
since 2002) has been removed in favour of AC_CONFIG_HEADERS.
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index fad886d..83176e4 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
AC_PREREQ(2.59)
|
||||
AC_INIT([xrdp], [0.6.0], [xrdp-devel@lists.sourceforge.net])
|
||||
-AM_CONFIG_HEADER(config_ac.h:config_ac-h.in)
|
||||
+AC_CONFIG_HEADERS(config_ac.h:config_ac-h.in)
|
||||
AM_INIT_AUTOMAKE([1.6 foreign])
|
||||
AC_PROG_CC
|
||||
AC_C_CONST
|
||||
--
|
||||
1.8.1.1
|
||||
|
42
aur/xrdp/PKGBUILD
Normal file
42
aur/xrdp/PKGBUILD
Normal file
|
@ -0,0 +1,42 @@
|
|||
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
|
||||
# Maintainer: techryda <techryda at silentdome dot com>
|
||||
# Contributor: Mathias R. <pu154r@overlinux.org>
|
||||
pkgname=xrdp
|
||||
pkgver=0.6.0
|
||||
pkgrel=6
|
||||
pkgdesc="An open source remote desktop protocol (RDP) server"
|
||||
url="http://xrdp.sourceforge.net/"
|
||||
arch=('arm' 'armv6h' 'armv7h')
|
||||
license=('GPL')
|
||||
depends=('tigervnc')
|
||||
source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-v$pkgver.tar.gz"
|
||||
'xrdp.service'
|
||||
'xrdp-sesman.service'
|
||||
'0001-Fix-the-build-with-automake-1.13.patch')
|
||||
md5sums=('b2577256b5a34bd72849cd40375c92de'
|
||||
'0cb760b3e8a34f9bdf4daa871444d74c'
|
||||
'58eb44bdc7ca5bb436d6fd66826f9b0f'
|
||||
'dd097b937263565e34b6526560ac00a3')
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-v${pkgver}"
|
||||
patch < ../0001-Fix-the-build-with-automake-1.13.patch
|
||||
# Fix path in xrdp.sh file
|
||||
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${pkgname}-v${pkgver}"
|
||||
./bootstrap
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${pkgname}-v${pkgver}"
|
||||
make DESTDIR="$pkgdir" install
|
||||
cd ${pkgdir}
|
||||
# Install systemd service files
|
||||
mkdir -p usr/lib/systemd/system
|
||||
cp ${srcdir}/*.service usr/lib/systemd/system
|
||||
}
|
15
aur/xrdp/xrdp-sesman.service
Normal file
15
aur/xrdp/xrdp-sesman.service
Normal file
|
@ -0,0 +1,15 @@
|
|||
[Unit]
|
||||
Description=xrdp session manager
|
||||
After=syslog.target network.target
|
||||
StopWhenUnneeded=true
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
PIDFile=/var/run/xrdp-sesman.pid
|
||||
EnvironmentFile=/etc/xrdp/xrdp.ini
|
||||
ExecStart=/usr/bin/xrdp-sesman $SESMAN_OPTIONS
|
||||
ExecStop=/usr/bin/xrdp-sesman $SESMAN_OPTIONS --kill
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
|
14
aur/xrdp/xrdp.service
Normal file
14
aur/xrdp/xrdp.service
Normal file
|
@ -0,0 +1,14 @@
|
|||
[Unit]
|
||||
Description=xrdp daemon
|
||||
Requires=xrdp-sesman.service
|
||||
After=syslog.target network.target xrdp-sesman.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
PIDFile=/var/run/xrdp.pid
|
||||
EnvironmentFile=/etc/xrdp/xrdp.ini
|
||||
ExecStart=/usr/bin/xrdp $XRDP_OPTIONS
|
||||
ExecStop=/usr/bin/xrdp $XRDP_OPTIONS --kill
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
Loading…
Reference in a new issue