mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/vtk to 9.3.0-3
This commit is contained in:
parent
c4435d2f23
commit
0764990ded
5 changed files with 10 additions and 204 deletions
|
@ -1,7 +1,7 @@
|
|||
pkgbase = vtk
|
||||
pkgdesc = Software system for 3D computer graphics, image processing, and visualization
|
||||
pkgver = 9.3.0
|
||||
pkgrel = 2
|
||||
pkgrel = 3
|
||||
url = https://www.vtk.org/
|
||||
arch = x86_64
|
||||
license = BSD
|
||||
|
@ -107,17 +107,9 @@ pkgbase = vtk
|
|||
options = staticlibs
|
||||
source = https://www.vtk.org//files/release/9.3/VTK-9.3.0.tar.gz
|
||||
source = vtk-occt.patch
|
||||
source = https://github.com/Kitware/VTK/commit/1233ceec.patch
|
||||
source = https://github.com/Kitware/VTK/commit/4d8283bc.patch
|
||||
source = fmt-10.patch
|
||||
source = 47ceab32.patch
|
||||
source = fdb93d3e9.patch
|
||||
source = https://gitlab.kitware.com/vtk/vtk/-/commit/5055371e.patch
|
||||
sha256sums = fdc7b9295225b34e4fdddc49cd06e66e94260cb00efee456e0f66568c9681be9
|
||||
sha256sums = df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011
|
||||
sha256sums = 5f662d5052dc07ee43d690c5ffdc1880c5c6c4236945c03a40177ae3a6dc5917
|
||||
sha256sums = 82eae5864704b1d955c905d75e565380829b05bb6300c4614da2d19834e15014
|
||||
sha256sums = c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe
|
||||
sha256sums = d9e9eb9ebadd3ca066729732165f4420b0df10759defc17458a1b0b71255b36e
|
||||
sha256sums = 79eae9ff919a36f79ba91916fdc8b2c7312713ad13a6972a6d38220f229b1887
|
||||
sha256sums = 54861a8667c505fedb96b49283521ce62af62148b629e953bbd065f831f02d04
|
||||
|
||||
pkgname = vtk
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
From 47ceab32e3af877045a96ef58c1f30ab72bf8260 Mon Sep 17 00:00:00 2001
|
||||
From: Caitlin Ross <caitlin.ross@kitware.com>
|
||||
Date: Tue, 6 Dec 2022 10:49:34 -0600
|
||||
Subject: [PATCH] adios debug mode deprecated
|
||||
|
||||
---
|
||||
fides/DataSetWriter.cxx | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/fides/DataSetWriter.cxx b/fides/DataSetWriter.cxx
|
||||
index 94c79126..6ca00bdd 100644
|
||||
--- a/fides/DataSetWriter.cxx
|
||||
+++ b/fides/DataSetWriter.cxx
|
||||
@@ -71,9 +71,9 @@ public:
|
||||
: DataSets(dataSets)
|
||||
, OutputFileName(fname)
|
||||
#ifdef FIDES_USE_MPI
|
||||
- , Adios(MPI_COMM_WORLD, adios2::DebugON)
|
||||
+ , Adios(MPI_COMM_WORLD)
|
||||
#else
|
||||
- , Adios(true)
|
||||
+ , Adios()
|
||||
#endif
|
||||
, FieldsToWriteSet(false)
|
||||
{
|
||||
--
|
||||
GitLab
|
||||
|
|
@ -16,7 +16,7 @@
|
|||
pkgname=vtk
|
||||
# May need bootstrapping on upgrades due to circular vtk <-> opencascade dependency
|
||||
pkgver=9.3.0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="Software system for 3D computer graphics, image processing, and visualization"
|
||||
arch=(x86_64)
|
||||
url="https://www.vtk.org/"
|
||||
|
@ -126,33 +126,17 @@ optdepends=(
|
|||
options=(staticlibs)
|
||||
source=(${url}/files/release/${pkgver%.*}/VTK-${pkgver}.tar.gz
|
||||
vtk-occt.patch
|
||||
https://github.com/Kitware/VTK/commit/1233ceec.patch
|
||||
https://github.com/Kitware/VTK/commit/4d8283bc.patch
|
||||
fmt-10.patch
|
||||
47ceab32.patch
|
||||
fdb93d3e9.patch)
|
||||
https://gitlab.kitware.com/vtk/vtk/-/commit/5055371e.patch)
|
||||
sha256sums=('fdc7b9295225b34e4fdddc49cd06e66e94260cb00efee456e0f66568c9681be9'
|
||||
'df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011'
|
||||
'5f662d5052dc07ee43d690c5ffdc1880c5c6c4236945c03a40177ae3a6dc5917'
|
||||
'82eae5864704b1d955c905d75e565380829b05bb6300c4614da2d19834e15014'
|
||||
'c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe'
|
||||
'd9e9eb9ebadd3ca066729732165f4420b0df10759defc17458a1b0b71255b36e'
|
||||
'79eae9ff919a36f79ba91916fdc8b2c7312713ad13a6972a6d38220f229b1887')
|
||||
'54861a8667c505fedb96b49283521ce62af62148b629e953bbd065f831f02d04')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname^^}-${pkgver}
|
||||
# We have a patched fmt
|
||||
# sed -i "s|8.1.0|9.0.0|" ThirdParty/fmt/CMakeLists.txt
|
||||
sed -i "s|3.9.0|5.1.0|" ThirdParty/fast_float/CMakeLists.txt
|
||||
|
||||
patch -Np1 -i "$srcdir"/vtk-occt.patch
|
||||
|
||||
# patch -p1 -i ../1233ceec.patch # Fix build with GCC 13
|
||||
# patch -p1 -i ../4d8283bc.patch
|
||||
# patch -p1 -i ../fmt-10.patch # Fix build with fmt 10
|
||||
# Fix build with adios2 2.9
|
||||
# patch -d ThirdParty/fides/vtkfides -p1 < ../47ceab32.patch
|
||||
# patch -p1 < ../fdb93d3e9.patch
|
||||
patch -Np1 -i ../5055371e.patch # Fix link to PDAL 2.6
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -194,13 +178,14 @@ build() {
|
|||
-DVTK_MODULE_ENABLE_VTK_FiltersOpenTURNS=NO \
|
||||
-DVTK_MODULE_ENABLE_VTK_RenderingZSpace=NO \
|
||||
-DOpenGL_GL_PREFERENCE=LEGACY \
|
||||
-DVTK_IGNORE_CMAKE_CXX11_CHECKS=ON \
|
||||
-Wno-dev
|
||||
# -DFIDES_USE_EXTERNAL_RAPIDJSON=ON \
|
||||
make -C build
|
||||
cmake --build build
|
||||
}
|
||||
|
||||
package() {
|
||||
make -C build DESTDIR="${pkgdir}" install
|
||||
DESTDIR="${pkgdir}" cmake --install build
|
||||
|
||||
# Move the vtk.jar to the arch-specific location…
|
||||
install -dv "${pkgdir}"/usr/share/java/vtk
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
From fdb93d3e9d447b9dd6ce5c77aca18396cf9b6aa3 Mon Sep 17 00:00:00 2001
|
||||
From: Vicente Bolea <vicente.bolea@kitware.com>
|
||||
Date: Mon, 3 Apr 2023 12:58:58 -0400
|
||||
Subject: [PATCH] Update IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
|
||||
|
||||
---
|
||||
IO/ADIOS2/vtkADIOS2CoreImageReader.cxx | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx b/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
|
||||
index 5d58905a881..3ce039345a9 100644
|
||||
--- a/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
|
||||
+++ b/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
|
||||
@@ -361,12 +361,12 @@ bool vtkADIOS2CoreImageReader::OpenAndReadMetaData()
|
||||
vtkMPICommunicator* comm =
|
||||
static_cast<vtkMPICommunicator*>(this->Controller->GetCommunicator());
|
||||
|
||||
- this->Impl->Adios.reset(new adios2::ADIOS(*comm->GetMPIComm()->GetHandle(), adios2::DebugON));
|
||||
+ this->Impl->Adios.reset(new adios2::ADIOS(*comm->GetMPIComm()->GetHandle()));
|
||||
#else
|
||||
// Make sure the ADIOS subsystem is initialized before processing any
|
||||
// sort of request.
|
||||
|
||||
- this->Impl->Adios.reset(new adios2::ADIOS(adios2::DebugON));
|
||||
+ this->Impl->Adios.reset(new adios2::ADIOS());
|
||||
// Before processing any request, read the meta data first
|
||||
#endif
|
||||
}
|
||||
--
|
||||
GitLab
|
||||
|
|
@ -1,112 +0,0 @@
|
|||
diff --git a/ThirdParty/ioss/vtkioss/Ioss_Field.C b/ThirdParty/ioss/vtkioss/Ioss_Field.C
|
||||
index 62e1bdc93e..f0cafabca6 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/Ioss_Field.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/Ioss_Field.C
|
||||
@@ -249,14 +249,14 @@ bool Ioss::Field::equal_(const Ioss::Field &rhs, bool quiet) const
|
||||
|
||||
if (this->type_ != rhs.type_) {
|
||||
if (!quiet) {
|
||||
- fmt::print(Ioss::OUTPUT(), "\n\tFIELD type mismatch ({} v. {})", this->type_, rhs.type_);
|
||||
+ fmt::print(Ioss::OUTPUT(), "\n\tFIELD type mismatch ({} v. {})", static_cast<int>(this->type_), static_cast<int>(rhs.type_));
|
||||
}
|
||||
return false;
|
||||
}
|
||||
|
||||
if (this->role_ != rhs.role_) {
|
||||
if (!quiet) {
|
||||
- fmt::print(Ioss::OUTPUT(), "\n\tFIELD role mismatch ({} v. {})", this->role_, rhs.role_);
|
||||
+ fmt::print(Ioss::OUTPUT(), "\n\tFIELD role mismatch ({} v. {})", static_cast<int>(this->role_), static_cast<int>(rhs.role_));
|
||||
}
|
||||
return false;
|
||||
}
|
||||
diff --git a/ThirdParty/ioss/vtkioss/Ioss_GroupingEntity.C b/ThirdParty/ioss/vtkioss/Ioss_GroupingEntity.C
|
||||
index 89158bec9d..db60449d73 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/Ioss_GroupingEntity.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/Ioss_GroupingEntity.C
|
||||
@@ -356,7 +356,7 @@ bool Ioss::GroupingEntity::equal_(const Ioss::GroupingEntity &rhs, const bool qu
|
||||
if (this->entityState != rhs.entityState) {
|
||||
if (!quiet) {
|
||||
fmt::print(Ioss::OUTPUT(), "GroupingEntity: entityState mismatch ([] vs. [])\n",
|
||||
- this->entityState, rhs.entityState);
|
||||
+ static_cast<int>(this->entityState), static_cast<int>(rhs.entityState));
|
||||
}
|
||||
return false;
|
||||
}
|
||||
diff --git a/ThirdParty/ioss/vtkioss/Ioss_Region.C b/ThirdParty/ioss/vtkioss/Ioss_Region.C
|
||||
index dcf53bea99..79816c16f9 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/Ioss_Region.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/Ioss_Region.C
|
||||
@@ -1622,7 +1622,7 @@ namespace Ioss {
|
||||
"\n\nERROR: The entity named '{}' of type {} which is being aliased to '{}' does "
|
||||
"not exist in "
|
||||
"region '{}'.\n",
|
||||
- db_name, type, alias, name());
|
||||
+ db_name, static_cast<int>(type), alias, name());
|
||||
IOSS_ERROR(errmsg);
|
||||
}
|
||||
|
||||
diff --git a/ThirdParty/ioss/vtkioss/cgns/Iocgns_DatabaseIO.C b/ThirdParty/ioss/vtkioss/cgns/Iocgns_DatabaseIO.C
|
||||
index e4bc3c8ff1..6207990255 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/cgns/Iocgns_DatabaseIO.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/cgns/Iocgns_DatabaseIO.C
|
||||
@@ -1332,7 +1332,7 @@ namespace Iocgns {
|
||||
"ERROR: CGNS: Zone {} adjacency data is not correct type. Require "
|
||||
"Abutting1to1 and PointList."
|
||||
" {}\t{}\t{}",
|
||||
- zone, connect_type, ptset_type, donor_ptset_type);
|
||||
+ zone, static_cast<int>(connect_type), static_cast<int>(ptset_type), static_cast<int>(donor_ptset_type));
|
||||
IOSS_ERROR(errmsg);
|
||||
}
|
||||
|
||||
diff --git a/ThirdParty/ioss/vtkioss/cgns/Iocgns_Utils.C b/ThirdParty/ioss/vtkioss/cgns/Iocgns_Utils.C
|
||||
index 3768535aa7..bf115394a6 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/cgns/Iocgns_Utils.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/cgns/Iocgns_Utils.C
|
||||
@@ -269,7 +269,7 @@ namespace {
|
||||
fmt::print(Ioss::WARNING(),
|
||||
"On sideset '{}', the boundary condition type was previously set to {}"
|
||||
" which does not match the current value of {}. It will keep the old value.\n",
|
||||
- sset->name(), old_bocotype, bocotype);
|
||||
+ sset->name(), static_cast<int>(old_bocotype), static_cast<int>(bocotype));
|
||||
}
|
||||
}
|
||||
else {
|
||||
diff --git a/ThirdParty/ioss/vtkioss/exodus/Ioex_BaseDatabaseIO.C b/ThirdParty/ioss/vtkioss/exodus/Ioex_BaseDatabaseIO.C
|
||||
index d488007982..aef98f430a 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/exodus/Ioex_BaseDatabaseIO.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/exodus/Ioex_BaseDatabaseIO.C
|
||||
@@ -762,7 +762,7 @@ namespace Ioex {
|
||||
std::ostringstream errmsg;
|
||||
fmt::print(errmsg,
|
||||
"Error: Failed to find entity of type {} with id {} for assembly {}.\n",
|
||||
- type, assembly.entity_list[j], assem->name());
|
||||
+ static_cast<int>(type), assembly.entity_list[j], assem->name());
|
||||
IOSS_ERROR(errmsg);
|
||||
}
|
||||
|
||||
diff --git a/ThirdParty/ioss/vtkioss/exodus/Ioex_DatabaseIO.C b/ThirdParty/ioss/vtkioss/exodus/Ioex_DatabaseIO.C
|
||||
index 98de3a2acf..71a2c9f724 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/exodus/Ioex_DatabaseIO.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/exodus/Ioex_DatabaseIO.C
|
||||
@@ -1760,7 +1760,7 @@ namespace Ioex {
|
||||
fmt::print(errmsg,
|
||||
"INTERNAL ERROR: Invalid setting for `split_type` {}. Something is wrong "
|
||||
"in the Ioex::DatabaseIO class. Please report.\n",
|
||||
- split_type);
|
||||
+ static_cast<int>(split_type));
|
||||
IOSS_ERROR(errmsg);
|
||||
}
|
||||
assert(elem_topo != nullptr);
|
||||
diff --git a/ThirdParty/ioss/vtkioss/exodus/Ioex_SuperElement.C b/ThirdParty/ioss/vtkioss/exodus/Ioex_SuperElement.C
|
||||
index bf3261fd6c..ec7ee7544e 100644
|
||||
--- a/ThirdParty/ioss/vtkioss/exodus/Ioex_SuperElement.C
|
||||
+++ b/ThirdParty/ioss/vtkioss/exodus/Ioex_SuperElement.C
|
||||
@@ -242,7 +242,7 @@ int64_t Ioex::SuperElement::internal_get_field_data(const Ioss::Field &field, vo
|
||||
}
|
||||
}
|
||||
else {
|
||||
- fmt::print(Ioss::WARNING(), "{} '{}'. Unknown input field '{}'", type(), name(),
|
||||
+ fmt::print(Ioss::WARNING(), "{} '{}'. Unknown input field '{}'", static_cast<int>(type()), name(),
|
||||
field.get_name());
|
||||
return -4;
|
||||
}
|
Loading…
Reference in a new issue